Copyrights and Credits

This publication is protected by Copyright and permission should be obtained from the publisher prior to any prohibited reproduction, storage in a retrieval system, or transmission in any form or by any means electronic, mechanical, photocopying, recording, or otherwise.

This work is protected by United States copyright laws and is provided solely for the use of instructors in teaching their courses and assessing student learning. Dissemination or sale of any part of this work (including on the World Wide Web) will destroy the integrity of the work is not permitted. The work and materials from it should never be made available to students except by instructors using the accompanying text in their classes. All recipients of this work are expected to abide by these restrictions and to honor the intended pedagogical purposes and the needs of other instructors who rely on these materials.

TestGen is a registered trademark of Tamarack Software, Inc.

TestGen, QuizMaster, and associated Tamarack products are licensed and distributed by Pearson Education.

TestGen Program, QuizMaster Program, and TestGen Plug-in (Windows and Macintosh versions), (c)1997-2010 Tamarack Software, Inc.

The NeoAccess software contained within this program is proprietary to NeoLogic Systems, Inc. and is licensed to the TestGen Program and QuizMaster Program (Windows and Macintosh versions). NeoLogic Systems, Inc. makes no warranties whatsoever, expressed or implied, regarding this product, including warranties with respect to its merchantability or its fitness for any particular purpose.

Copyright © Biit Inc 1996-1998. All Rights Reserved.

Biit disclaims all warranties with regard to this software including all implied warranties of merchantability and fitness. In no event shall Biit be liable for any special, indirect or consequential damages or any damages whatsoever resulting from loss of use, data or profits, whether in an action of contract, negligence or other tortious action, arising out of or in connection with the use or performance of this software.

Copyright © FairCom Corporation 1992-2000. All Rights Reserved.

The TestGen software is based in part on the work of the Independent JPEG Group.


The Independent JPEG Group makes NO WARRANTY or representation, either express or implied, with respect to this software, its quality, accuracy, merchantability, or fitness for a particular purpose. This software is provided "AS IS", and you, its user, assume the entire risk as to its quality and accuracy. The Independent JPEG Group accepts NO LIABILITY for damages of any kind.

Windows, Windows XP, Windows Vista, and Word are registered trademarks of Microsoft Corporation in the United States and/or other countries.

Apple, Macintosh, iMac, and Mac OS are registered trademarks of Apple Computer, Inc., registered in the U.S.A. and other countries.

Safari is a trademark of Apple Computer, Inc.

Internet Explorer is a registered trademark of Microsoft Corporation in the United States and/or other countries.

Netscape Navigator is a registered trademark of Netscape Communications Corporation in the United States and other countries.

Firefox is a registered trademark of Mozilla Foundation.

Blackboard is a registered trademark of Blackboard, Inc.
WebCT and WebCT Vista are registered trademarks of WebCT, a Blackboard Company.

ANGEL is a registered trademark of ANGEL Learning.

Adobe, Macromedia, Acrobat, and Flash are registered trademarks of Adobe Systems Incorporated.

Pentium is a registered trademark of Intel Corporation.
# Table of Contents

**Copyrights and Credits** ................................................................................................................. ii

**Getting Started** ............................................................................................................................... 1

- About TestGen................................................................................................................................. 1
- System Requirements ..................................................................................................................... 2
- Installing and Starting TestGen ....................................................................................................... 3
- Downloading from the TestGen Web Site ....................................................................................... 5
- Installing the TestGen Plug-in ......................................................................................................... 6
- Using and Changing a Password .................................................................................................... 7
- Product Support Options ................................................................................................................. 8
- About QuizMaster .......................................................................................................................... 10

**Menus, Toolbars, and Work Areas** .............................................................................................. 13

- The TestGen Menu Bar ................................................................................................................. 13
- The Standard Toolbar .................................................................................................................... 16
- The Text Formatting Toolbar ......................................................................................................... 18
- The Equation Editing Toolbar ........................................................................................................ 19
- The Library and Editing Work Areas.............................................................................................. 21

**Creating Tests** .............................................................................................................................. 23

- Choosing a Test Type ................................................................................................................... 23
- Creating Tests for Paper ............................................................................................................... 24
- Creating Tests for the Web ............................................................................................................ 25
- Saving and Opening Tests ............................................................................................................ 29
- Changing One Test Type to Another ............................................................................................. 31

**Choosing Test Questions** ............................................................................................................. 32

- Building a Test Step-by-Step ........................................................................................................ 32
- Choosing Questions from a Testbank ............................................................................................ 34
- Using the TestGen Wizard ............................................................................................................ 38
- Getting Test Summary Information ............................................................................................... 41
- Using a Filtered Testbank View ................................................................................................... 42
Test Gen 7.4 Help

Editing Test Content ................................................................................................................... 44
Modifying Questions and Answers on Tests.................................................................................. 44
Inserting International Characters .................................................................................................. 47
Inserting Symbols and Templates .................................................................................................. 48
Inserting Graphics.......................................................................................................................... 49
Adding New Questions to Tests ..................................................................................................... 51
Adding Notes to Tests ................................................................................................................... 57
Changing Question Types ............................................................................................................. 58

Working with Questions .............................................................................................................. 59
Pinning Questions and Answer Choices on Tests ........................................................................ 59
Rearranging Questions on Tests.................................................................................................. 61
Sorting Questions on Tests ........................................................................................................... 62
Scrambling Questions and Answer Choices on Tests ................................................................. 65
Assigning Point Values on Tests .................................................................................................. 66
Locking/Unlocking Number Values on Tests ............................................................................... 67
Changing Question Number Style for Tests ............................................................................... 68

Adjusting Test Page Layout and Display ...................................................................................... 69
Using Question Type Headers on Tests ..................................................................................... 69
Using Page Headers and Footers on Tests .................................................................................. 71
Inserting Page Numbers and Date on Tests ............................................................................... 72
Inserting Page Breaks on Tests .................................................................................................. 73
Setting Question Display Options for Tests................................................................................ 74
Changing Answer Display Options for Tests ............................................................................... 76
Changing Descriptor Display Options for Tests ......................................................................... 78
Adjusting Workspace and Question Spacing .............................................................................. 80

Testbank Library ............................................................................................................................ 81
Opening and Closing Testbanks .................................................................................................. 81
Changing Answer Display for Testbanks ..................................................................................... 83
Changing Descriptor Display for Testbanks ................................................................................ 84
Getting Testbank Summary Information ..................................................................................... 86
Switching Between Question View and ID View ........................................................................ 87
Show or Hide the Testbank Library .............................................................................................. 89
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Managing Library Content</td>
<td>90</td>
</tr>
<tr>
<td><strong>Resource Library</strong></td>
<td>93</td>
</tr>
<tr>
<td>Using Resource Library Templates</td>
<td>93</td>
</tr>
<tr>
<td><strong>Printing and Exporting</strong></td>
<td>96</td>
</tr>
<tr>
<td>Printing Tests</td>
<td>96</td>
</tr>
<tr>
<td>Exporting Tests to Text or RTF Files</td>
<td>99</td>
</tr>
<tr>
<td>Exporting HTML Practice Tests</td>
<td>101</td>
</tr>
<tr>
<td>Exporting Tests to HTML Pages</td>
<td>103</td>
</tr>
<tr>
<td>Exporting Tests to PDF Files</td>
<td>105</td>
</tr>
<tr>
<td>Exporting Tests for Blackboard</td>
<td>106</td>
</tr>
<tr>
<td>Exporting Tests for WebCT 3.x/4.x</td>
<td>108</td>
</tr>
<tr>
<td>Exporting Tests for WebCT CE and Vista</td>
<td>111</td>
</tr>
<tr>
<td>Printing Testbanks</td>
<td>114</td>
</tr>
<tr>
<td><strong>Editing Testbanks</strong></td>
<td>117</td>
</tr>
<tr>
<td>Enabling and Disabling Testbank Editing</td>
<td>117</td>
</tr>
<tr>
<td>Modifying Testbanks</td>
<td>118</td>
</tr>
<tr>
<td>Editing Multiple-Choice and Bimodal Questions</td>
<td>121</td>
</tr>
<tr>
<td>Editing True/False Questions</td>
<td>124</td>
</tr>
<tr>
<td>Editing Short Answer and Essay Questions</td>
<td>125</td>
</tr>
<tr>
<td>Editing Vocabulary Questions</td>
<td>127</td>
</tr>
<tr>
<td>Editing Matching Questions</td>
<td>128</td>
</tr>
<tr>
<td>Adding Explanations</td>
<td>130</td>
</tr>
<tr>
<td>Adding Comments</td>
<td>131</td>
</tr>
<tr>
<td>Using the Ruler and Tabs</td>
<td>132</td>
</tr>
<tr>
<td>Using the Properties Window</td>
<td>133</td>
</tr>
<tr>
<td>Using Shared Instructions</td>
<td>135</td>
</tr>
<tr>
<td>Using Shared Descriptors</td>
<td>139</td>
</tr>
<tr>
<td>Save As New Testbank</td>
<td>143</td>
</tr>
<tr>
<td><strong>Math Related Editing</strong></td>
<td>144</td>
</tr>
<tr>
<td>Using Symbols and Templates</td>
<td>144</td>
</tr>
<tr>
<td>Inserting Mathematical Graphs</td>
<td>147</td>
</tr>
<tr>
<td>Defining and Inserting Variables</td>
<td>156</td>
</tr>
</tbody>
</table>
Calculating New Values for Variables ................................................................. 160
Defining Evaluated Answers for Short Answer Questions ........................................ 162
**Other Advanced Editing** ..................................................................................... 168
Managing Graphics ...................................................................................................... 168
Inserting Tables ............................................................................................................ 172
Using the Macro Editor ................................................................................................ 174
Using Global Style Replacement ............................................................................... 175
Setting Default Styles for Tests ............................................................................. 176
Setting Default Styles for Testbanks ....................................................................... 178
Starting a New Testbank ........................................................................................... 180
**TestGen Tools** ........................................................................................................ 185
Checking Spelling for Tests and Testbanks ............................................................ 185
Using Find and Replace ............................................................................................ 186
Setting TestGen Preferences .................................................................................. 187
Resetting TestGen Defaults .................................................................................... 190
Using Keyboard Shortcuts ....................................................................................... 191
**Reference** ............................................................................................................... 192
Error Messages for Export and Save ......................................................................... 192
**Limited Warranty** .................................................................................................. 194
Getting Started

About TestGen

TestGen is a test generator program that lets you view and edit testbank questions, transfer them to tests, print in a variety of formats, and prepare tests for use with the TestGen plug-in as well as widely used course management systems such as CourseCompass, MyMathLab, EconLab, FinanceWorks, Blackboard, and various versions of WebCT. TestGen's built-in random number generator makes it ideal for creating multiple versions of tests that involve math calculations and provides more possible test items than testbank questions. Powerful filter and sort functions let you easily locate and arrange questions in the order you prefer.

Features

TestGen has many useful features, which include:

- List titles of frequently used testbanks in the Testbank Library
- View testbank and test questions on-screen
- Add questions to tests using drag-and-drop or point-and-click transfer
- Build quick tests with the TestGen Wizard
- Choose from a variety of question types: multiple-choice, bimodal, short-answer, true/false, matching, essay, and vocabulary
- Sort test questions with a built-in SmartSort or a customized order
- Add and modify test and testbank questions on-screen
- Print up to twenty-five forms of a single test
- Set up a filter to show only the testbank questions that meet your specified criteria
- Recalculate variables in questions
- View descriptor information for each question
- Use symbol palettes and templates to insert math notation
- Insert graphics on tests and in testbanks
- Create Cartesian, polar, and number line graphs for mathematics using a built-in graphing tool
- Use a built-in spell checker
- Export tests as text (.txt, .rtf), Acrobat (.pdf), or web (.html) files; as interactive HTML practice tests; in Blackboard 6.x-9.x format; in WebCT 3.x/4.x format, or in QTI (WebCT CE 6.x and WebCT VISTA) format
- Publish tests for use with QuizMaster
- Link to Pearson Education's TestGen web site for online tutorials, product support, and software updates
System Requirements

TestGen 7.4 for Windows™ has the following minimum system requirements:

- Windows 2000, Windows XP, Windows Vista, or Windows 7 operating system
- a Pentium® (or equivalent) microprocessor running at 233 MHz or faster
- 128 MB of RAM (random access memory)
- 20 MB of hard disk space (varies depending on the testbank size).

TestGen 7.4 for the Macintosh™ has the following minimum system requirements:

- Macintosh OS X v.10.4 - v.10.6
- Macintosh computer with a Power PC G3, G4, or G5 or Intel processor
- 128 MB of RAM (random access memory)
- 20 MB of hard disk space (varies depending on the testbank size).

A web browser is required to use the TestGen plug-in and view TestGen Help. The following configurations are recommended:

- For Windows 2000: Internet Explorer 6 or 7, Firefox® 2 or 3
- For Windows XP: Internet Explorer 6, 7, or 8, Firefox® 2 or 3
- For Windows Vista or Windows 7: Internet Explorer 7 or 8, Firefox® 2 or 3
- For Macintosh OS X v.10.4 - v.10.6: Safari™ 3.1 or Firefox® 2 or 3

*Note:* The TestGen plug-in for Windows requires a 32-bit (not 64-bit) browser.

*Note:* TestGen Help requires Flash® Player 6.0 or higher. If the Help table of contents does not display properly, you may need to update the Flash Player installed on your computer. Use your web browser to go to the Adobe® Macromedia® Flash Player download page to obtain the latest version of the Flash Player. After the new player is installed, restart TestGen.

Please check the TestGen Instructor web site for updates on supported hardware and software.
Getting Started

Installing and Starting TestGen

To install the TestGen program, testbank questions, and/or the TestGen plug-in, insert the TestGen CD and double-click the CD icon if the CD does not open automatically.

On the Windows CD, run the `tgsetup.exe` program. On the Macintosh CD, start TestGen 7 Setup. Follow the steps on-screen to perform the Typical (Windows) or Easy Install (Macintosh) and refer to the Readme.txt file on the CD for additional information.

Clean-Up Options During Installation

If you have one or more older versions of TestGen on your computer, you can "clean up" your old TestGen files during installation. The cleanup activities include:

- the option to remove all old and outdated installations of the TestGen program and copy program preferences, password, exam settings, and the spell check user dictionary from your most recent application to the new installation of TestGen;
- removing old Start menu program groups and shortcuts (in Windows);
- and the option to check the Web for program updates at the end of installation.

The clean-up process:

- deletes the files for old versions of TestGen, but does NOT delete the folders or directories that contained them.
- does NOT delete existing testbank (.BOK) files;
- does NOT delete existing test (.TST) files, user preferences and settings files, or other user files that might have been created while using older versions of the program.

To comply with more strict security standards, TestGen documents should not be stored in the TestGen application directory. All TestGen preferences are stored in the system-approved (Windows or Mac) preferences folder, and all TestGen testbanks (.bok) and tests (.tst) are stored in the system-approved user documents folder. TestGen moves these files to the appropriate folders and updates your library, preferences, and file location paths as needed.

TestGen Plug-in Installation for Instructors

The TestGen installer installs the TestGen plug-in in the Plugins (or Internet Plug-ins) folder of Internet Explorer, Netscape Navigator, Safari, or Firefox so that you can view web tests on your computer before you post them for student use. Follow the instructions on the screen during the plug-in installation.

Updating, Testing, and Removing the TestGen Plug-in

It is easy to update the TestGen plug-in files using the shortcuts and utilities put on your computer during installation. Follow the instructions below for your computer.

Windows

On the Windows Start menu, choose TestGen and then TestGen Plug-in to find the options that let you update, test, and remove the TestGen plug-in. If you connect to the Web and update the plug-in, you see the plug-in test page to verify that the plug-in has been installed properly.
Test Gen 7.4 Help

To remove the TestGen plug-in files from your computer, choose the Remove TestGen Plug-in option on the Start>TestGen>TestGen Plug-in menu.

**Macintosh**

On the Macintosh, open the Applications folder and then the TestGen Plug-in Utilities folder to find shortcuts that let you update and test the TestGen plug-in. If you connect to the Web and update the plug-in, you see the plug-in test page to verify that the plug-in has been installed properly.

To remove the TestGen plug-in, locate the /Library/Internet Plug-ins folder and remove the TGPlugin folder.

**Starting TestGen**

The TestGen application starts automatically at the end of a Typical (or Easy) install or a Custom install of the TestGen program. On Windows computers, the TestGen installer creates shortcuts for the TestGen program, the Tests folder, and the TestGen plug-in on your desktop. On Macintosh computers, you will find icons for the TestGen program and Tests folder on the Dock. To restart TestGen later, double-click its desktop shortcut (Windows) or click its icon on the Dock (Macintosh. If the shortcuts get deleted or if you cannot find them, follow the instructions below to start the program.

**Windows Users**

1. Click the Windows Start menu and select Programs.
2. Select TestGen to start the program.

**Macintosh Users**

1. Open the TestGen folder (usually found in the Applications folder)
2. Double-click the TestGen application icon to start the program.

**Adding Testbanks to the Testbank Library**

When the TestGen program starts, you can have TestGen search your computer and list the names of available testbanks in the Testbank Library, where you can easily select a testbank to view questions and choose items for tests. The option to "Locate Testbanks" is always available on the File menu.

**Installing Testbanks from the TestGen CD**

Most often, if you obtain a copy of TestGen on a CD, there will also be a testbank on the CD. If you already have the TestGen application installed and need to install just the new testbank, you can either run the TestGen installer and choose Custom install to install just the testbank, or you can copy the testbank file directly from the CD's Resources folder to your computer.

*Note: You cannot work with the testbank file while it is on the CD; it will be shown as "read-only."*
Downloading from the TestGen Web Site

If you do not have a TestGen CD or if you want to download the most recent TestGen application, TestGen Plug-in, or a textbook-specific testbank, open your web browser to go to the Pearson TestGen Instructor Site:

http://www.pearsoned.com/testgen

To access this site, you need to enter the login ID and password assigned to you by Pearson, usually the same ones you use to access the Pearson Education Instructor Resource Center (IRC) or online products such as CourseCompass, Math XL, MyMathLab, or EconLab.

Follow the on-screen directions to select, download, and install the files you need.
Installing the TestGen Plug-in

The TestGen plug-in lets students and instructors view and take TestGen tests in a web browser. When instructors install TestGen, the TestGen plug-in is installed at the same time as the TestGen program so that instructors can preview web tests on their computers.

The TestGen CD Web Utilities folder also contains a standalone installer for the TestGen plug-in that you can use to install the plug-in on student or lab computers.

To install the plug-in on a Windows or Macintosh computer:

1. Open the Web Utilities folder on the TestGen CD and run the `tgpluginsetup.exe` program (Windows) or the `TGPlugin Setup` program (Macintosh).

   *Note:* To install the TestGen program and plug-in, you must log on as a user who has administrative rights. If you do not have administrative rights, the installation program will terminate.

2. Follow the directions on-screen to install the plug-in in the Plugins folder of Internet Explorer or Netscape Navigator. The installer will launch your web browser and display a web page to let you know if installation was successful.

Newer versions of the plug-in may also be obtained from the Pearson TestGen web site. See the Product Support page.

Installing the TestGen plug-in lets you and your students run TestGen tests using various supported web browsers. Tests can have any combination of the following features:

- adjustable color, size, and placement of the test window,
- a review mode that allows students to see their answers along with the highlighted correct answers,
- a test timer and warning message when the test time is almost done,
- random regeneration of numbers each time the test is run,
- shuffling of multiple-choice answers each time the test is run,
- evaluated short answer questions,
- scrambling of question order each time the test is run,
- test-taking help for the student,
- a score window when the test is complete,
- results sent to a file on the local computer or server,
- option to print tests and results,
- optional date/time stamp.

The plug-in is also available for download from a variety of publisher-supported sites, which also sometimes provide pre-made tests and course management systems to keep track of tests and scores.
Using and Changing a Password

If you want to restrict access to the TestGen program on your computer, you can set a password that you will need to enter each time you start the program. This prevents unauthorized users from running the program and getting access to testbanks and test files.

Setting a Password

To set up a password, select "Change Password" from the Tools menu. The first time you do this, you see the Password Registration dialog. Type one or more characters in the space provided for your new password. Then re-enter your password to verify it. In case you need it later, also type a hint that will help you remember your password. Then click OK.

Changing a Password

To change an existing password, click the Change It button on the Password Verification dialog shown at program startup or select "Change Password" on the Tools menu. Then, enter your current password, enter your new password, and re-enter your new password along with a hint. The program checks to see if your current password is valid before accepting your new password. Your password is saved with the program and cannot be retrieved in any way once you have entered it.

Deleting a Password

If you set a password, but then decide you do not want to use a password, sign on to TestGen as usual, and then select "Change Password" on the Tools menu. Click the No Password button at the bottom of the password dialog.

Forgotten Password

If you cannot remember your password, even with the hint, click the Forgot It button and write down the code number. When you contact Product Support, they will use the code number to retrieve your password.
Product Support Options

You can obtain product support for the TestGen and QuizMaster programs in the following ways:

TestGen Help Menu

Select "Help" from TestGen's Help menu or press F1 to get to the browser-based TestGen help system. TestGen Help provides a table of contents and a Search function to help you quickly locate the information you need. Help topics can also be printed, if desired.

Note: TestGen Help requires Flash Player 6.0 or higher. If the Help table of contents does not display properly, you may need to update the Flash Player installed on your computer. Use your web browser to go to the Adobe Macromedia Flash Player download page to obtain the latest version of the Flash Player. After the new player is installed, restart TestGen.

How Do I Tour

The TestGen Startup screen has a "How Do I?" button that links to tutorials that illustrate the main functions of TestGen. You can also connect to the tutorials by selecting "How Do I Tour" from the Help menu. The tutorials open and run in your web browser.

Online Product Support

Select "Online Product Support" from TestGen's Help menu to open your web browser and display a form where you can report problems or ask questions. Complete the form and click the Send Mail button at the bottom of the form. You will receive a response from the Pearson Customer Technical Support team.

Online Software Download

Choose this option from TestGen's Help menu to connect your web browser to Pearson's TestGen Instructor Site (http://www.pearsoned.com/testgen) where you can download the TestGen application, the TestGen plug-in, and textbook-specific testbanks. To access this site, you need to enter the login ID and password assigned to you by Pearson, usually the same ones you use to access the Pearson Education Instructor Resource Center (IRC) or online products such as CourseCompass, Math XL, MyMathLab, or EconLab.

Follow the on-screen directions to select, download, and install the files you need.

Check for Program Updates

You can find out if you have the most recent release of the TestGen application by selecting "Check for Updates" from the TestGen Help menu. When you check for updates, the TestGen program closes and you see the updater window.

The updater lets you know if new files are available and you can download them immediately, if desired, after which the TestGen program restarts. If you already have the most recent version of
the program or if you choose not to update immediately, the updater closes and the TestGen program restarts.

Contact Pearson Customer Technical Support

Phone: 1-800-677-6337 (1-800-6-PROFESSOR)

Web: 247.pearsoned.com

Email: media.support@pearsoned.com
About QuizMaster

The **QuizMaster** student testing program is a companion product for Tamarack's TestGen software that provides a way for students to take tests on a **local area network** of computers and then lets instructors view and print reports based on the results of these tests. Instructors create tests with the TestGen program and publish the tests in QuizMaster format so they can be used with the QuizMaster program to display test questions on a computer, receive student answers, and show the results in both on-screen and printed reports.

The **QuizMaster Utility** lets instructors set preferences for test availability, customize grading scales, and view and print reports for students, classes, and courses. The reports show records of student IDs and passwords, raw and percent scores, lists of missed objectives, recommendations for restudy, and statistics such as mean, median, standard deviation, and letter-grade frequencies.

Features of QuizMaster

Here are some of the many useful features of the QuizMaster and the QuizMaster Utility programs.

**For student use:**

- Students can easily sign-on, select a test, move from question to question, mark and review questions, and view or print their scores at the end of the test.
- Students can see and/or print a list of the objectives or topics mastered and missed so that missed objectives can be restudied.
- Students can, when allowed by the instructor, print a list of questions they missed on a test.
- Students can take tests at the same time or at different times to make the best use of computer resources.

**Many Instructor options:**

- Instructors can set a time limit for tests so that all students take the test under the same conditions.
- Instructors can give students access to an online calculator during the test to help with calculations.
- Instructors can set up or modify grading scales to assign grades for each test.

**Easy setup and maintenance of student record and tests:**

- Instructors can use the import option to preregister students by name, class, and course.
- Records can be erased for completed classes or students who drop a class.
- Tests created with TestGen can include randomized numbers, graphics, and user-added questions.
A variety of reporting options:

- All reports are available in both on-screen and printed reports.
- Reports based on scores can be sorted by student name, ID, percent score, or objective.
- Reports based on objectives allow instructors to evaluate the needs of students as individuals or as a group.

For security:

- Test questions appear in random order (and with randomized numbers, when available) so students who are sitting next to each other in the computer lab cannot share answers.
- Instructors have the option to save and review an exact copy of the last test taken by each student in the course.
- Student records and instructor files are kept confidential and secure by a simple, yet effective password system with encoded files.
- The option to use a proctor password provides even more security when students sign on to take a test.
- Network compatibility provides a paper- and disk-free environment for test taking and scoring.

Installing QuizMaster

When you are ready to install QuizMaster, locate the QuizMaster installer in the LAN Utilities folder of the TestGen CD, or download the installer from the Pearson Education TestGen website.

After you download the installer, unzip or unstuff it, and then run `qmsetup.exe` (for Windows) or `QuizMaster Setup` (for Macintosh) and follow the instructions on the screen. You will need to install both the QuizMaster Utility, so it runs in TestGen, and the QuizMaster student program. The QuizMaster student program is designed to be installed on a network server and should not be installed in the same directory or folder as TestGen or the testbank files. Note that students need rights to create, read, write, open, and modify files in the QuizMaster Records folder. For security, records files are encoded so that they cannot be read as text documents.

Note: Some programs or extensions, such as virus checkers, may interfere with installation. If this happens, you will need to turn off those programs causing the conflict and restart your computer before installing QuizMaster.

After installing the student program on a server, you can set up a shortcut or alias to the QuizMaster program on each computer where students will be taking tests. Locate the QuizMaster program on the server and create a shortcut for it. Drag the shortcut onto the Start menu (Windows) or into the Dock (Macintosh).

Alternate Installation Configuration

On some networks, you might find it more efficient to install the student QuizMaster program on each computer that students will use to take tests. After installing the student QuizMaster programs, complete the linking procedure (described in the next section) for one of the student computers. Then copy the file `qmeq.cfg` from the QuizMaster folder into the QuizMaster folder on other student computers. Examine the contents of the file to be sure that the pathname to the Records folder is correct and matches the qmeq.cfg file in the TestGen application folder.
Installing and Starting the QuizMaster Utility

One of the options in the QuizMaster installer is to install the QuizMaster Utility. You will know that the QuizMaster Utility has been correctly installed in TestGen if you see entries for "Publish QuizMaster Test" and "Start QuizMaster Utility" on the File menu, and an icon for QuizMaster Test on the Startup window. There is also an additional option on the Help menu for QuizMaster Help.

The first time you start the utility, you need to link it to the QuizMaster student program so that both programs know where student records and tests are stored. The program prompts you to locate the QuizMaster student program file. Locate and select the QuizMaster program file on the network server and click Open.

After locating the QuizMaster program, you see the QuizMaster Configuration window. Follow the instructions to enter the pathname of the directory where you want student records to be stored. This pathname varies depending on how your network is set up.

When you click OK on the QuizMaster Configuration window, TestGen creates a file called qmeq.cfg in both the TestGen program folder and the QuizMaster program folder. The qmeq.cfg file is a text file that contains the pathname for the Records folder and it links TestGen and the QuizMaster Utility program to the QuizMaster student program. You can now run the QuizMaster Utility program to set up course and section names and preferences.

Note: If you need to change the location of the programs at a later date, you need to reinstall the programs and change the contents of the qmeq.cfg file, or delete the qmeq.cfg files from the two locations and run the QuizMaster Utility program to set up the new qmeq.cfg files.

QuizMaster Help

After you install the QuizMaster Utility, the Help menu in TestGen displays an additional entry for "QuizMaster Help." Select this option to find out more about the options available in the QuizMaster student program and the QuizMaster Utility.
Menus, Toolbars, and Work Areas

The TestGen Menu Bar

The TestGen menu bar, located at the top of the TestGen application window, is the place to look for all the controls you need to work in TestGen. Many of the options listed on the menus display keyboard shortcuts you can use instead of making selections from the menus. Three toolbars, which you can display below the TestGen menu bar, contain icons for functions that are frequently used when working with tests and testbanks.

Brief descriptions of the TestGen menu options are given below.

File Menu

The File menu includes options to open, close, save, and create testbanks and tests. It also includes standard page setup and print options, the option to add testbank titles to the Testbank Library, and options to export tests to a variety of different formats. The "Exit" option closes the TestGen application.

Edit Menu

The Edit menu includes standard editing options for Undo/Redo, Cut, Copy, Paste, Insert, Replace, and Delete, and Select All. You will also find "Find and Replace" on the Edit menu.

View Menu

The options on the View menu allow you to show or hide to provide additional tools and information or reduce screen clutter, as needed:

- the Standard toolbar, Text Formatting toolbar, or Equation Editing toolbar,
- the Testbank Library and Resource Library,
- rulers used for test and testbank editing,
- summary information for tests and testbanks,
- a toggle to view either question IDs or question text in testbanks and tests,
- a toggle to view either variable names or variable values in questions that contain user-defined or programmed variables,
- invisible characters, such as tabs and spaces in text edit fields,
- question properties when editing testbanks,
- the testbank setup dialog for new testbanks.
Insert Menu

The options on the Insert menu let you insert questions and components of questions onto tests or into testbanks:

- questions and additional answer choices,
- tables, pictures (graphics), graphs, international characters, and randomized variables.

In addition, you can use the Insert menu to insert page breaks on tests and new section headings in testbanks open for editing.

Navigate Menu

The options on the Navigate menu let you display the First, Previous, Next, or Last page of a test. You can also "Jump to..." a particular page. When working with testbanks, you can use "Expand Selection" to show all the items under the selected heading(s) or "Collapse All" to close up all the visible sections in the testbank or Testbank Library.

Question Menu

The Question menu contains an assortment of functions related to working with questions on tests:

- sort, scramble, pin/unpin, lock/unlock number values, assign point values;
- calculate new values for randomized numbers
- change the question type, mark the correct answer, or change the answer blank style.

Tools Menu

The options on the Tools menu assist in the preparation of tests and testbanks:

- spell check for tests and testbanks,
- header-footer editor for test pages and testbanks,
- macro editor to set up frequently used text or expressions to insert in test items,
- graphics library and transparent graphics to manage pictures (graphics),
- global style replacement to universally change fonts, size, and styles in tests and testbanks,
- filter testbank content to view only questions that meet specified criteria,
- evaluated answer editor to define acceptable forms of the correct answer for short answer and bimodal questions (in short answer form) on web tests,
- preferences for the TestGen application, tests, and testbanks,
- change password or reset TestGen to its "out-of-box" settings.
Window Menu

Each time you open a test or testbank, it opens in its own TestGen editing window. The Window menu contains the Arrange option, which resizes all of the open windows and positions them so that they cascade down from the upper left corner of the screen.

The Window menu also lists all the open and active windows so you can click on any of the window titles in the list to bring the desired window to the front of other open windows.

When more than one test or testbank editing window is active, if you close one of the test or testbank editing windows, other windows remain open. When you close the last open test or testbank editing window, TestGen keeps running and the Startup pane shows at the right side of the screen.

Help Menu

The Help menu contains a variety of convenient methods to get additional support for TestGen, including links to:

"How Do I?" online tutorials, online product support, software download, and a check for program updates.
The Standard Toolbar

The Standard toolbar contains icons that are shortcuts for many of the frequently used functions found on the TestGen menus — File, Navigate, View, Question, and Tools. If the Standard toolbar is not visible, select "Toolbars > Standard" from the View menu.

1. **New** - Start a new test or testbank by making a selection on the Startup pane
   - **Open** - Open a test or testbank file
   - **Save** - Save the test or testbank that is in the active editing window
   - **Print** - Print the test or testbank that is in the active editing window

2. **Previous** - Display the page or screen that precedes the current page of questions in a test or testbank
   - **Next** - Display the page or screen that follows the current page of questions in a test or testbank
   - **Jump** - Go to the start of a test page you specify by number
   - **Top** - Display the first page or screen of questions in a test or testbank
   - **Bottom** - Display the last page or screen of questions in a test or testbank

3. **Test Information (or Testbank Information)** - Display a summary of the types and numbers of questions on the current test or in the selected testbank
   - **Calculate New Values** - Display a new set of randomly generated number values for all variables in the selected question(s)
   - **Lock Number Values for Question** - Keep the same number values that are currently displayed for all variable numbers even if numbers in other items are recalculated
   - **Mark or Unmark as Correct Answer** - Indicate the currently selected answer choice as the correct answer for a multiple choice or true/false question (can also be used to remove the correct answer mark)
   - **Pin or Unpin Question/Answer Position** - Lock the selected question or answer choice in place so it retains its absolute position even if the order of other questions or answer choices are scramble
   - **Scramble** - Randomly change the order of questions and/or answer choices on tests
| **Sort** - Arrange the questions on a test according to the preferences set by the instructor |
| **Assign Point Value** - Assign the number of points for the selected question(s) to be used to calculate the total score for a web test |

| **4** | **Show or Hide Library** - Display or close the Testbank Library at the left side of the TestGen window |
| **Toggle Bimodal Questions** - Change the display of the selected bimodal question(s) from multiple choice to short answer format or from short answer to multiple choice format. Also changes the form of Vocabulary questions so that the question (term) and answer (definition) are reversed on a test. |
The Text Formatting Toolbar

The Text Formatting toolbar contains icons that are shortcuts for frequently used editing functions and tools, some of which are not found on the TestGen menus. If the Text Formatting toolbar is not visible at the top of the TestGen window, select "Toolbars > Text Formatting" from the View menu.

1. Cut - Delete the selected item(s) but keep a copy in memory
   Copy - Leave the selected item(s) as is and keep a copy in memory
   Paste - Place whatever was copied or cut into memory at the location of the cursor
   Delete - Remove the selected item(s) and do not keep a copy in memory

2. Find and Replace - Locate specified text in all or part of a test or testbank with the option to replace it with other text
   Spell Check - Start the spell check tool for the selected test or portion of a testbank

3. Font - Select a font to apply to the selected text
   Font Size - Select a font size to apply to the selected text
   Bold, Italic, Underline - Apply bold, italic, or underlining to the selected text
   Styles - Apply plain, bold, italic, underlining, or other styles to the selected text by choosing them from a list
   Text Color - Apply a standard or custom color to the selected text

4. Align left - Position the selected paragraph, picture, graph, or table at the left edge of the edit area
   Align center - Position the selected paragraph, picture, graph, or table horizontally in the center of the edit area
   Align right - Position the selected paragraph, picture, graph, or table at the right edge of the edit area
   Justify - Insert space as needed in each line of the selected paragraph(s) so that the text is even with the left and right margins of the text area
The Equation Editing Toolbar

The Equation Editing toolbar at the top of the TestGen application contains tools to insert symbols not found on the keyboard, math equations, and pre-formatted tables. If the Equation Editing toolbar is not visible, select "Toolbars > Equation Editing" from the View menu.

Symbol Palettes

Each of the first nine icons on the Equation Editing toolbar opens a palette of symbols that you can insert at the current location of the cursor while you are typing or editing.

1 Operations - mathematical operations, composition, abstract algebra
2 Relations - equality, approximate inequality, inequalities
3 Sets and Logic - sets, proofs, logic
4 Geometry - geometric figures and symbols
5 Arrows, Lines and Bars - directional arrows and line segments
6 Greek Uppercase Letters - capital Greek alphabet
7 Greek Lowercase Letters - lowercase Greek alphabet
8 Script Letters - symbols for number sets
9 Miscellaneous Symbols - infinity, degree symbol, currency, checkmark, imaginary "i"

Math Templates

The seven template icons on the Equation Editing toolbar each display a palette of mathematical or scientific expression templates that you can insert at the cursor location. The templates contain slots, or fields, for you to enter numbers or text, and the expressions change size dynamically as you enter numbers or text in any of the fields.

1 Fractions, mixed numbers, superscripts, subscripts, grouping box
2 Radicals, long division, synthetic division, sinking funds, annuities
3 Over and under bars, braces, rays, lines, arcs
Test Gen 7.4 Help

4 Hat, tilde, cross-out, primes
5 Integrals, summation, co-product
6 Parentheses, vertical bars, double bars, braces, brackets
7 Determinants, matrices, pre-formatted charts and tables

Click a template to insert it at the cursor location, and fill in the cells with text or numbers as desired.

More details on using templates are in the "Math-Related Editing" section.
The Library and Editing Work Areas

The TestGen application window is divided into three distinct work areas:

- toolbars,
- Testbank and Resource Libraries,
- test and testbank editing window.

Toolbars

Under the TestGen menu bar, at the top of the screen, up to three toolbars can be displayed: the Standard toolbar, the Text Formatting toolbar, and the Equation Editing toolbar. Each can be turned on or off as needed.

Testbank and Resource Libraries

Below the menu bar and toolbars the screen is divided into two sections, one of which is the library section. The Testbank Library lists one or more testbanks from which you can select questions for tests. The Resource Library contains templates for new questions, answers, answer choices, and notes that you can transfer to tests or testbanks. The entire library area can be hidden from view when it is not needed.
Test and Testbank Editing Window

To the right of the Testbank Library is an area reserved for building and editing tests and testbanks. Each time TestGen starts, before you open a test, a Startup pane occupies the editing space, and you can choose the type of test you want to create or select a recently used test. When a test is open, you can

- drag or copy questions from a testbank in the Testbank Library,
- directly edit and work with questions in the test editing window, and
- adjust the layout of the test.

When testbank editing is enabled, you can make new testbanks or make changes to existing testbank items in the same area that you build and edit tests.

If you have a test or testbank open for editing and choose to start a new test or testbank, another editing window will open within TestGen.

Resizing Work Areas

Depending on what you are trying to accomplish, you can change the layout of the work areas and toolbars:

- Hide toolbars you are not using by selecting "Toolbars" from the View menu. Click the name of the toolbar you want to hide to remove the checkmark next to its name. Repeat the process to click the name of the toolbar the next time you want to bring it into view.
- Show or hide the Testbank and Resource Libraries by selecting "Hide Library" or "Show Library" from the View menu, or clicking the Library icon on the Standard toolbar.
- Resize the library and editing areas by moving your mouse over the vertical gray line that divides the left half of the screen from the right half. When the mouse pointer becomes a horizontal double-arrow, click and hold down the mouse button and drag the arrow left or right to resize the work areas. Release the mouse to set the vertical bar.

Arranging Multiple Windows

Each time you open a test, start a new test, or open a testbank for editing, a new TestGen window opens. If more than one TestGen window is open at the same time, you can switch from one editing window to another by one of these methods:

- Find the name of the document in the Windows Task Bar or on the Macintosh Dock and clicking it to bring that document to the top of the stack.
- Find the name of the document you want by selecting it from the Windows menu to bring it to the top of the stack.
- Use the "Arrange" command on the TestGen Window menu to make all the open windows cascade down from the top, left corner of the screen. From all the visible title bars, click the one for the document you want to bring to the front of the stack.
Creating Tests

Choosing a Test Type

TestGen lets you create tests that can be printed, displayed in a web browser for online testing, or displayed in QuizMaster for testing on a local area network, if you have this option installed.

When you start the TestGen application or choose "New Test" from the File menu, the right side of the screen displays a Startup pane with buttons to create:

- a Paper Test—suitable for printing or exporting to an RTF or PDF file, or HTML pages
- a Web Test—select TestGen Plug-in; Blackboard 6.x - 9.x; WebCT 3.x and 4.x; QTI (WebCT CE 6, WebCT Vista); or HTML practice test
- a TestGen Wizard test—quickly choose questions for a paper test
- a QuizMaster test—publish it to work with the QuizMaster student application (if installed) on a local area network

Selecting the type of test you want helps TestGen check your selections to make sure the questions you choose will work appropriately for your test.

When the new test window opens, the top of the test window shows the test name and the type of test you are authoring. When you have the test window open, you can proceed to transfer questions from a testbank or add your own questions to the test.
Creating Tests for Paper

You can start a new paper test in any of the following ways:

- click the Paper Test button on the Startup pane,
- select "New Test" from the File menu, or
- click the TestGen Wizard button on the Startup pane.

When you create a new test, choosing a paper test implies that the test will be printed and distributed on paper, but a paper test can also be exported to an RTF file, a PDF file, or a formatted HTML file.

Features of a Paper Test

Paper tests can include all question types, and you can choose questions by any of the methods described in the topic "Choosing Questions from a Testbank". After selecting the questions you want, modify the content as needed, and adjust the test layout. Then save and print the test.

Below are a few of the options available for paper tests:

- can use the TestGen Wizard to choose questions randomly
- can include a variety of question types: multiple-choice, short answer, bimodal, true/false, matching, essay, and vocabulary
- can customize the test header, page headers and footers
- can insert page breaks
- can insert "notes" between questions
- can customize question type headers
- can see test pages and answer key on-screen before printing
- can "pin" questions to prevent scrambling
- can sort questions
- can print multiple forms of a test by shuffling question and/or answer choice order
- can export the test to RTF, PDF, or HTML formatted files
Creating Tests for the Web

Creating a test for the Web implies that students will take the test at a computer using a web browser. When you create a new test by clicking the Web Test button on the Startup pane, you need to choose the specific web platform(s) for the test as shown below:

If you always want to make the same kind of web test, you can hide this dialog by making a selection and then checking the "Don't show this again." option. The program remembers the last option you selected and uses that as the default for all new tests.

The top of the test window shows the test name and type of test selected:

TestGen customizes the menus and buttons to make it easy for you to choose questions that are compatible with the test type you choose. If you select more than one platform, TestGen applies the options for the platform that has the most stringent requirements. For example, if you choose both TestGen Plug-in and HTML Practice test, the points option and short answer questions are
Test Gen 7.4 Help

not allowed, even though the TestGen plug-in supports them, because the HTML test does not allow these options.

**TestGen Plug-in Tests**

The TestGen plug-in, available for Windows and Macintosh, lets students take TestGen tests using a web browser, such as Internet Explorer or Netscape Navigator. Plug-in tests are compatible with web-based course management systems supported by Pearson Education companies, such as Course Compass, MyMathLab, EconLab, and FinanceWorks. Students need to download and install the TestGen plug-in on their computers and have log-in privileges to use these systems. The instructions for using the plug-in are provided by the publisher for each course management web site.

*Note*: If you create a web test on a Windows PC and students will take the test using Macintosh computers, you might want to increase the size of the font, to 14 point for example, before saving and distributing the test, since the difference in screen resolution between Windows PCs and Macintoshes causes the type to look smaller on Macintoshes. You can use the Global Style Replacement feature to resize a whole test at once.

**Blackboard Tests**

When you create a test for use with Blackboard® 6.x - 9.x, use the "Export" option on the File menu to export files that can be used with these course management systems. Instructors can upload the test files exported from TestGen into their Blackboard courses. See "Exporting Tests for Blackboard" for more information.

**WebCT Tests**

When create a test for use with WebCT® 3.x, 4.x, CE 6.x, or Vista® 4.x, use the "Export" option on the File menu to export files that can be used with these course management systems. Instructors can upload the test files exported from TestGen into their WebCT courses. The tests exported for WebCT CE 6.x and Vista 4.x are in QTI format, which can be used with other QTI-compliant testing systems. See "Exporting Tests for WebCT" for more information.

**HTML Practice Tests**

When you create an HTML practice test, you use the "Export" option on the File menu to create a folder of HTML files that students can view with a web browser. The web browser needs to support HTML 3.0 or higher (frames, tables, forms) and JavaScript. Netscape® Navigator and Microsoft® Internet Explorer 4.0 and higher are compatible browsers. See "Exporting HTML Practice Tests" for more information.
**Comparison of Web Test Types**

Here is how the types of web tests are alike and different:

<table>
<thead>
<tr>
<th>Feature</th>
<th>TestGenPlug-in</th>
<th>Blackboard (6.x - 9.x)</th>
<th>WebCT (3.x, 4.x, CE 6.x, and Vista 4.x)</th>
<th>HTML Practice Test</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maximum # of questions</td>
<td>40</td>
<td>no limit</td>
<td>no limit</td>
<td>no limit</td>
</tr>
<tr>
<td>Test Header</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Page headers and footers</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Question type headers</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Continuous document, no page breaks</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Pinned questions allowed</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Assigned point values allowed</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>MC questions with more than one correct answer allowed</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Question types allowed</td>
<td>Multiple choice, short answer, bimodal, true/false</td>
<td>Multiple choice, short answer, bimodal, true/false, matching, vocabulary, essay</td>
<td>Multiple choice, short answer, bimodal, true/false, matching, vocabulary, essay</td>
<td>Multiple choice, bimodal (no short answer), true/false</td>
</tr>
<tr>
<td>Allows alternate correct answers for short answer questions</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Feature</td>
<td>Yes, for all question types except essay and short answer questions with long answers</td>
<td>No</td>
<td>Yes, for all question types except essay and short answer questions with long answers</td>
<td>No</td>
</tr>
<tr>
<td>-------------------------------------------</td>
<td>----------------------------------------------------------------------------------------</td>
<td>----</td>
<td>----------------------------------------------------------------------------------------</td>
<td>----</td>
</tr>
<tr>
<td>Explanations included (when available in testbank or test)</td>
<td>OK in questions, not allowed in short answers</td>
<td>OK in questions</td>
<td>Not allowed in short answers; no answers &gt; 2000 char</td>
<td>OK in question, not in short answers</td>
</tr>
<tr>
<td>Tables, graphics, and math graphs</td>
<td>OK in questions and answers</td>
<td>OK in questions</td>
<td>Not allowed in short answers; no answers &gt; 2000 char</td>
<td>OK in question, not in short answers</td>
</tr>
<tr>
<td>TestGen symbols</td>
<td>OK in questions and answers</td>
<td>OK in questions</td>
<td>Only standard keyboard (ISO 8859-1) and international palette characters allowed in short answers</td>
<td>Yes</td>
</tr>
<tr>
<td>TestGen templates</td>
<td>OK in questions (export to characters and/or GIFs)</td>
<td>OK in questions (export to characters and/or GIFs)</td>
<td>Templates not allowed in short answers</td>
<td>OK in all (export to HTML or GIFs)</td>
</tr>
<tr>
<td>File / Export</td>
<td>Not needed</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>
Saving and Opening Tests

This section discusses how to save new tests, how to save tests using a different name, and how to open existing tests.

Saving a New Test

Each time you start a new TestGen test, it is temporarily named "Untitled" followed by a number—"Untitled1.tst" for example. The test name appears at the top of the test window.

When you click the Close box or select "Close" from the File menu, and the test has not been saved, a dialog asks if you want to save the tests.

You can also select "Save" from the File menu to open the file dialog and give the test a name if it has not previously been saved to disk. If the test has previously been saved and you choose "Save," the test is resaved using the same name it was assigned previously, with the new contents replacing the old.

Saving and Renaming a Test

If you want to save a test and rename the file at the same time, select "Save Test as..." from the File menu. This opens the file dialog so you can type a new name for the test and save it either in the default location for tests, or anywhere you can navigate to on your computer. The two test files, with the old and the new names, both remain stored on your computer.

Opening an Existing Test

The easiest way to open an existing test is to find its name in the Recent Tests list on the Startup pane.
Click any of the Recent Tests to open it in the editing window.

If you don't see the name of the test you want in the Recent Tests list, select "Open" from the File menu. In the file dialog, locate the name of the test you want to open and click Open. You can identify a TestGen test file by its icon, which looks like a piece of paper with a pencil next to it, and its filename extension, which is .tst.

Note: TestGen saves and looks for tests in a Tests folder inside the TestGen folder, which is located in your system-approved user Documents folder. You can change the location where tests are stored by selecting "Preferences" from the Setup menu and clicking the File Locations tab.

Tests created with earlier versions of TestGen are converted to work with TestGen 7 when you open the tests. If the test was made with TestGen 5.5 or higher and specified as a test for paper, the web, or QuizMaster, the test type (paper or web) is retained. Tests created with TestGen's earlier than version 5.5 convert to paper tests.
Changing One Test Type to Another

When you have a test open on the right side of the screen, the top of the test editing area shows the test filename along with an abbreviation for the test type: Paper test (Paper), TestGen Plug-in (TG Plug-in), WebCT (WCT), Blackboard (BB), or HTML Practice test (HTML Practice). You can change the test from one type to another if select "Change Test Type" from the File menu and choose the preferred type of test—paper, web, or QuizMaster (if installed). If you choose a web test, you also need to choose the specific platform, just as if you were starting a new test.

The Save As... dialog appears so you can save the test with a new filename (make a copy) or resave the test using the same name (replace the current file).

Before converting the test, TestGen confirms that the questions are suitable for the new test type. If any of the questions could cause problems in the new target delivery mode, you see a list of the affected questions and a description of the error or problem.

Errors that might occur when switching test types:

- Question type is not supported in target delivery mode.
- Answer contains information that cannot be entered or evaluated in target delivery mode
- Question cannot be evaluated online unless a correct answer is provided.
- Answer length exceeds limit of target delivery mode.

Alert messages and notes:

- Locked answer positions will not be retained in target delivery mode.
- Question contains characters that might not display properly online.
- Question contains a graphic that will not display properly in target delivery mode.
- Answer might need more information to be evaluated properly by software.
- Check the question to make sure that the answer can be entered and evaluated online.

Return to the test and make the necessary changes to the test to correct the problem before you save, export, or publish the test.
Choosing Test Questions

Building a Test Step-by-Step

This section gives a quick overview of the basic steps for making a paper test. All the procedures and options are described in more detail in other sections of TestGen Help.

1. **Start the TestGen program**

   If you followed the typical installation, you can start the TestGen application from the shortcut on your desktop or from the Windows Start menu or from the TestGen folder on your Macintosh hard disk. If you used a Custom install, find the TestGen folder and the TestGen application file to start the program. Enter your password, if used.

2. **Open a Testbank**

   If you followed the typical installation, one or more testbanks are listed in the Testbank Library at the left side of the screen. If the Testbank Library is empty, select "Add Testbank to Library" from the File menu and locate and a TestGen testbank file, which usually is named with the abbreviation for a textbook and has a .BOK extension (e.g., psych.BOK, chem.BOK, or alg.BOK).

   In the Testbank Library, click the plus (+) sign next to the testbank you want to use to display its chapter titles. Click the plus (+) sign next to the chapter you want to use to display its subsections or questions. If there are subsections, click the plus (+) sign next to a subsection title to display its questions.

3. **Choose a Test Type**

   The right side of the TestGen program window shows a Startup pane from which you can select the type of test you want. For this demonstration, click the button next to Paper Test. A test editing window will open on the right side of the screen.

4. **Choose and Transfer Questions to the Test**

   There are many ways to transfer questions from a testbank to a test. You can use drag-and-drop to move a question from the testbank to a test, but you may also want to try the methods described below for choosing and transferring questions:

   "Add Selected Item(s)" Button

   With questions displayed in the Testbank Library, click once on a question that you want to put on your test. Its background changes color to show that it is selected.

   Now click the Add Selected Item(s) button at the bottom of the testbank window. A copy of the question appears as the first question on your test.

   **Transfer Multiple Items**

   To select more than one question at a time in the testbank, hold down the [Ctrl] key when you click the mouse to select a question. Continue to hold down the [Ctrl] key to click on and select additional questions.

   To make continuous selections, hold down the [Shift] key as you click the first and last question in a series.
Choosing Test Questions

With multiple questions selected, click the Add Selected Item(s) button to transfer the questions to the test.

Transfer Multiple Copies of a Question

If a testbank question has variable text or numbers, you can transfer multiple copies of the question to a test. First select a question that contains variables (the variant status indicator shows an inverted, black triangle next to the question and the number of variations is greater than 1). Then click the Choose Multiple... button at the bottom of the Testbank Library. Enter a number and click the Add to Test button. Multiple copies of the question you selected are transferred to the test, each with different numbers or text, depending on the assigned variables.

If you select more than one question containing variables and click the Choose Multiple... button, you get multiple copies of all the selected questions when you enter a number and click the Add to Test button.

Transfer Questions Randomly

To have the computer choose questions randomly, select a chapter or section title in the Testbank Library. Then click the Choose Multiple... button. Enter the number of questions you want to transfer and click the Add to Test button. The number of questions you chose are randomly selected from those available for the section you selected.

You can also select more than one title or heading and choose multiple questions. The number you enter after clicking the Choose Multiple... button determines the number of questions that are randomly chosen from each title or heading you have selected.

5. Add Your Own Questions

To add a question of your own to the test, click the Resource Library tab on the left side of the screen. Click the plus (+) sign next to Question Templates to see the list of question types. Select the question type you want to put on the test and drag it onto the test. In the test editing window, click in the question field and type your question, replacing any default text that might appear. For a multiple-choice question, click and type in each of the answer choices. Select the correct answer choice by clicking just to the left of the answer choice letter so the background of the answer choice changes color. Click the checkmark (Mark/Unmark as correct answer) on the Standard toolbar to mark the choice as the correct answer.

Other question types can be added and edited in a similar manner.

6. Modify Test Header and Layout

Double-click the test heading at the top of the test window to open the Header and Footer Editor where you can modify or add text. When you are done, click the Save button, and then close the Header and Footer Editor. Your new header appears at the top of the test.

7. Save the Test

There are many other ways to modify your test, and these are explained in the Help sections "Adjusting Test Page Layout," "Working with Questions," and "Editing Test Content." When you are finished with the test, select "Save" from the File menu. Give the test a name and click Save to save the test.

8. Print the Test

To print the test, select "Print" from the File menu and enter "1" for the number of versions. Be sure Print Answer Key is checked before you click OK. When the print dialog appears, set the print or page range to "All" and click OK.
Choosing Questions from a Testbank

When the test editing window is open and you are ready to start choosing questions from a testbank, the general procedure is:

1. Open a testbank in the Testbank Library.
2. Manually or randomly select one or more questions from the testbank.
3. Transfer the selected questions to the test.

The sections below give detailed information about how to choose one or more questions manually or randomly and transfer them to a test.

Selecting Questions Manually

Follow the directions below to select a single question, multiple questions, or multiple copies of questions from a testbank.

Choosing a Single Question

First open a testbank and locate the question you want to use on your test. Click on the question so that its background changes color, and then click the Add Selected Item(s) button.
Choosing Test Questions

A copy of the question appears in the test window. You can also drag the question from the testbank to the test by selecting the question and moving it to the test window while holding down the mouse button, then dropping it in place by releasing the mouse button. (For matching questions, use drag-and-drop or copy-and-paste instead of the Add Selected Item(s) button.)

If a SmartSort is in effect, the question moves to the correct location on the test according to the rules of the SmartSort. If the test is in user-defined order, the question is inserted at the location of the insertion line.

Choosing Multiple Questions

To choose more than one question in a testbank, click on a single question to select it, hold down the [Ctrl] key, and click on one or more additional questions. With multiple questions selected, click the Add Selected Item(s) button to copy the questions to the test window.

You can select and transfer a block of questions—for example, questions 1-10 in a particular chapter section—by selecting the first question in the series, then holding down the [Shift] key and selecting the last question. This will highlight the entire block of questions, and all will transfer to the test when you click the Add Selected Items(s) button.
Another way to transfer multiple questions to a test is to select any chapter or section title in a testbank and drag the title into the test window. This process copies every question contained in that chapter or section onto the test.

**Choosing Multiple Copies of a Single Question**

If a testbank question includes variable numbers or text, you can copy different randomly generated variations of the question onto a test. Select the question in the testbank and click the Choose Multiple... button. Enter the number of variations you want of the selected question. Then click the Add to Test button. Each question variation copied to the test includes different randomly generated numbers or text, without duplication.

*Note:* Many math testbanks have questions that use variables. To identify testbank questions that have more than one variation, select "Preferences > Testbank Options" from the Tools menu. Then click the Descriptors tab. Select "Variant status" to display a small, inverted triangle next to all questions that have more than one variation. You can also display the descriptor "#Var" to show how many variations are possible for each question. If a test question has no variables, #Var has a value of 1, and if you try to transfer multiple copies of the question, you will see a warning message asking whether you want to allow duplicate questions on the test.

**Choosing Multiple Copies of Multiple Questions**

If a testbank contains questions that include variable numbers or text, you can select more than one question and then request multiple copies of each question selected. First select the questions you want while holding the [Ctrl] or [Shift] key; then click the Choose Multiple... button. Enter the number of variations you want for each selected question, and then click the Add to Test button. You will get multiple copies of the selected questions, without duplication.

*Note:* To identify testbank questions that have more than one variation, select "Preferences > Testbank Options" from the Tools menu. Then click the Descriptors tab. Select "Variant status" to display a small, inverted triangle next to all questions that have more than one variation. You can also display the descriptor "#Var" to show how many variations are possible for each question. If a test question has no variables, #Var has a value of 1, and if you try to transfer multiple copies of the question, you will see a warning message asking whether you want to allow duplicate questions on the test.
Choosing Questions Randomly

You need to use the Choose Multiple... button at the bottom of the Testbank Library to choose questions randomly from a testbank chapter or section.

**Selecting Randomly from One Chapter or Section**

In a testbank, click on the title of the chapter or section from which you want to select questions. (Do not select an individual question or question ID.) Then, click the Choose Multiple... button and enter the number of questions you want randomly chosen from the selected heading. Then click the Add to Test button. The program randomly selects that number of questions from those available for the chapter or section you selected.

**Selecting Randomly from Multiple Chapters or Sections**

To randomly choose questions from more than one chapter or section, hold down the [Ctrl] or [Shift] key and select more than one chapter or section title. Click the Choose Multiple... button and enter the number of questions you want from each selected chapter or section. When you click the Add to Test button, the questions will be selected randomly from the available questions and transferred to the test.

*Note:* When selecting randomly from a chapter or section that has subsections, the "random" selection attempts to select questions from every subsection. Matching questions are never selected in a random selection.
Using the TestGen Wizard

Use the TestGen Wizard when you want to make a quick quiz by choosing questions randomly from one or more chapters or pick questions quickly from an abbreviated question list. To start the TestGen Wizard, select a testbank in the Testbank Library, then click the TestGen Wizard icon on the Startup pane. Enter a name for your test and then click OK to proceed to the next step.

Picking Chapters or Sections

After you name the test, select the chapters or sections you want to use for the test.

After you choose chapters or sections for your test, you choose whether to pick questions randomly or from a list.
Choosing Randomly

To can choose questions randomly by question type, chapter/section, topic, objective, or other categories that appear on the drop-down list. The items available on the list vary by testbank, since not all categories are used in all testbanks.

Type numbers in the right-hand column to indicate how many of each type you want from the number of questions available. Click OK to continue to the test summary.

Note: Matching items are not included in random selections. Also, the scrambled order produced by a random selection might not be suitable for testbank questions that rely on a fixed order.
Choosing from a List

If you choose to select questions from a list instead of randomly, you work from a scrolling list of questions from the selected chapters or sections. Along with the question type, you see the question type, the question ID, and the first portion of the question.

Select questions by holding down the [Shift] key (to make consecutive selections) or the [Ctrl] key (to make scattered selections) and clicking each item you want to put on the test. Click OK to continue to the test summary.

Test Summary

The test summary window shows the test name, chapters or sections selected, selection method, and total number of questions selected. Click Finish to build the test. The TestGen Wizard window closes and the test window opens with your selected questions. In the test window, you can modify the test as needed by editing or adding questions, rearranging questions, or changing the test layout. Finish by saving and/or printing the test.
Choosing Test Questions

Getting Test Summary Information

To see a summary of a test's contents, click anywhere on an open test to make it the active window and then select “Summary Information” from the View menu or click the Test Information icon on the Standard toolbar. A dialog opens, showing the total number of questions on the test.

Use the drop-down menu to change the display and show details for the number of questions per question type, topic or other descriptor (when available), or static vs. algorithmic.
Using a Filtered Testbank View

You can apply a filter to a testbank to locate questions that meet your criteria. For example, you might want to view only multiple-choice questions or only those questions that have a difficulty level of 2.

Please note the following rules for applying a filter to a testbank:

- You can specify a filter for one testbank at a time.
- Each testbank can have its own filter.
- A filter is for the current session only—when you quit the TestGen application and return later, the full testbank is displayed.

To apply a filter, first select a testbank in the Testbank Library. Then select "Filter Testbank Content" from the Tools menu to display the Testbank Search Criteria dialog.

Setting up the Filter Criteria

In the Testbank Search Criteria dialog, change the settings for any category in the first column by choosing from the drop-down menus in columns two and three. The combination of all the settings defines the set of questions you will see when you click the radio button for "Show Only Questions That Meet Criteria Above" and click OK. The program searches the testbank for questions that meet the specified criteria and displays a message to let you know how many questions were found.

Note: Since not all categories apply to all testbanks, the drop-down menus for some of the categories may be inactive for the testbank you have selected.
Choosing Test Questions

Locating Found Questions (Question View)

When you filter a testbank that is in Question view, only those questions that meet your criteria are displayed. Located questions do not renumber, so the display could show, for example, items numbered 1, 3, 6, 7, and 10, if those are the only questions that meet the filter criteria. A dimmed chapter or section heading indicates that none of the questions in the entire chapter or section meet the criteria.

Locating Found Questions (ID View)

When you filter a testbank that is in ID view, the IDs for the questions that meet your criteria are displayed in the normal color, while other IDs are a dimmed. Once you locate a question or group of questions that meet the criteria, you can switch to Question view to see the question content.

The headings for chapters and sections that contain questions that meet the criteria remain the normal color, and you can use the plus (+) and minus (-) signs to expand and close up these sections to locate the questions. A dimmed chapter or section heading indicates that none of the questions in the entire chapter or section meet the criteria.

Show All Questions

To display all the testbank questions again after applying a filter, select "Filter Testbank Content" from the Tools menu. In the Testbank Search Criteria dialog, click the radio button for "Show All Questions" and then click OK.
Editing Test Content

Modifying Questions and Answers on Tests

It is easy to make changes to questions and answers on TestGen tests that you create simply by clicking and typing on the test page. Some parts of tests have separate editing windows, and some items are for display only.

Note: For security purposes, some pre-made tests have locked questions that cannot be edited. Refer to the section on "Deleting Questions from Tests" for more information.

Areas with Direct Editing

You can edit any of the following items by clicking directly on them to activate and put a cursor in the editing field:

- questions
- answers (short answer, essay, matching, and vocabulary questions)
- answer choices (multiple choice and bimodal questions)
- instructions, notes, comments, explanations

Clicking on an editable field activates the field by placing a flashing cursor in it, and a light gray border appears around the question, answer, answer choice, or instruction. Edit or type new text as desired. A multiple-choice example is shown here.

<table>
<thead>
<tr>
<th>17) An ideological political party</th>
</tr>
</thead>
<tbody>
<tr>
<td>A) holds extreme political views.</td>
</tr>
<tr>
<td>B) will not cooperate with other parties.</td>
</tr>
<tr>
<td>C) is deeply committed to certain policy goals.</td>
</tr>
<tr>
<td>D) all of the above</td>
</tr>
<tr>
<td>Answer: C</td>
</tr>
</tbody>
</table>

You can also modify questions and answers for short answer, essay and vocabulary questions directly on the test page, but you may need to display the answer field, which by default is turned off on the test page. To display the answer field on a test page, select "Preferences > Test Options" from the Tools menu and click the Descriptors tab. Check the box for Correct Answer and click OK.

<table>
<thead>
<tr>
<th>2) _______ families are characterized by the presence of violence and ab</th>
</tr>
</thead>
<tbody>
<tr>
<td>Answer: Dysfunctional</td>
</tr>
</tbody>
</table>

If you need to see characters such as paragraph marks, tabs, and spaces, in the text editing fields, select "Invisible Characters" from the View menu.

Test items that contain variables highlight the variables with a colored background when you click in any question or answer field that contains them.
Editing Test Content

Be careful when editing near these highlighted variables, since deleting one can affect the calculations in other parts of the question or answer(s) in the test item, causing it to become incorrect or invalid.

In addition to editing text, you can

- add, edit, or remove math expressions and symbols,
- insert, replace, or remove graphics,
- add, edit, or remove tables.

Areas with Separate Editors

The following parts of a test can be edited in their own editing windows:

- Page headers and footers—Double-click any page header or footer to open the Header-Footer Editor, or select "Header-Footer Editor" from the Tools menu.
- Question type headers—Double-click any question type header or select "Question Type Headers" from the Tools menu to open the Edit Question Type Headings dialog and make changes.

Items for Display Only

The following items on a test are for display only and cannot be edited directly on a test.

Descriptors

When shown, descriptors such as difficulty level, page reference, and topic cannot be edited on the test page since these items are added and edited during testbank authoring and editing. However, you can control which items, if any, are displayed on the test by selecting "Preferences > Test Options" from the Tools menu and using the settings on the Descriptors tab.

Multiple-Choice Answer Letters

The letters shown as the answers for multiple-choice questions cannot be edited directly. However, when you mark or unmark any of the answer choices as the correct answer, the letters displayed by the "Answer:" label change.

To mark an answer choice as correct, first select the answer choice by clicking just to the left of the answer choice letter so that the background of the entire answer choice changes color. Then right-click the answer choice and choose "Mark/Unmark as correct" from the pop-up menu. (You can also choose "Mark or Unmark as Correct Answer" from the Question menu.) The correct answer indicator—a checkmark in a green circle—appears next to the correct answer.

Repeat the process to remove the correct answer indicator from any choice that was previously marked as correct.

You can add additional answer choices for multiple-choice and bimodal questions by dragging a Blank Answer Choice from the Resource Library into the answer choice list for a question.
Rearrange the order of choices by dragging and dropping. If you need to delete an answer choice, select it so its background changes color, and then press the Delete key. Adding, deleting, or rearranging the answer choices for a multiple-choice question causes the letter shown as the correct answer to change when the remaining or reordered answer choices are assigned new letters.

**True/False Answer Indicator**

The answers for true/false questions appear below the question when you display answers on a test. The words "True" and "False" are not directly editable, but you can change which answer is correct. The correct answer indicator—a checkmark in a green circle—appears next to the correct answer.

If the answer is shown as "True" and you want "False" to be the correct answer, click either "True" or "False" to select it. Then right-click on the selected word and choose "Mark/Unmark as correct" from the pop-up menu. (You can also select "Mark or Unmark as Correct Answer" from the Question menu.) This will either select the answer as correct or remove the correct answer indicator from the choice, depending on its original state.

**Answers for Matching Questions**

The correct match for a matching question is set up during testbank authoring and editing, but the answer choices in column 2 are randomly arranged and assigned letters when groups of matching questions are displayed in a two-column format on tests.

You can edit the answer choices in column 2 by clicking on any of the choices to activate the editing field. Change the text as desired.

You can add additional answer choices (foils) to column 2 by selecting a matching question and dragging a Blank Answer Choice from the Resource Library onto any question in the matching group. You can also add a foil by selecting "Blank Answer Choice" from the Insert menu.

The new answer choice is inserted into column 2 and the existing choices are assigned new letters based on the position of the new choice. The letters for the correct answers for each of the matching questions change to reflect the newly assigned letters in column 2.

*Note*: If you edit two answer choices so that they are identical, they will merge into one answer choice in column 2.

**Answer Key**

You can display the answers for questions on a test and turn them off before printing, but the Answer Key does not show on-screen. When you print a test, the options on the test print dialog let you choose whether to print the Answer Key along with the test pages.
Inserting International Characters

When you need to insert an international character that you cannot type from the keyboard, place the cursor where you want to insert the character. Then select "International Characters" from the Insert menu. This displays the International Characters dialog.

Click the tab for Spanish, French, German, or Italian to display characters for the selected language. To insert a character, click the desired character and then the Insert button. Click and insert additional characters as needed, or click the Close button to close the tool and continue typing.
Inserting Symbols and Templates

To insert symbols, mathematical expression, or pre-formatted tables into test or testbank questions or other editable items, use the Equation Editing toolbar. If the Equation Editing toolbar is not visible, select "Toolbars > Equation Editing" from the View menu.

The icons on this toolbar are divided into two sections: the nine icons on the left each open to display a palette of symbols, and the seven icons on the right each open to display a palette of dynamic templates that contain one or more fields for you to fill in.

Place the cursor in the editing field at the location where you want to insert the symbol, expression, or table. Then click one of the icons on the Equation Editing toolbar to open its associated palette. Click an item on the palette to insert it into the question.

If you insert a template, there will be one or more empty fields, or cells, for you to fill in. Click in any of the fields to enter text or other elements, or use the right arrow key to move from one field to another.

More details about using templates are in the "Math Related Editing" section.
Inserting Graphics

TestGen allows you to insert pictures (graphics files) into questions, answers, instructions, page headers, and explanations in test and testbank questions. You can prepare these graphics using commercial software or obtain them from other sources. TestGen recommends graphics in the following formats:

- bitmap (.bmp), GIF (.gif), JPEG (.jpg)
- PICT (Mac only)

Other graphics file formats may also work, such as those included in the list below:

- PNG (.png), TIF (.tif), black-and-white PCX (.pcx)

There are many variations of some types of graphics files. If you experience problems inserting an image, you may want to try converting the image to one of the recommended formats and try to reinsert the image again.

Inserting Images on Tests

When you want to include an image on a test, place the cursor in the editing field where you want the graphic to appear, and then select "Picture" from the Insert menu. Use the Open... dialog to locate the image file on your computer, select it, and click Open. The picture appears in your question.

1) Which of the labeled parts of the tooth is made up of a nonliving compound of phosphate and calcium?

You can also copy and paste images from other documents into TestGen questions, as long as the file types are compatible.
Inserting Images in Testbanks

When you insert an image in a question during testbank editing, it is stored in the Miscellaneous category of the Graphics Library. If you want images to be grouped by chapters or other categories in the Graphics Library, you need to add the graphics to the Graphics Library first, and then place the images into questions from the Graphics Library. For more information, see the Graphics Library topic in the "Other Advanced Editing" section of TestGen Help.
Adding New Questions to Tests

In addition to using questions transferred from a testbank, you can add your own questions to tests by either of these methods:

- Drag one of the question templates from the Resource Library onto your test. More details about question templates are in the section "Using Resource Library Templates."

- Select a question on your test (its background changes color), and then select "Question" from the Insert menu. Choose a question type from the submenu to insert the new question template below the selected question on your test.

Entering Questions

Question types include: multiple-choice, true/false, short answer, essay, vocabulary, bimodal, and matching. When you insert a question template onto your test, click in the question field to type your question and replace any placeholder text that appears. The question field expands as you type. Use the Text Formatting and Equation Editing toolbars as needed to enter questions.

Entering Answers

The method for indicating the correct answer for a question varies by question type:

**Multiple Choice**

Fill in the four answer choices by clicking in each field and typing. You can add additional answer choices for multiple-choice and bimodal questions by dragging a Blank Answer Choice from the Resource Library into the answer choice list for a question. Rearrange the order of choices, if necessary, by dragging and dropping. If you need to delete an answer choice, select it so its background changes color, and then press the Delete key.

To **mark an answer choice as the correct answer**, select the answer choice so its background changes color. Then right-click the answer choice and select "Mark/Unmark as Correct" from the pop-up menu. You can also choose "Mark or Unmark as Correct Answer" from the Question menu.

**Short Answer, Essay, and Vocabulary**

To fill in the answer for the question, the Answer field needs to be showing below the question. If it is not, select "Preferences > Test Options" from the Tools menu and click the Descriptors tab. Check the box next to "Correct Answer" and click OK. Below the question, click just to the right of the word "Answer:" to place the cursor and begin typing. The answer field expands as you type.

**Answer Blanks for Short Answers**

When you want a short answer question to have longer or multiple answer lines for students to answer lettered parts of the question, select "Change Answer Blank" from the Question menu. A dialog opens for you to select the answer blank width and the number of answer blanks. If you want the answer blanks to be labeled with lowercase letters: a., b., and so on, check the box next to Show Labels.

**Note**: The option to show answer blanks must be selected on the Questions tab of the Test Options dialog in order for answer blanks to appear on the test.
**True/False**

To mark True or False as the correct answer for the question, the answer choices need to be showing below the question. If they are not, select "Preferences > Test Options" from the Tools menu and click the Descriptors tab. Check the box next to "Correct Answer" and click OK. Below the true/false question, select either True or False so its background changes color. Then right-click the answer choice and select "Mark/Unmark as Correct" from the pop-up menu. You can also choose "Mark or Unmark as Correct Answer" from the Question menu.

**Bimodal**

Bimodal questions look like multiple-choice questions in the Resource Library, but they can also function as short answer questions if the answer choices are hidden. You control whether bimodal questions are displayed as multiple-choice or as short answer by setting a preference on the Questions tab of the Test Options dialog.

If your preference is to display bimodal questions as multiple choice, then fill in the question and answer choices on the test as you would for a multiple choice question, as described above. If the preference is set to show bimodal questions as short answer questions, then fill in the question and answer as you would for a short answer question as described above.

**Matching**

Matching items include a numbered question field and a lettered answer field for you to complete. Groups of matching questions on tests are dynamic, meaning that as you add matching items to a matching group, the answer choices in column 2, the right-hand column, automatically and randomly rearrange themselves so that, in most cases, correct answers are not directly across from the questions they match.

**Location of Answer Choices**

For the first matching question you add to a matching group, the answer is directly across from the question. Answer choices rearrange themselves with each new matching item you add to the group. As you add additional matching questions to the same group, the matching choice for question 4, for example, might appear in position B. Fill in the question and the matching answer in the vacant positions.

**Match the following:**

<table>
<thead>
<tr>
<th>1) finger</th>
<th>A) long bone</th>
</tr>
</thead>
<tbody>
<tr>
<td>2) wrist</td>
<td>B)</td>
</tr>
<tr>
<td>3) sternum</td>
<td>C) flat bone</td>
</tr>
<tr>
<td>4) My new matching question</td>
<td>D) short bone</td>
</tr>
</tbody>
</table>

**Combining of Identical Choices**

Another dynamic aspect of matching questions is that if two or more questions in a matching group have identical answers, the answer appears only once in the answer choice column. If you add a matching question and fill in an answer choice that is identical to one that is already in the
column of choices, you will see the answer choices shuffle and combine. It's possible for the answer choice column to have fewer entries than the number of questions in the matching group.

Adding Foils to Column 2

If you want additional choices in column 2, the answer choice column, you can add “foils” to the answer choice list. To add a foil, open the Resource Library and click the plus (+) sign next to Other Templates. Drag a Blank Answer Choice from the Resource Library and drop it below any of the questions in the matching group. You can also add a foil by selecting “Blank Answer Choice” from the Question menu.

The blank answer choices is inserted in a random location in column 2, ready for you to fill-in. Other choices move down and are assigned new letters to accommodate the newly inserted choice.

Using foils can cause the number of items in column 2 to be greater than the number of questions in the group due to the extra answer choices.

Entering Alternate Correct Answers

When you create questions for web tests that use the TestGen plug-in or Blackboard, you can set up short answer questions or bimodal questions (in short answer form) so they can accept more than one form of the correct answer. If students match any of the answers in the list, the question is marked as correct. A green evaluated answer icon [E] next to an answer indicates that more than one form of the answer will be accepted as correct.

Evaluated Answer Editor

To view or add evaluated answers for a short answer or bimodal question on a web test, select “Evaluated Answer Editor” from the Tools menu. This opens the Evaluated Answer Editor. The example below uses the L (literal) option to list acceptable variations in the text-based answer.

25) The most common systemic disorder that causes peripheral neuropathy is _______.
Answer: Diabetes mellitus

Enter additional forms of the correct answer to be accepted during TestGen Plug-in testing:
Answer 1: (exact match) Diabetes mellitus
Answer 2: Diabetes
Answer 3:
The example below also uses the \texttt{L} (literal) option to list various orders and punctuation for a text-based answer that involves words for two fill-in blanks.

84) The police function is divided into the two major roles: the \underline{\hspace{2cm}} role and the \underline{\hspace{2cm}} role.

Answer: proactive, reactive

More detailed explanations and examples are given in the section of this guide titled "Defining Evaluated Answers for Short Answer Questions."
Editing Test Content
Deleting Questions from Tests

It's easy to remove a question from a test if you decide you do not need it. You can delete one question at a time, a continuous block of questions, or several questions that are not in a continuous block.

Deleting a Single Question

First select the question you want to delete by clicking the test page near the left edge of the question number. You will know you have the entire question selected when its background changes color. Then press the Delete key, click the Cut button, or select "Cut" or "Delete" from the Edit menu. The question is removed from the test and the questions below move up on the page to fill the space. Questions renumber automatically.

Deleting a Continuous Block of Questions

To delete a continuous block of questions, hold down the Shift key and select the first question and the last question in the block. The background for these questions and all those in between change color to let you know they are all selected. Then press the Delete key, click the Cut button, or select "Cut" or "Delete" from the Edit menu. All the selected questions are removed from the test and the questions below move up on the page to fill the space. Questions renumber automatically.

Deleting Multiple Questions Not Continuous

To delete several questions that are not all in a continuous block, hold the Ctrl key and click each question you want to delete so that it becomes selected. Then press the Delete key, click the Cut button, or select "Cut" or "Delete" from the Edit menu. The questions are removed from the test and the remaining questions move up on the page to fill the space, renumbering as needed.

Locked Questions on Pre-made Tests

Sometimes, pre-made tests are included with a testbank from a publisher, and it's possible that one or more of the questions on the pre-made tests could be locked for security purposes. When you open the test, the locked questions will be marked with a broken pencil icon to the left of the question number as shown below.

Locked questions cannot be modified or deleted from the test, but you can move or scramble the questions as desired. You can also copy the locked questions or add new questions to the test.
Adding Notes to Tests

In addition to adding questions, answers, instructions, question type headers, and page headers and footers on tests, you can add your own notes before any question on a test. Notes might include special instructions for a question or group of questions, part headings for the test, or messages to test takers.

Adding Notes

To add a note to a test, display the Testbank Library and click the Resource Library tab. Click the [+] next to Notes and find "Blank note" in the list of items. Drag the blank note onto the test window and drop it above any test question. The note contains the words "Blank note" until you click in the note field on the test and begin to type.

Type text as desired—you can change the font, font size, style, color, alignment, and spacing as needed. You can also insert symbols, templates, graphics, tables, and graphs, just as with other editable fields on tests.

Each note becomes attached to the question that follows it, so if you move or reorder a question that follows a note, the note moves with the question.

Deleting Notes

To remove a note from a test, delete all the content (text, spaces, images, etc.) from the note so that the note field is blank. When you click outside the empty note field, you will receive a message asking if you want to remove the note from the test.
Changing Question Types

On rare occasions, you may want to change a question from one type to another. It is possible, though not always desirable, to do this for any question on a test. First select the question you want to change by clicking on the question number so the background of the question changes color. Then right-click on the question and select "Change Question Type" from the pop-up menu. You can also select "Change Question Type" from the Question menu.

In the Change Question Type dialog, select the new question type from the drop-down menu. In some cases, if data will be lost from a question, you will receive a message. For example, changing a multiple-choice question to a true/false question will result in the loss of the answer choices. Changing a true/false question to a multiple-choice question lists "True" and "False" as choices A and B, without any additional choices.

Special Note for Bimodal Questions

To switch a bimodal question between its multiple-choice and short answer formats, do not use the Change Question Type option. Leave the question as a bimodal question, and use the [BI] button on the Standard toolbar to switch between the multiple-choice and short answer forms of a bimodal question. When you start with a bimodal question, switching between the short answer and multiple-choice forms does not lose any of the answer choices.
Working with Questions

Pinning Questions and Answer Choices on Tests

Use the Pin option to prevent questions or answer choices from shifting positions on tests when test items are scrambled. Pinned questions or answer choices are marked with a non-printing pin symbol that is only visible on-screen in TestGen.

Pinning Questions

To prevent one or more questions from shifting positions during a scramble, select one or more questions on the test. Be sure the entire question, not just the question or answer field, is selected by clicking just to the left of the question number so that the background of the question changes color. Then select "Pin/Unpin Question Position" from the Question menu or the Standard toolbar.

A small push pin marks pinned questions on a test as shown below.

<table>
<thead>
<tr>
<th>3) The monthly supply of desktop personal computers is given by the equation $Q_S = 15,000 + 43.75P$. At a price of $800, what is the price elasticity of supply?</th>
</tr>
</thead>
<tbody>
<tr>
<td>4) Refer to the question above. At a price of $750, what is the price elasticity of supply?</td>
</tr>
</tbody>
</table>

To remove a pin from a pinned question, select the question and select "Pin/Unpin Question Position" from the Question menu or the Standard toolbar.

Pinned questions do not move from their locations if a test is scrambled or if you print multiple versions of a test and choose to scramble the question order. For example, an item pinned at number 3, will remain in the number 3 position even when other questions change positions.

When a test contains adjacent pinned questions, and you export the test as a question pool for Blackboard, the adjacent pinned questions are treated as a question group. If any one of the question group is selected, then all will be selected and transferred to the test in their original, relative order.

Note: Adding or deleting questions ahead of pinned questions will cause test questions to renumber, affecting the relative position of the pinned question.

Note: You cannot apply a SmartSort to a test that has pinned questions.

Pinning Answer Choices

The order of multiple-choice and bimodal answer choices can be shuffled when a test is printed and multiple forms are generated or when a test is used online. It is important to pin answer choices such as "none of the above" or "all of the above" that need to remain in place when other choices are shuffled. If an answer choice such as "Both B and C are correct" is the correct answer, choices B and C also need to be pinned in place. If "Both B and C are correct" is pinned, but is NOT the correct answer, then B and C usually do not have to be pinned in place.

To keep an answer choice in a static position, select the answer choice by clicking just to the left of the answer choice letter so that the answer choice changes color. Then click select "Pin/Unpin
Test Gen 7.4 Help

Answer Choice” from the Question menu or the Standard toolbar. A small pin appears next to the answer choice, and the answer choice will not change its position if other unpinned answer choices are shuffled.

1) A fibrous joint that is a peg-in-socket is called a ______ joint.
   A) syndesmosis
   B) suture
   C) synchondrosis
   D) gomphosis
   ◐ E) none of the above

Answer: D

To remove a pin from a pinned answer choice, select the answer choice and select "Pin/Unpin Answer Choice" from the Question menu or the Standard toolbar.
Rearranging Questions on Tests

When you make a new test, questions remain in the order that you create when you transfer items from the testbank. You can leave questions in this "user-defined" order or choose a SmartSort. When you choose a User-Defined order for a test, you can choose the exact order for the test questions. The program will not reorder the questions in any way unless you print multiple forms and request scrambling or use a scrambled order for web tests.

When questions are in User-Defined order, you can change the order of the questions by dragging them from one location to another. Select a question on the test by clicking to the left of the question number so the background of the question changes color. Then click on the question, hold down the mouse button, and drag the question until a horizontal line appears below the question where you want to insert. Release the mouse button to drop the question.

You can also use cut-and-paste to move questions.

To have TestGen automatically sort questions by testbank order, question type, or difficulty, or by other custom criteria, choose one of the question sorting options on the Sort dialog.
Sorting Questions on Tests

TestGen provides a set of predefined sorting methods, called "SmartSorts," which automatically group or arrange questions by testbank order, by question type, or according to custom sort criteria. To use a SmartSort, click in the test editing window (be sure the cursor is not in an edit field) and then click the A-Z Sort button or select "Sort" from the Question menu. This displays the Specify Sort Order dialog.

Make a selection by clicking one of the radio buttons.

Note: If a test contains "pinned" questions, the questions need to be unpinned before any SmartSort sort can be applied.
User-Defined Order

When you start a new test, no SmartSort is applied, and test questions remain in the order that you create when you transfer items from the testbank. You can leave questions in "user-defined" order or choose a SmartSort. When you choose user-defined order for a test, you can choose the exact order for the test questions. In either Question view or ID view, you can rearrange test questions by dragging them from one location to another. Select a question on the test and hold down the mouse button; then drag until a horizontal line appears below the question where you want to insert. Release the mouse button to drop the question.

SmartSort by Testbank Order

When you choose SmartSort by Testbank Order, test questions are put in order according to their question IDs. For example, the questions are ordered by chapter, question type, and question number, or by chapter, section, problem type, and question number. If tests contain questions from more than one testbank, testbank names are sorted alphanumerically.

SmartSort by Question Type

When you choose SmartSort by Question Type, test questions are put in order according to the types of questions used in the testbank. You specify the order of the question types by assigning a number to each question type.

Note: If you change the form of a bimodal question from its multiple-choice form to its short answer form, or from its short answer form to its multiple-choice form, and the test uses a SmartSort by Question Type, the bimodal question may move to a new location on the test.

Custom SmartSort

When you choose Custom SmartSort, you can specify up to three levels of sorting for a test. Use the pull-down menus on the sort dialog to set up the sort criteria. For example, you can arrange to sort questions first by question type, then by chapter, and then by difficulty level. You do not need to specify all three levels.

Switching Sort Methods

You can switch between SmartSorts at any time, or switch to a User-Defined order after using a SmartSort.

SmartSort to SmartSort

When you switch from one SmartSort to another after you have selected questions for a test, the questions are reorganized according to the rules of the new SmartSort.

SmartSort to User-Defined Order

When you switch from a SmartSort to User-Defined order after choosing questions for a test, all the SmartSort rules for grouping questions are ignored and the test becomes a list of questions that you can rearrange in any order. Initially, the order of the questions on a User-Defined test converted from a SmartSort is exactly the same as on the SmartSort test. If you add new questions after converting to a User-Defined order, they are inserted where you want them and not sorted in any way by TestGen.
User-Defined Order to SmartSort

When you switch from a User-Defined order to a SmartSort after choosing questions for a test, the questions will be regrouped according to the SmartSort.

Caution: If you switch from User-Defined order to a SmartSort, the program does not remember your User-Defined order, and you cannot automatically return to it after a SmartSort has been applied.
Scrambling Questions and Answer Choices on Tests

You can have TestGen scramble the order of questions and answer choices on your test. When you have the test window open and active, select "Scramble" from the Question menu or click the Scramble button on the Standard toolbar and choose what to scramble:

All Questions—The order of test questions is randomly scrambled, regardless of which questions are selected.

Selected Answer Choices—The order of answer choices is scrambled for each selected multiple-choice or bimodal question.

All Questions and Answer Choices—Both the order of all the test questions and the order of answer choices for multiple-choice and bimodal questions are scrambled, regardless of which questions are selected.

Note: If you scramble test questions while a SmartSort is in effect, the questions on the test are randomly mixed at the lowest level of sorting so that the SmartSort rules are still enforced. For example, if the SmartSort is by question type, then questions of the same type remain together, but the order of questions within each question type is scrambled. Test items that are linked to a shared instruction will remain grouped during random scrambling.

Note: If the test questions are sorted by testbank order, the Scramble option is unavailable.

Scrambling a Test in User-Defined Order

If you have test questions in a user-defined order and select to scramble questions, the questions are scrambled at random to produce the new order. No grouping occurs except for shared Instructions. Pinned questions and answer choices, however, remain stationary while everything else scrambles around them.

Scrambling a test that is in user-defined order may or may not produce desirable results, depending on the types of questions on the test. For example, if you manually put questions in order by question type, without using the SmartSort, scrambling questions on the test will usually mix up the questions so they are no longer grouped by type.
Assigning Point Values on Tests

When you create a paper test or a web test to be used with the TestGen plug-in, Blackboard, or Web CT, you can assign point values to test questions using the Points button on the Standard toolbar. (If the Standard toolbar is not visible, select "Toolbars > Standard" from the View menu.)

New questions that you add to the test have a default point value of "1" unless you assign another value. To assign point values greater than 1, select one or more test questions and click the Points button or select "Assign Point Value" from the Question menu. Enter the number of points for the question(s) and click OK.

As you are building a test, you can see the total number of points assigned for the test at the top of the test window.

When the test runs in the TestGen plug-in in an online product that supports points, the point values for each question are displayed at the top of the question window. Point values can also appear in the go-to-question window and in the test summary window of online tests. At the end of the test, the points scored by the student and the total number of points show in the test results window along with the raw and percent scores. (If the point values for all the questions on the test are "1", then point values are not displayed.)

*Note:* Be sure to confirm that your online product has implemented point scoring before assigning points to each question. You can determine this by referring to the online help system of the product you are using.

When point values are assigned to questions on paper tests, there is an option to display the point values on the test's answer key just before you print the test.
Locking/Unlocking Number Values on Tests

If questions on a test contain either algorithmically generated variables or user-defined variables and you can automatically recalculate variables when you print multiple forms of the test so that each form is different.

However, if you want specific questions to retain the values you see on-screen, you can "lock in" the number values for those questions on the test. To lock the current values, select the question(s) you want to lock and then click the Lock button on the Standard toolbar or select "Lock-Unlock Number Values" from the Question menu.

An upward pointing arrow appears next to the question(s) you selected to indicate that the question is variable, but the values are locked. A downward pointing arrow next to the question indicates that the question is variable, but the on-screen values are not locked.

To unlock a question and make it variable again, select the question and click the Lock button again.

Note: The locked and unlocked values symbols do not print on a test.

---

Factor completely. State that the polynomial is prime if it cannot be factored.

1) \(x^2 - x - 6\)
   - A) \((x + 2)(x - 3)\)
   - B) \((x + 3)(x - 2)\)
   - C) \((x + 1)(x - 6)\)

2) \(x^2 + 8x - 20\)
   - A) \((x + 10)(x - 2)\)
   - B) \((x - 10)(x + 2)\)
   - C) \((x - 10)(x + 1)\)
Changing Question Number Style for Tests

Choose "Preferences > Test Options" to set or change the numbering style for questions on tests. Click the Numbers tab and make changes for the question number style or starting number. Click the Set as default... button if you want your selections to remain in effect for all future tests. Click OK to close the dialog and apply the changes to the current test.

Numbering Style

Choices for numbering style on tests include the question number followed by a parenthesis or followed by a period. Click the radio button next to the style you prefer.

First Question Number

Normally, the first question number for tests is "1," but you can choose a different number, if necessary. Enter the desired starting number in the input box.

Renumber by Question Type

Standard numbering for a test uses consecutive question numbers from the beginning to the end of the test. You can restart the numbering for each question type on the test by checking the "Renumber by question type" box. The numbers for each question type start with the number you have set as the first question number (see above) and continue with consecutive numbers until the next question type starts. For this option to work, you must have question type headers displayed. It also is most effective if questions are sorted by question type.

Do Not Display Question Numbers

If you want to turn off all the question numbers on a test, check the box next to "Do not display question numbers."
Adjusting Test Page Layout and Display

Using Question Type Headers on Tests

TestGen supplies a standard question type header for each of the six main question types: multiple choice, true/false, short answer, essay, matching, and vocabulary. Question type headers are initially generic, not specific to a particular group of questions. They are most useful when a test is sorted by question type.

Along with the option to either display or not display question type headers on tests, you also have the option to set up the wording that you prefer for each question type header.

Displaying Question Type Headers

To turn question type headers on or off, select "Preferences > Test Options" from the Tools menu. At the bottom of the Questions tab, there are two radio buttons for Question Type Headers. Select one of these buttons to display or hide the question type headers and click OK to apply your choice to the current test.

If you click the Set as default... button, your selection is saved and applies to the current test as well as to all the tests you create in the future.

Note: If you choose to display question type headers, but all the text has been removed from them, you won't see any headers on the test.

Editing Question Type Headers

To modify the wording of any of the question type headers, select "Question Type Headers" from the Tools menu. If question type headers are already displayed on the test, you can also double-click any of the headers to open the Edit Question Type Headings dialog.
Make changes as needed. If a question type header needs to include a symbol or expression, click one of the buttons on the Equation Editing toolbar to display a palette and select a symbol to insert at the cursor location. (If the Equation Editing toolbar is not visible, select "Toolbars > Equation Editing" from the View menu.) You do not need to edit all of the question type headers if your test includes only one or two question types. Click OK to apply your changes to the current test.

If you click the Set as Default... button, your selection is saved and applies to the current test as well as to all future tests you create.
Using Page Headers and Footers on Tests

On printed tests, you can customize what appears in the test headers and footers.

Editing Test Headers and Footers

With a test window open, either select "Header-Footer Editor" from the Tools menu or double-click on the header or footer area of the test page. This opens the Header & Footer Editor.

Page 1 Header and Page 1 Footer—Whatever you put in these fields appears at the top (header) and bottom (footer) of the first page of your test.

Page 2 Header—Whatever you put in this field appears at the top of page 2 and every test page that follows.

Page 2 Footer—Whatever you put in this field appears at the bottom of page 2 and every test page that follows.

Headers and footers may include text as well as graphics, tables, and symbols. Select "Toolbars" from the View menu to display the Standard toolbar, the Text Formatting toolbar, or the Equation Editing toolbar. You can also select "Show Rulers" from the View menu if you need to set tabs or adjust alignment.

To close the Header-Footer Editor and save your changes for the current test, click Save or select "Close" from the File menu. To save the headers and footers as the new default for future tests, click Save as Default. Click Cancel to close the window without making any changes.
Inserting Page Numbers and Date on Tests

On paper tests, you may want the test header or footer to include automatic page numbering or the date. Double-click a test header or footer to open the Header & Footer Editor, or select "Header-Footer Editor" from the Tools menu.

Automatic Page Numbering

Place the cursor at the location where you want the page number to appear and select "Page Numbers" from the Insert menu. A "#" placeholder appears while you are editing, but is replaced by consecutive page numbers when you close the Header & Footer Editor.

The same procedure can be used to insert page numbers in headers and footers for printed testbanks.

Page Numbers Outside of Headers and Footers

Although page numbers are designed to be inserted in headers and footers, it is possible to insert them in other editable locations on a test. When you insert a page number, the "#" placeholder appears, but then changes to the appropriate page number when you click outside the edit field. Page numbers inserted in this manner do not carry over to the same locations on other pages.

Page Numbers of Multiple Test Forms

If you choose to print multiple forms of a test, you can distinguish one form from another by inserting the page number in either a header or footer. A different letter of the alphabet will print as part of the page number for each form of the test. For example, if you insert the page number in the Page 1 Footer, the first form of the test will use A-1, A-2, and so on, the second form of the test will use B-1, B-2, and so on.

Insert Date

Place the cursor at the location where you want the date to appear and select "Date" from the Insert menu. The date appears in the format MM/DD/YYYY. If the date is in the page 1 header or footer, it appears only on the first page of the test. If the date is in the page 2 header or footer, it will appear in the same location on every page of your test after the first page.

The same procedure can be used to insert the date in headers and footers for printed testbanks.

Note: The date is obtained from your computer system whenever you open or print the test and may change from the date you see when you create the test.
Inserting Page Breaks on Tests

After you select all the questions for a test, you may want to insert one or more page breaks to force specific questions or sections of a test to start at the top of a new page. To insert and remove page breaks, the test must be in Question view.

Inserting a Page Break

To insert a page break in a test, select the question on your test that you want to be at the top of a new page. Then select "Page Break" from the Insert menu. A horizontal line appears where the page break occurs and the selected question goes to the top of the next page. The page break indicator is a non-printing item.

Note: The Scramble option is disabled if you insert page breaks on a test.

Removing a Page Break

To remove a page break from a test, use the mouse pointer to select the horizontal line that indicates the page break. Then press the Delete key. The questions will reflow on the pages to fill in any blank spaces caused by the page break.
Setting Question Display Options for Tests

When you view a test in Question view, you see the pages of the test as they will be printed. To change settings related to the display of specific question types and answer blanks, select "Preferences > Test Options" from the Tools menu and click the Question Display tab.

Click one of the radio buttons in each group to indicate your preferences. Then click OK. If you want to save the settings so they apply to the current test as well as all future tests, click the Save as default... button before you click OK.

The categories and settings are described on the next page.
Column Format

Select one of the choices to put the test in either one-column or two-column format. One-column format works best for tests that contain wide tables or graphics, since two-column format could cause clipping of graphics and tables that are too wide. Two-column format works best when questions and answer choices are relatively short. Depending on the size of the left and right margins, each column will be about 3" to 3.5" wide. The answer key is also printed in multiple-columns.

Answer Blanks

Select one of the choices to display or hide answer blanks on a test. Answer blanks for multiple-choice, true/false, short answer, and matching questions print along the right edge of the test page. Essay questions do not have answer blanks, but can have workspace below for students to write their answers.

True/False Questions

This option applies to printed tests only. Select one of the choices to print standard write-on lines for answer blanks or to print "T or F" instead of answer blanks for true/false (TF) questions. This is a global setting for all the true/false questions on the test.

Form of Bimodal Questions

Select one of the choices to indicate if you want bimodal (BI) questions to be displayed as multiple-choice questions or as short answer questions. This is a "global" setting that affects all the bimodal questions on your test. However, you can override the global setting for individual questions on the test by clicking the bimodal BI button on the Standard toolbar after selecting one or more bimodal questions on a test.

Note: If you change the form of a bimodal question from multiple-choice to short answer, or vice versa, and the test is using a SmartSort by question type, the question may move to a new location on the test.

Form of Vocabulary Questions

Select one of the choices to have either the "term" or the "definition" displayed for vocabulary (VO) questions. This is a global setting the affects all the vocabulary questions on the test. However, you can override the global setting for individual questions on the test by clicking the bimodal BI button on the Standard toolbar after selecting one or more vocabulary questions on a test.

Question Type Headers

Select one of the choices to either display or not display question type headers at the beginning of each question type section on a test.
Changing Answer Display Options for Tests

When you want to change the way answer choices are shown for multiple-choice questions on your test, or include answer lines for essay questions, select "Preferences > Test Options" from the Tools menu and click the Answer Display tab. Be sure the test is in Question view to observe these settings.

![Test Options window]

**Multiple Choice Answer Styles**

Select the style for how you want multiple choice answers to appear:

- A)
- A.
- a)
- a.
- 1)
- 1.
- □ Alternate ABCDE/FGHJK

**Multiple Choice Answer Layout**

Select the layout for how you want multiple choice answers to appear:

- Display answer choices horizontally if space permits
- Display answer choices vertically

**Essay Answer Layout**

Essay Questions

- Display lined space for answers
- Do not display lined space for answers
Multiple Choice Answer Styles

Click one of the radio buttons to indicate which style you want to use to label answer choices for multiple-choice and bimodal questions and click OK. If you want to save the settings so they apply to the current test as well as all future tests, click the Set as Default... button before you click OK.

Answer Bubbles

The last of the multiple choice answer styles provides the choice of an oval, or "bubble," that will contain the answer choice letter so students can fill-in the oval for the correct answer with a pencil or pen.

Preprinted Scoring Sheets

If your test uses multiple-choice questions with five or fewer answer choices, and you use preprinted scoring sheets that have alternate sets of letters for every other row, check the box next to "ABCDE/FGHJK." This assigns alternate sets of letters to the choices for multiple-choice questions, using ABCDE for odd-numbered questions and FGHJK ("I" intentionally omitted) for even-numbered questions. Students can mark their answers on the sheets, which can then be machine-scored.

Multiple Choice Answer Layout

Your choice for this section determines whether answer choices for multiple-choice and bimodal questions are

- arranged in rows horizontally across the page, or
- stacked in a column vertically.

If you choose to have answer choices arranged horizontally across the page, TestGen evenly fits two to five choices across the page, depending on the width of the widest answer.

Essay Answer Layout

Select one of the choices to either display or not display write-on lines when workspace is shown for essay (ES) questions. When write-on lines are selected, each line of preassigned workspace displays a horizontal line for students to write their answer to the question.
Changing Descriptor Display Options for Tests

When you want to change what descriptors are displayed for each item on a test, select "Preferences > Test Options" from the Tools menu and click the Descriptors tab.

When you make your selections and click OK, descriptors for the categories you have checked appear below each question. If you want to save the settings so they apply to the current test as well as all future tests, click the Save as default... button before you click OK.

Note: Not all testbanks and question types may contain information for all the descriptor categories, so only the descriptor label will show on the test page if you choose a descriptor category that has no assigned values. Also, some items are displayed only when the test is in Question view.

Editable Descriptors

Most of the descriptors on a test are "view only" and are assigned to questions when a testbank is written. However, the following fields can be displayed and edited on a test.

Comment—Comments may be provided by the testbank author or the instructor who creates a test. Comments do not display when you view a test in ID view.

Correct Answer—All answers can be edited directly on the test page. For multiple-choice questions, identifying one of the choices as correct or incorrect changes the letters that are displayed below the question as the correct answer. Answers do not display when you view a test in ID view.
Uneditable Descriptors

The following fields are “view only” on tests, but most can be modified if you choose to edit the source testbank.

**Page Reference**—Page references refer to a page, set of pages, or feature in the textbook related to the question.

**Difficulty Level**—A number from 1 to 9 indicates the relative difficulty of the question, ranging from easy to difficult. The numbers 1, 2, and 3 are most often used to denote easy, medium, and difficult questions. A difficulty of 0 or blank means that no difficulty level has been assigned by the author.

**Question Type**—The question type is indicated by an abbreviation for the main types of questions in TestGen: multiple choice (MC), bimodal (BI), true/false (TF), short answer (SA), essay (ES), matching (MA), and vocabulary (VO).

**Workspace Value**—A number from 0 to 15 indicates the number of blank lines that are displayed for the question if the test is set up to show preset workspace.

**Number of Variations**—The number of variations (Var:) tells how many variations are available for the question. If the question does not include any variables, then Var: is 1. When variables are included in the question, the number of variations can range anywhere from 1 to 50+ (more than 50), depending on the number of variables and the range for each variable.

**Variant Status**—When you check the Variant Status box, a downward pointing arrowhead (v) appears next to questions that contain variables and have more than one variation.

**Pronunciation**—Vocabulary (VO) questions can include a pronunciation to show a phonetic spelling of the term. The pronunciation can be displayed or printed on tests. This pronunciation does not display in ID view.

**Question Dates**—TestGen stores and displays the date a question was created and modified.

**Topic, Skill, and Objective**—These three categories are shared fields that contain the topic, skill, or objective for a question. The category names and type of content vary from testbank to testbank.

**User 1 and User 2**—These two categories are shared fields that assign additional information to a question; the category names and type of information vary from testbank to testbank.

**Explanation**—Explanations may be provided by the testbank author to explain the correct answer for multiple-choice, true/false, or short answer questions. Incorrect answer choices for multiple-choice questions may also have explanations. Explanations do not display in ID view.
Adjusting Workspace and Question Spacing

TestGen has controls for displaying both workspace within a question and spacing between questions on tests.

Question Workspace

Some testbanks (for math, in general) have a preset amount of workspace assigned to each question by the testbank author to allow students space to write their answers or show their work on a paper test. By default, this workspace does not show up on a test when you transfer questions from the testbank.

To make the assigned workspace, if available, display on tests as you transfer items from the testbank, select "Preferences > Application" from the Tools menu and change the workspace setting on the Transfer Options tab.

Note: This setting applies only as you transfer items from a testbank. After test items are on the test page, you can adjust spacing between questions either globally, affecting all questions on the test, or manually, on an item-by-item basis. To adjust workspace values in a testbank, open the testbank in the edit window, select a question, and display the Properties window for the question.

Spacing Between Questions

To adjust the blank space between questions globally, affecting all questions on the test, go to the Default Styles tab of the Test Options dialog. Use the settings in the Spacing section to set a preference for spacing between questions that applies to the current or future tests.

Manually Adjusting Spacing

To adjust the spacing between test questions on a case-by-case basis, do either of the following:

- Put the cursor at the end of the question field and press the Enter or Return key one or more times to add blank lines. If there is too much workspace at the end of a question, put the cursor at the end of the workspace and use the Backspace key to delete the unwanted lines.
- Put the cursor in the one-line editable field between questions and press Enter or Return to increase the space between two questions.
Testbank Library

Opening and Closing Testbanks

This section discusses how to open and close testbanks in order to view questions and build tests or to modify testbank content.

Opening Testbanks to Make Tests

In order to make tests with TestGen, unless you plan to write all new questions, you need to use a testbank from the Testbank Library. Testbanks are added to the Testbank Library during installation or can be added manually at a later date.

When you want to choose questions from a testbank in the Testbank Library, click the plus (+) sign next to its title or double-click the title. You can open or close chapters and sections of a testbank in the same way, by either:

- clicking the plus (+) and minus (–) signs to the left of each title or subheading, or
- double-clicking on a title or subheading.

Open each chapter or section as needed to display testbank questions and choose items for your test.

Expanding and Collapsing Sections

The options to "Expand Selection" or "Collapse All" on the Navigate menu have keyboard shortcuts that let you quickly show and hide questions in a testbank. To use the keyboard shortcut for "Expand Selection," select a section title and press Ctrl-E (Windows) or Apple-E (Macintosh). The section expands to show all the questions.

To use the keyboard shortcut for "Collapse All," select a chapter or section heading and press Ctrl-K (Windows) or Apple-K (Macintosh). This collapses all sections in the window.

Opening Testbanks for Editing

In order to open a testbank for editing, you need to have testbank editing enabled, which is done through a setting on the Testbank Editing tab of the Application Preferences window. With testbank editing enabled, you see the Recent Testbanks list on the Startup pane. If the testbank you want to edit is listed in the Recent Testbanks list, click its title to open the testbank in the editing window.
If the testbank you want to edit is not in the Recent Testbanks list, you can open the testbank for editing in one of the following ways:

- Select the testbank title in the Testbank Library and select "Edit Testbank" from the File menu.
- Click "Browse for other testbanks" on the Startup pane to open a dialog where you can navigate to a testbank on your computer and select a file to open.
- Select "Open" from the File menu and change the File Type drop-down menu to look for Testbank files (*.bok). Locate a testbank file on your computer and open it in the testbank editing window. By default, testbanks are stored in a Testbanks folder inside the TestGen folder, which is located in your system-approved user documents folder.

Once the testbank opens in the testbank editing window, you can view questions or their IDs by opening chapters or sections in the same way as you would in the Testbank Library, using the plus (+) signs or Navigation menu options, as described above.
Changing Answer Display for Testbanks

To change the answer choice display and the layout of answer choices for multiple-choice and bimodal questions in a testbank, you need to edit the testbank answer display options.

Select the title of the testbank you want to change and select "Edit Testbank" from the File menu. (Testbank editing must be enabled for you to make changes in the answer display options.) This opens the testbank in the testbank editing window. Click in the testbank editing window and then select "Preferences > Testbank Options" from the Tools menu.

When the Testbank Options window opens, click the Multiple Choice and Bimodal Answer Display tab.

![Testbank Options window]

Make your selections in the window, then click OK to close it. Then close the testbank editing session. When you next view the testbank in the Testbank Library, it uses the settings you selected.

Display Multiple Choice and Bimodal Answer Choices in Testbank

By default, when you view testbank questions in the Testbank Library, you see the answer choices for multiple-choice and bimodal questions. To fit more questions on the screen, in testbanks in which the answer choices are not needed in order to select questions, you can display only the question stem and no answer choices while viewing testbanks.

Multiple Choice Answer Layout

Your choice for this section determines whether answer choices for multiple-choice and bimodal questions are stacked in a single column (vertically) or arranged horizontally across the page, as space permits. If you choose to have answer choices arranged horizontally across the page, TestGen fits them into two to five columns, depending on the width of the widest answer.
Changing Descriptor Display for Testbanks

The first time you open a testbank, the display shows questions and information as it was set up by the testbank author—usually questions, answers, and applicable descriptors. To change the display of answers and descriptors in a testbank, you need to open the testbank for editing and change the descriptor display options.

Select the title of the testbank you want to change and select "Edit Testbank" from the File menu. (Testbank editing must be enabled for you to make changes in the descriptor display options.) This opens the testbank in the testbank editing window. Click in the testbank editing window and then select "Preferences > Testbank Options" from the Tools menu.

When the Testbank Options window opens, click the Descriptors tab, which contains controls to display or hide various testbank question descriptors while viewing a testbank in Question view or ID view.

Check the box for each descriptor you want to view in the current testbank. After making your selections, click OK to close the window. The selected descriptors show for each question in the testbank.

Note: Not all testbanks and question types contain information for all the descriptor categories, so only the descriptor label will show if a question has no assigned value for the selected descriptor category.

When you finish the testbank editing session and next view the testbank in the Testbank Library, it shows the descriptors you selected.

Testbank Descriptors

The descriptor fields are as follows:

Page Reference—Page references refer to a page, set of pages, or feature in the textbook related to the question.
**Difficulty Level**—A number from 1 to 9 indicates the relative difficulty of the question, ranging from easy to difficult. The numbers 1, 2, and 3 are most often used to denote easy, medium, and difficult questions. A difficulty of blank or 0 means that no difficulty level has been assigned by the author.

**Question Type**—The question type is indicated by an abbreviation for the main types of questions in TestGen: multiple choice (MC), bimodal (BI), true/false (TF), short answer (SA), essay (ES), matching (MA), and vocabulary (VO).

**Workspace Value**—A number from 0 to 15 indicates the number of blank lines that will show below the question if workspace is displayed on a test.

**Number of Variations**—The number of variations (Var:) tells how many variations are available for the question. If the question does not include any variables, then Var: is 1. When variables are included in the question, the number of variations can range anywhere from 1 to 50+ (more than 50), depending on the number of variables and the range for each variable.

**Variant Status**—When you check the Variant Status box, a downward pointing arrowhead (v) appears next to questions that contain variables and have more than one variation.

**Pronunciation**—Vocabulary (VO) questions can include a pronunciation to show a phonetic spelling of the term. This field does not display in ID view.

**Question Dates**—TestGen stores and displays the date a question was created and modified. The dates cannot be edited.

**Topic, Skill, Objective**—These three categories are shared fields that contain the topic, skill, or objective for a question. The category names and type of content vary from testbank to testbank and can be edited in testbanks. **Note:** The names of these categories, as well as User 1 and User 2, may be different due to changes during testbank authoring.

**User 1, User 2**—These two categories are shared fields that assign additional information to a question; the category names and type of information vary from testbank to testbank and can be edited in testbanks.

**Correct Answer**—In Question view, shows the letter of the correct answer for a multiple-choice question, the word True or False for true/false questions, full answers for short answer or essay, the term or definition for vocabulary questions, the correct match for a matching question. Answers do not display in ID view.

**Explanation**—Explanations may be provided by the testbank author to explain the correct answer for multiple-choice, true/false, or short answer questions. Incorrect answer choices for multiple-choice questions may also have explanations. Explanations do not display in ID view.

**Comment**—Comments may be provided by the testbank author. Comments do not display in ID view.
Getting Testbank Summary Information

The Testbank Info window shows a summary of the testbank’s contents as well as its computer filename and location. To display testbank information, select any question or heading for a testbank in the Testbank Library. Then select “Testbank Information” from the View menu or click the Testbank Information icon on the Standard toolbar.

### Content Information

In the top portion of the Testbank Info window, use the drop-down menu to change the display and show details for the number of questions per question type, topic (or other available descriptor), or static vs. algorithmic.

### File Information

Although testbanks listed in the Testbank Library have descriptive names based on textbook titles, each testbank is stored on disk with a shorter computer filename. The book title shown in the Testbank Library is actually a link to the file on disk—a TestGen file that has a .BOK extension (filename.bok). It is possible to have two items listed with the same name in the Testbank Library, but each represents a different file on disk. This could occur if you have used the computer operating system to make a copy of a file and store it in a different folder, using the same filename, then added the copy to the Testbank Library.

Use the Testbank Info window to view the filename and location on disk for any testbank you select in the Testbank Library.
Switching Between Question View and ID View

There are two different viewing modes for questions in a testbank—question view and ID view. You can switch between the two viewing modes by selecting either "Question Text" or "Question IDs" from the View menu.

View Question Text

When you start TestGen and double-click on a chapter title or subheadings in a testbank, you see the questions contained in that chapter or section. For example, in question view, you might see:

```
1) Which of the following is necessary for proper conduction of

   A) Fe                  B) I                  C) P

   Answer: D

2) A phospholipid is usually:

   A) partially hydrophilic and partially hydrophobic.
     B) hydrophobic.
     C) hydrophilic.
     D) neither hydrophilic nor hydrophobic.

   Answer: A

3) In general, the category of lipids that we refer to as oils have

   A) a high water content.          B) long
```

Questions might also have additional information displayed below them—answer, page reference, topic, or other descriptors.
View Question IDs

To locate a particular question number more quickly, or to be able to select a block or assortment of questions more easily by choosing their question numbers, you can switch from question view to ID view.

Viewing question IDs shows a numerical representation of each question based on its location in the testbank. Each question ID includes a multi-part number that gives the question's relative position in the testbank and its question number. For example, the question ID "HAP 2.3-8" indicates chapter 2, subheading 3 (multiple choice), question 8 in the testbank abbreviated as "HAP."

Questions in ID view might also have additional information displayed below them—page reference, topic, or other descriptors.

Note: If a testbank has unnumbered "chapters" or sections in its table of contents, such as supplemental chapters or appendices, that interrupt the flow of consecutively numbered chapters, the question IDs will not reflect the chapter numbers. For example, if a supplemental chapter is between chapters 2 and 3, then the supplemental chapter IDs will start with "3" and the IDs for chapter 3 will start with "4".
Show or Hide the Testbank Library

The Testbank and Resource Libraries are displayed on the left side of the screen when you start TestGen. The right side of the screen is reserved for the Startup pane as well as tests and testbanks that you want to edit. In order to maximize the space available for editing and viewing tests, you can close the library pane on the left. Choose one of the following ways to hide or show the Testbank and Resource Libraries:

- Select "Hide Library" or "Show Library" from the View menu.
- Click the "Hide Library" or "Show Library" icon on the Standard toolbar.
- Right-click in either the library or editing area to display a menu and choose "Hide/Show Library."
Managing Library Content

The Testbank Library lists testbanks that you can use to create tests or open for editing. Testbanks listed in the Testbank Library have descriptive names based on textbook titles, but each testbank is stored on disk with a shorter computer filename. The title shown in the Testbank Library is a link to the file on disk—a TestGen file that has a .BOK extension (filename.bok).

This section discusses adding, deleting, and renaming testbanks, as well as resolving broken links.

Adding Testbanks to the Testbank Library

There are various ways to add testbanks to the Testbank Library during TestGen startup, later by browsing to locate a single testbank, or later to add all testbanks at once.

Add Testbanks During Startup

When you start the TestGen program and there are no testbanks in the Testbank Library, you can let TestGen search your computer for testbank files and list their titles in the Testbank Library. This option is useful if you have testbanks scattered about that you want to reuse with a new version of TestGen.

Add a Single Testbank by Browsing

After TestGen is installed, you can add testbanks one-at-a-time by opening the File menu or right-clicking in the Testbank Library and selecting "Add Testbank to Library". Use the browse dialog to locate and select a TestGen testbank (.bok) file on your computer and click Open to display the testbank's title in the Testbank Library.

Locate and Add All Testbanks

After TestGen is installed, if you have multiple TestGen testbanks on your computer, but not yet listed in the Testbank Library, you can select "Locate Testbanks" on the File menu. When you click OK, TestGen will search your computer's hard drive to find all the TestGen testbank (.bok) files and add their titles to the Testbank Library.

Note: When adding testbanks to the Testbank Library, no testbank files are moved on your computer. The titles listed in the Testbank Library are simply links to the existing testbank locations.

Deleting Testbanks from the Testbank Library

When you want to remove a testbank from the list of testbanks in the Testbank Library, select one or more testbank names from the list, and then do one of the following:

- Click the Delete icon on the Standard toolbar.
- Select "Delete" from the Edit menu.
- Press the Delete key on your computer keyboard.
- Right-click on a testbank name in the list and choose "Delete" from the contextual menu.

After you choose Delete, confirm that you want to remove the testbank from the Testbank Library.
Note: Deleting a testbank name from the list of testbanks in the Testbank Library does NOT delete the testbank file from your computer; it simply removes the library link.

Only complete testbanks can be removed from the Testbank Library. You cannot delete chapters, sections, or questions from a testbank in the Testbank Library. If you need to modify the contents of a testbank, enable testbank editing and make changes to the testbank in the testbank editing window.
Renaming Testbanks in the Testbank Library

You cannot change either the long name or the filename for a testbank in the Testbank Library unless you open the testbank for editing or change the filename using the computer operating system. If you open a testbank for editing, you can choose "Testbank Setup" from the View menu and change the title for the testbank. During testbank editing, you can also select "Save as New Testbank" from the File menu to save the current testbank using a new filename and add it to the Testbank Library.

Note: If you use the computer operating system to change the filename of (or move) a testbank that has been added to the Testbank Library, a broken link will result and TestGen will not be able to list the testbank in from the Testbank Library the next time you run TestGen.

Resolving Broken Links

When a testbank is added to the Testbank Library, TestGen links the testbank title with the testbank (.bok) file's location on your computer. Each time the Testbank Library is opened, all links to testbanks are validated to make sure the file is still available in the same location as when it was added to the Library. If the file has been moved, renamed, or deleted, and TestGen is unable to locate the .bok file for one or more testbanks in the Testbank Library list, you see a message to indicate the problem. Clicking OK closes the dialog and removes the affected testbanks from the Testbank Library list.

If you want the affected testbanks to be listed in the Testbank Library again, use the procedure described above for adding testbanks by browsing.
Resource Library

Using Resource Library Templates

The Resource Library contains Question Templates and Other Templates that you can drag into a test or testbank editing window. To use one of the prepared question templates while creating a test, display the Testbank Library on the left side of the screen and click the Resource Library tab. Then click the [+] sign next to Question Templates to display the names of the various question types you can drag onto your test.

Question Templates

Question templates let you add new, blank multiple-choice, short answer, true/false, bimodal, essay, matching, and vocabulary questions to a test or testbank.

Adding Multiple Choice Questions

To add a blank multiple-choice question to your test, drag the Multiple Choice template from the Resource Library into the test window. A pointer with a horizontal line between questions indicates the location for the new question when you drop it by releasing the mouse button. You can also select a question on your test, and then select "Question > Multiple Choice" from the Insert menu to insert a new question below the selected question.

Initially, the new question says "Multiple Choice" in the question field. Click on these words to place the cursor and begin typing your own question. In the same manner, click in each of the answer choice fields to fill in the answer choices. The question and answer choices fields expand as you type.

Answer Choices

You can delete an answer choice by clicking to the left of the answer choice letter to make the answer choice background turn black. Then press Delete or select "Delete" or "Cut" from the Edit menu. When only two answer choices remain, you will not be able to delete any more choices, since every multiple-choice question needs at least two answer choices.

You can add an answer choice by dragging a "Blank Answer Choice" from the Other Templates section of the Resource Library. Drop the blank answer choice below another answer choice to position it in the list of answer choices for the question. You can also select a question on your test, and then select "Blank Answer Choice" from the Insert menu to insert a blank answer choice at the end of the existing answer choices. The letters for other answer choices adjust automatically, depending on where the blank answer choice is inserted.

Correct Answer

To mark an answer choice as the correct answer, select the answer choice so its background changes color. Then right-click the answer choice and select "Mark/Unmark as Correct" from the pop-up menu. You can also choose "Mark or Unmark as Correct Answer" from the Question menu.
**Adding Short Answer and Essay Questions**

To add a blank short answer or essay question to your test, drag the Short Answer or Essay template from the Resource Library into the test window. A pointer and horizontal line between questions indicate the location for the new question when you "drop" it by releasing the mouse button. You can also select a question on your test, and then select "Question > Short Answer" or "Question > Essay" from the Insert menu to insert a new question below the selected question.

Initially, the new question says "Short Answer" or "Essay" in the question field. Click on these words to place the cursor and begin typing your own question. The question field expands as you type.

To fill in the answer for the question, the Answer field needs to be showing below the question. If it is not, select "Preferences > Test Options" from the Tools menu and click the Descriptors tab. Check the box next to "Correct Answer" and click OK. Below the short answer or essay question, click just to the right of the word "Answer:" to place the cursor and begin typing. The answer field expands as you type.

**Adding True/False Questions**

To add a blank true/false question to your test, drag the True/False template from the Resource Library into the test window. A pointer and horizontal line between questions indicate the location for the new question when you "drop" it by releasing the mouse button. You can also select a question on your test, and then select "Question > True/False" from the Insert menu to insert a new true/false question below the selected question.

Initially, the new question says "True/False" in the question field. Click on these words to place the cursor and begin typing your own question. The question field expands as you type.

**Correct Answer**

To mark True or False as the correct answer for the question, the answer choices need to be showing below the question. If they are not, select "Preferences > Test Options" from the Tools menu and click the Descriptors tab. Check the box next to "Correct Answer" and click OK. Below the true/false question, select either True or False so its background changes color. Then right-click the answer choice and select "Mark/Unmark as Correct" from the pop-up menu. You can also choose "Mark or Unmark as Correct Answer" from the Question menu.

**Adding Bimodal Questions**

To add a new bimodal question to your test, drag the Bimodal template from the Resource Library into the test window. A pointer and horizontal line between questions indicate the location for the new question when you "drop" it by releasing the mouse button. You can also select a question on your test, and then select "Question > Bimodal" from the Insert menu to insert a new bimodal question below the selected question.

Bimodal questions look like multiple-choice questions in the Resource Library, but they can also function as short answer questions if the answer choices are hidden. You control whether bimodal questions are displayed as multiple-choice or as short answer by setting a preference on the Questions tab of the Test Options dialog.

If your preference is to display bimodal questions as multiple choice, then fill in the question and answer choices on the test as you would for a multiple choice question, as described above. If the preference is set to show bimodal questions as short answer questions, then fill in the question and answer as you would for a short answer question as described above.
Adding Matching Questions

You can use the template for a matching question to create your own dynamic groups of matching questions on tests or to add matching items to testbanks.

Matching Items on Tests

When you drag the template for a matching question onto a test, two editing fields appear: a numbered question field in column 1 and a lettered answer field in column 2. Groups of matching questions on tests are dynamic, meaning that as you add matching items to a matching group, the answer choices in column 2, the right-hand column, automatically and randomly rearrange themselves so that most answer choices are not directly across from the questions they match. See the section on "Adding New Questions to Tests" for more information.

Matching Items in Testbanks

Matching items in testbanks include a field for the question that appears in column 1 and the matching answer that appears in column 2 on a test. Matching items are set up as individual items in a testbank, but related items share a common instruction that links them together on a test. For more information about adding matching items to testbank, see the section on "Editing Matching Questions."

Adding Vocabulary Questions

To add a blank vocabulary question to your test, drag the Vocabulary template from the Resource Library into the test window. A pointer and horizontal line between questions indicate the location for the new question when you "drop" it by releasing the mouse button. You can also select a question on your test, and then select "Question > Vocabulary" from the Insert menu to insert a new question below the selected question.

Initially, the new question says "Vocabulary" in the question field. Click on these words to place the cursor and begin typing your own question—the vocabulary term. The question field expands as you type.

To fill in the answer for the question, the Answer field needs to be showing below the question. If it is not, select "Preferences > Test Options" from the Tools menu and click the Descriptors tab. Check the box next to "Correct Answer" and click OK.

Below the vocabulary question, click just to the right of the word "Answer:" to place the cursor and begin typing the definition for the term. The answer field expands as you type.

Other Templates

In addition to Blank Answer Choices, described above, the Other Templates portion of the Resource Library contains a Blank Note template that you can drag onto your tests in order to insert instructions, part headings, or messages for test takers.

To add a note to a test, display the Testbank Library and click the Resource Library tab. Click the [+] next to Notes and find "Blank note" in the list of items. Drag the Blank note onto the test and drop it above one of the test questions, where you want it to appear. The note contains the words "Blank note" until you click in the note field on the test and begin to type.
Printing and Exporting

Printing Tests

TestGen prints test pages in the same layout you see in the test window. Usually, the test will be in Question view and you will see the test questions themselves. If the test is in ID view, the printed pages display only question IDs.

When you are ready to print a test, make sure the test window is active, and then select "Print" from the File menu to display the Test Print Settings dialog.

Setting the Test Print Options

**Number of versions**

You can print up to 25 different forms, or versions, of a test. Each printed version of a test is distinguished by a unique letter that is printed as part of the page number. The question types
you selected, the variability of each question, and the settings for the following three options determine how each version of a test will differ from the other:

**Preserve question order**
If you select this option, the questions on each version of the test will be in the same order as on the first version of the test. If you do not select this option, questions on each version will be randomly scrambled at the lowest level of organizational sorting.

**Preserve number values**
If you select this option, the questions that contain randomized numbers or text will not be recalculated or regenerated from version to version. All versions of the test will use the same values as the first version of the test. If you do not select this option, algorithmic questions will be recalculated or regenerated so that each version of the test contains different number or text values.

**Preserve multiple-choice answer order**
If your test contains multiple-choice questions or bimodal questions in multiple-choice format, and you select this option, the order of the answer choices on all the versions will be the same as on the first version of the test. If the option is not selected, multiple-choice answers will be randomly reordered on each version of the test.

**Print correlation of questions**
If you request more than one version of a test, then you can print a correlation table that shows where each question from the testbank is used on each version of the test. The correlation lists each question by its question ID and gives its question number on each version of the test. For example, if your test includes multiple-choice question 1 from chapter 1 of the testbank (Testbank 1.1-1), and you have printed two versions in which the question order is scrambled, you can track where this question occurs on version A and version B. The correlation prints after all the requested forms and their answer keys are printed.

**Print answer key**
Select this option to print an answer key for each version. Check other boxes to select which information to print for each question. If no point values have been assigned to individual questions, then all questions will display a point value of “1”. When descriptor categories, such as topic or page references, are unavailable for the selected test items, they are dimmed and cannot be selected for printing on the answer key.

Enter the number of columns (1-5) you want for the answer key. Multiple columns work best when the test contains all or mostly multiple-choice, true/false, and short answer questions with answers that are single words or short phrases. If answers are wider than the space allowed by the column, the answers will wrap within the column.

**Print student answer sheet**
Select this option to print a form that students can use to record their answers for the test questions. The answer form includes a short write-on line for each question, similar to what you would see if you were to display answer blanks on the test page.

Enter the number of columns (1-5) you want for the student answer sheet. Multiple columns work best when the test contains all or mostly multiple-choice, true/false, and short answer questions with answers that are single words or short phrases. If the anticipated answers are longer than one line, the answer sheet will leave multiple lines of space for students to write their answers within the column.
**Change starting page number**

In order for page numbers to show up on a test, you must insert them in a test page header or footer before printing. If you want the test to start on a page number other than "1," change the number in the input box on the Test Print Settings dialog. Choose one of the options below the starting page number box to control the numbering on test pages, answer keys, and multiple versions of the test.

**Save Settings**

Click OK to save the settings only for the current session. Click the "Save as default" button to save the settings for the current test as well as for future tests.

**Setting the Page Setup Options**

To set the paper size, margins, orientation, or scaling that will be used when you view or print a test, select "Page Setup" from the File menu. This is the standard Page Setup dialog for your printer.
Exporting Tests to Text or RTF Files

You can transfer the tests you create with TestGen to files that you can open and edit with a word processing program:

- plain text (.txt), or
- formatted text (.rtf).

Use the formatted text file option to export to an .rtf file that you can open with Microsoft Word®.

Exporting Tests to Plain Text Files

Create or open the TestGen test you want to export and select "Export" from the File menu.

On the Export Test dialog, choose to export the exam to a "Plain Text File." Then give the file a name that includes a .txt extension (e.g., chapter1.txt) and choose where you would like to save it.

Note: Whenever you export a file as a plain text file, it loses all formatting such as bold, underlining, italics, variable text or numbers, and graphics.

Exporting Tests to Formatted Text Files

A test exported to a Formatted Text File produces an .rtf, or "rich text," file that preserves TestGen's styles such as bold, italics, underline, superscripts, subscripts, color, indents, and strikeouts, with the exception of overlines, all lowercase, and boxed styles. Use this type of export to produce a test file you can open with Microsoft Word 2000 (or later) or other word processors that support rtf 1.6 or later.

In TestGen, prepare the test so that it displays the information you want to export by selecting "Preferences > Test Options" from the Tools menu and make selections on the Question Display,
Answer Display, and Descriptors tabs. For example, you might want to stack answer choices, show question type headers, and set up page headers/footers. Then select "Export" from the File menu and choose to export the test as a "Formatted Text File." Name the file, including an .rtf extension (e.g., chapter1.rtf), and choose where you want to save it.

This type of rtf file is designed to be printed with little or no modification and is formatted with numerous column and sections to make the pages look the same as in TestGen. An answer key follows the test pages. Symbols are replaced using their Unicode values, and in the rare instance a symbol cannot be found in the font, it is converted to a graphic. Graphics and function plots are exported as low-resolution bitmap images. If the test includes algorithmic questions, the current values of the variables are exported to the rtf file. Non-printing characters are not included in the rtf document.

If you need to edit any of the questions, do so carefully, so as not to disturb the many column and section breaks that define the layout of the pages. Typing in the wrong "section" may produce unexpected shifting of the text that you can restore by using Undo.

Exporting Tests to Easy Edit Text Files

A test exported to an Easy Edit Text File produces an rtf, or "rich text," file that is similar to the layout of a Formatted Text File, but does not have all the column and section breaks. It is easier to make more extensive changes without causing the rest of the page to shift out of alignment.

Easy Edit Text files can be opened with most Word processors for further editing.
Exporting HTML Practice Tests

One of the types of web tests you can create with TestGen is an interactive HTML practice test that students can view with a web browser. Tests can include multiple-choice, bimodal, and true/false question types, and students get immediate feedback as they answer each question. To view the test, students need a web browser that supports HTML 3.0 or higher (frames, tables, forms) and one that fully supports JavaScript. Netscape® Navigator and Microsoft® Internet Explorer are compatible browsers.

Creating an HTML Practice Test

To create an interactive HTML practice test, select "New Test" from the File menu. On the Startup pane, click the Web Test button, and then choose "HTML Practice Test." Proceed by choosing or authoring any combination of multiple-choice, bimodal, or true/false questions for your HTML test. Then select "Export" from the File menu.

Choose to export the test as an HTML Practice Test and click OK. Then give the test a name (no spaces allowed) and choose where you would like to save it.

The TestGen program folder contains a folder named HTMLEXPT, and by default, the TestGen program creates a folder within the HTMLEXPT folder using the test name you assign to store all the HTML and graphics files associated with the test. The program automatically creates and updates the index.htm file and creates a contents page for all the HTML practice tests you store in the HTMLEXPT folder. You need to copy the HTMLEXPT folder to a location where students can access the index.htm file with a web browser.

Note: If you choose to save an HTML practice test in a location other than the default HTMLEXPT folder, the test questions and graphics are saved in a folder, but no index.htm file or contents page is set up.

Modifying the Contents Page

To remove a test from the test contents page, edit the index.htm file found in the HTMLEXPT folder using an HTML editor. Each test name occupies a cell in an HTML table, and you need to remove the appropriate row of the table for the test you want to delete. After editing the index.htm file, if you no longer want to use the test, you may also want to delete the corresponding test folder from the HTMLEXPT folder.

The Student Experience: Taking the Test

To start the HTML practice test, students need to open the index.htm file with a web browser. They select the test name from the menu. Questions appear one at a time and students enter their answer.
As they answer each question, students receive immediate feedback as to whether they have answered the question correctly and some test questions might also include textbook page references. Students can click the Contents button to return to the test menu or close the browser to quit. No scores are saved or recorded.
Exporting Tests to HTML Pages

You can export any TestGen paper test as a single-page, scrollable HTML document. Note that the document is intended for electronic distribution so students can view or print the test. The document is not interactive and cannot be altered except with an HTML editor or by returning to TestGen to make changes in the test before exporting it again.

Layout of the HTML Page

The layout of the HTML test page includes the following:

- exam header
- question type headers
- instructions (if test contains any)
- questions
- answer choices for multiple-choice questions, if any (always stacked)
- answer blanks (cannot be turned off)
- function plots (if used, exported as graphics in .gif format)

Text styles for bold, italic, underline, superscript, subscript, and strikeout are retained in the HTML document, but other styles applied in TestGen are not translated to the HTML document.

Items Not Included

Other items, such as descriptors, footers, answers, and answer key, are not exported to the HTML document, even though they may be visible on the test in TestGen.

Exporting the Test

To export a paper test to an HTML formatted page, with the test window active, select "Export..." from the File menu, select HTML Formatted File, and click OK. When the file dialog appears, choose where you want to save a folder for the test's exported HTML files.

The exported test is saved in a folder with the same name that you assign to the HTML test, and graphics are saved in an Images folder inside the test folder. For example, if you export a test named "AlgChap1.tst" to a folder named "MyTests" and name the HTML test file as "Chapter 1 Practice," the hierarchy would be:

- MyTests (folder)
  - Chapter 1 Practice (folder)
    - Chapter 1 Practice.html (file)
    - Images (folder)
      - image1.gif (graphic file)
      - image 2.gif (graphic file)
Double-click the HTML file to open your web browser and display the exam.

*Note:* If you transfer the exam via e-mail or to an FTP site for your students, be sure to include the entire folder, including the Images folder.
Exporting Tests to PDF Files

You can export any TestGen test to a single PDF file that can be viewed on Windows or Macintosh computers using Adobe Acrobat Reader 6.0 or later. When you have a test open, select "Export..." from the File menu, select PDF, and click OK. When the file dialog appears, name the file and save it in the location of your choice. To view the file, double-click it or open it from Acrobat Reader.

*Note:* No answer key is included when exporting a test to a PDF file.

**Alternate method for Macintosh OSX 10.0 and higher:**

The Macintosh operating system has built-in support for saving documents in PDF format. With a test open, select "Print" from the TestGen File menu. Then click the Save as PDF... button. Enter a filename and click OK. This method works for testbanks and any other document that you can print.

Getting Acrobat Reader

If you do not have a copy of Adobe Reader or need to update to a newer version, go to the Adobe web site (get.adobe.com/reader/) and follow the links to download the free software.
Exporting Tests for Blackboard

Follow these steps to create a test in TestGen and transfer it into Blackboard 6.x - 9.x.

Note: The files exported using the Blackboard 6.x-9.x option may also be used to import test questions into other learning management systems such as ANGEL® or Desire2Learn.

1. Choose Blackboard Test Type and Create a Test
   a. On TestGen's Startup screen, click Web Test. Then choose the option for Blackboard and click OK.
   b. Create the test, whether choosing questions from a testbank or adding your own questions.

2. Export the Test from TestGen as a .Zip File
   a. Select "Export" from the File menu, select the option for Blackboard from the Export Test dialog, and click OK.

   ![Export To Blackboard]

   b. Enter a name for the question pool (description is optional), then click OK.
   c. Review the filename and destination where the .zip file will be created and saved. (By default, the name matches its original .TST file and the location is the "tests" folder inside the TestGen folder.) You can change either of these, but note that you will need to locate this file for the upload process into Blackboard.
   d. Click Save.

3. Upload the Test into Blackboard
   Log into your Blackboard server.
   a. Click on the Courses tab in the top navigation bar.
   b. Click the course name that you would like to upload your test questions into.
   c. Click the Control Panel button in the left navigation bar.
   d. Click Pool Manager in the Assessment area or Pools in the Tests, Surveys, and Pools area. This is the area that your tests will be imported into. Having existing questions in this area will not affect the import.
   e. Click the Import Pool button on the Pool Manager page.
f. Locate the .zip file to upload by clicking the Browse button. (Tip: It may be in the "tests" folder inside the TestGen folder.) Then click Open. The .zip file name and location display in the box next to the Browse button.

g. Click the Submit button.

Depending on the number of questions being imported, it may take several minutes for the entire question pool import to be transferred into your Blackboard course. A message displays when the process is complete.

4. Create Assessment in Blackboard

The question pool you authored in TestGen can now be used in the same manner as question pools created directly within the Blackboard course.
Exporting Tests for WebCT 3.x/4.x

Follow these steps to create a test in TestGen and transfer it into WebCT 3.x and WebCT 4.x.

1. Choose WebCT Test Type and Create a Test
   a. Select "New test" from the File menu. On the Startup screen, click Web Test. Then choose the option for WebCT 3.x and 4.x and click OK.
   b. Create the test, whether choosing from a testbank or adding your own questions.

2. Export the Test from TestGen as a .Zip File
   a. Select "Export" from the File menu, select either the WebCT 3.x or 4.x option on the Export dialog box, and click OK.
   b. Provide the requested information in the "Export to WebCT" dialog box.
   c. Review the filename and destination where the .zip file will be saved. (By default, the name matches its original .TST file and the location is the "tests" folder inside the TestGen folder.) You can change either of these, but note that you will later need to locate this file for uploading into WebCT.
   d. Click Save.

3. Upload File into WebCT
   a. Log into your WebCT course and click on Manage Files.
   b. Click Upload file, and then click the Go button directly beneath it.
c. Locate the .zip file to upload by clicking the Browse button. (Tip: It might be in the “Tests” folder inside the TestGen folder.) Make sure the Destination folder is set to My-Files, then click the Upload button.

*Important:* Always upload TestGen files into the My-Files folder.

d. Locate the exported .zip file in the My-Files list and select the file by clicking its check box.

e. Choose Unzip from the drop-down list under the File Options heading and click its Go button.

f. Choose My-Files as the destination folder. Then click the Unzip button.

g. WebCT unzips the files to a subdirectory you specified during the TestGen export process. For example, if you typed demo_test as the WebCT folder name, the program unzips one or more .txt files into My-Files/demo_test. The program places any supporting .gif image files in My-Files/demo_test/imagefiles. You can delete the .txt files after you import the questions into the WebCT question database. However, the images must remain in this location.

### Folders and Files

Click on a folder below to view its files.

Display this file information:

- Size
- Date
- Time

- **My-Files**
  - demo_test.zip (3432 bytes)
  - schedule.html (7220 bytes)
  - student_roster.txt (7576 bytes)

- **demo_test**
  - demogtest.txt

- imagefiles
  - f18glq114g1.gif
  - f18glq115g1.gif
  - f18glq165ag1.gif
  - f18glq165g1.gif

---

4. **Import Questions into WebCT**

a. Click on View Designer Map.

b. In the Designer Options list on the right side of the window under the Modify heading, click on the link you have created to the WebCT Quiz/Survey Tool.

c. Click Import Questions into Database.

d. Click the Import button, and then click the Go button under Manage Questions. The Import Questions dialog box appears.
Test Gen 7.4 Help

e. Click the Browse button to locate the files you uploaded.

f. Locate the My-Files folder and open the folder for the questions you want to import. Select the text file you want to import and then click the Pick button.

![Pick a file from the file manager, as listed below, to display it in your course.](image)

Pick a file from the file manager, as listed below, to display it in your course.

Pick Close Help

If the file you want is not in the file manager, you can upload it from your local computer.

Upload

Files
Click an option button to select a file for your course.
Click on the name of a file if you would like to view it.

- My-Files
- demo_test
- imagefiles
- [current working directory]
demotest.txt

The question text files are located in a folder that corresponds to the WebCT folder you provided during the TestGen export process. Choose the "file.txt" file if you selected the option to place all the question types in one category. If you specified a unique file for each question type, you will see several files (such as mc.txt and tf.txt) in the folder. Select any one of those files.

g. Click the Import button.

h. Check that all the questions from the file are on screen and then click the Continue button. At this point, your questions are now in the question database. Repeat the process for each text file you uploaded.

5. **Create a Quiz in WebCT**

Refer to the WebCT help for instructions on creating a quiz or survey. When creating the quiz, you can view and select questions based on the Category Name you supplied when creating the .zip file with TestGen.
Exporting Tests for WebCT CE and Vista

Follow these steps to create a test in TestGen and transfer it into Web CE 6.x (Campus Edition) and WebCT Vista® 4.x. Tests exported for these platforms are in QTI format and are compatible with other QTI-compliant systems as well.

1. Choose WebCT Test Type and Create a Test
   a. Select "New test" from the File menu. On the Startup screen, click Web Test. Then choose either the QTI (WebCT CE 6.x and WebCT Vista) option and click OK.
   b. Create the test, whether choosing from a testbank or adding your own questions.

2. Export the Test from TestGen as a .Zip File
   a. Select "Export" from the File menu, select the QTI (WebCT CE 6.x and WebCT Vista) option on the Export dialog box, and click OK.
   b. The "Create a file for export" dialog box displays.
   c. Review the filename and destination where the .zip file will be saved. (By default, the name matches its original .TST file and the location is the "tests" folder inside the TestGen folder.) You can change either of these, but note that you will later need to locate this file for uploading into WebCT.
   d. Click Save.

3. Upload File into WebCT
   a. Log into your WebCT course, click the Build tab, and select either the Basic or Power view.
   b. In the left-hand column, click Content File. Then click the Select File button.
   c. In the File Browser, click Upload File.
In the Upload File dialog, click the Browse button to locate the .zip file you exported from TestGen. (Tip: It might be in the "Tests" folder inside the TestGen folder.) Check the box to Automatically expand uploaded Zip files.

d. Click the Save button. TestGen files will be uploaded into the Section Content folder. WebCT unzips the files to a subdirectory using the same name as the zip file.

4. Import Questions into WebCT

a. After uploading the content file, return to the Basic or Power View and click the Content Import button in the upper right portion of the screen.

b. In the File Browser, select the zip file you just uploaded and click Add Selected.

c. The questions in the zip file will be added to the Question Database.

d. Click the Return button to go back to your Home page.
5. Create a Quiz in WebCT

Refer to the WebCT help for instructions on creating an assessment. When creating a quiz or survey, you can view and select from existing questions in the category name based on the .zip file you exported from TestGen.
Printing Testbanks

When you want to print a question, a group of questions, a section, or a chapter from a testbank, you need to open the testbank in the testbank editing window. Then select "Print" from the File menu to display the Testbank Print Settings dialog.

Setting the Testbank Print Options

The Testbank Print Settings dialog has the following options:

Print Selected Questions

This option prints only those testbank questions that are selected in the testbank. To select items in Question view or ID view, hold down the [Shift] or [Control] key and click one or more questions or question IDs. If you select a chapter or section title instead of individual questions, then all the questions in the selected chapter(s) or section(s) will be printed.

Print a Range of Chapters

This option lets you print all the questions from one or more chapters in the selected testbank. Click the radio button and enter a single chapter number or a range of chapter numbers to print. Note that questions print with answers and descriptors only if you have this information displayed on-screen. You can select which items are displayed by selecting "Preferences > Testbank Options" from the Tools menu.

Number for First Page

Enter a starting number for the page numbers that will print in headers or footers you have set up to include automatic page numbering.
Setting Up Page Headers and Footers

You can customize what appears in the headers and footers for printed testbank pages. When you have selected a section heading or question in a testbank in the Testbank Library, select "Header-Footer Editor" from the Tools menu to open an editing window.

Odd Page Header
Whatever you put in this field appears at the top of page 1 and every odd-numbered testbank page that is printed.

Odd Page Footer
Whatever you put in this field appears at the bottom of page 1 and every odd-numbered testbank page that is printed.

Even Page Header

Even Page Footer

Headers and footers may include text as well as graphics, tables, and symbols. Select "Toolbars" from the View menu to display the Standard toolbar, the Text Formatting toolbar, or the Equation Editing toolbar. You can also select "Show Rulers" from the View menu if you need to set tabs or adjust alignment.

Automatic Text
You may want headers and footers to include automatic page numbers or the current date or the chapter number. Select these items from the Insert menu to insert placeholders that will be replaced with the appropriate numbers as the testbank prints. (The placeholder for chapter number is "99."

To close the Header & Footer Editor and save your changes for the current testbank, click Save or select "Close" from the File menu. To save the headers and footers as the new default to be used for future testbank printing, click Save as Default. Click Cancel to close the window without making any changes.
Setting the Page Setup Options

If you want to set the paper size, margins, orientation, or scaling that will be used when you print a testbank, select “Page Setup” from the File menu. This is the standard Page Setup dialog for your printer.
Editing Testbanks

Enabling and Disabling Testbank Editing

When you first install TestGen, the ability to edit testbanks in TestGen is turned OFF. It remains that way until the setting for testbank editing is changed on the TestGen Preferences dialog. Once testbank editing is turned on, you can open a testbank and modify it.

Enabling Testbank Editing

To turn TestGen editing capability ON, select "Preferences > Application" from the Tools menu and click the Testbank Editing tab. Select the option that enables testbank editing and click OK.

When testbank editing is enabled, you can do any of the following:

- Open a testbank to modify its contents—add, delete, rearrange, and modify all question types.
- Set up shared resources—instructions, topics, skills, objectives—and link them to one or more testbank questions.
- Assign properties to testbank questions—difficulty level, page reference, workspace.
- Change which descriptors are displayed in a testbank.
- Add alternate correct answers for short answer questions for use online.
- Create a new testbank from scratch.
- Copy questions from one testbank to another.
- Use the TestGen Startup screen to open one of the last five testbanks you edited.
- Use the TestGen Startup screen to browse for a testbank to open.

Opening Testbanks for Editing

To edit an existing testbank, when testbank editing is enabled, select a testbank in the Testbank Library. Then select "Edit Testbank" from the File menu or click "Browse for other testbanks" on the Startup screen. If you have previously opened any testbanks for editing, the five most recent will be listed on the Startup screen and you can choose from that list.

Testbank files open for editing appear on the right-hand side of the screen where they are ready for you to modify as needed. If the testbank open for editing is part of the Testbank Library, the testbank is locked for editing, and its title is grayed out. You cannot view a testbank's questions in the Testbank Library if the testbank is open for editing on the right side of the screen. Changes made to a testbank are reflected in the Testbank Library display after you close or end the testbank editing session for that testbank.

To edit testbanks that are not part of the Testbank Library, select "Open" from the TestGen File menu or use your mouse to drag a testbank (.bok) file that's on your desktop onto the icon for the TestGen application. The testbank will start the TestGen application and open in its own editing window.
Modifying Testbanks

In order to modify a testbank, it must be open for editing on the right side of the TestGen program window. This section discusses how to modify a testbank by editing, adding, moving, or deleting questions, sections, or chapters. You can also modify chapter and section titles.

Editing Questions and Properties

To edit testbank questions and answers, click in any of the displayed fields and type, modifying content as needed. Items that can be modified directly in the testbank window are questions, correct answers, answer choices, explanations, and comments.

1) Identify and explain three methods for creating memorable conclusions. Provide a hypothetical example of each with the topic "donating money.

Answer:

If answers or descriptors you need are not visible on the screen, select "Preferences > Testbanks" from the Tools menu, click the Descriptors tab, and mark the items you want to display. Then click OK. Sometimes, during editing, it is also useful to display invisible characters, such as paragraph marks, tabs, and spaces, in the text editing field. Select "Invisible Characters" from the View menu to display these marks.

You can find more information about working with each type of question in separate sections of Help devoted to: multiple choice and bimodal, true/false, short answer and essay, matching, and vocabulary questions.

To edit these parts of questions—instructions, graphs, workspace, tables, variables, difficulty level, page references, and shared descriptors—you need to use the Properties Editor or other tools built into TestGen. You can find more information about working with the properties window, table editor, graphics library, graphing tool, and variable worksheet in other sections of TestGen Help.

Editing Chapter and Section Titles

To modify an existing chapter or section title in the testbank, first select the chapter or section title, and then click in the editing field. Make changes in the title as needed. Changes are saved when you click out of the editing field.

Adding Questions

To add a question under an existing question, select "Question" and a question type from the Insert menu, or drag a question template from the Resource Library into the testbank editing window and drop it where you want the new question. Continue to modify and add questions under the same section until you are ready to add a new section.
Adding New Chapters and Sections

To add a new chapter or section to a testbank, you need to first select an existing chapter or section title, then select “Testbank Section Heading” from the Insert menu.

Adding Chapters

To add a new chapter to a testbank, close up all the testbank sections so that only the chapter titles are visible. Select the chapter title above where you want to insert a new chapter. For example, to add chapter 2, select the title for chapter 1. Then select “Testbank Section Heading” from the Insert menu. The new section heading is inserted, and you can click in the editing field to type the chapter title. If your titles include automatic numbering, the new chapter is numbered sequentially, and the numbers of the chapters below change accordingly.

Adding Sections to a Chapter

You can add sections to a chapter if a testbank was set up to have two or more levels. To add a new section to a chapter, click the plus (+) sign next to a chapter title to display the existing section titles. (You do not need to view the questions for this operation.) Select the section title above where you want to add a new section. Then select “Testbank Section Heading” from the Insert menu. The new section heading is inserted, and you can click in the editing field to type the section title. If the section heading uses automatic numbering, it is numbered sequentially, and the numbers of the other sections in the chapter adjust accordingly.

Follow a similar procedure to add sections in testbanks with three or more levels. Select an existing testbank heading and use the Insert menu to insert a new section at the same hierarchical level as the selected heading.

Moving Chapters, Sections, or Questions

It is easy to rearrange chapters, sections, or questions in a testbank using cut-and-insert or drag-and-drop. When you move chapters or sections using drag-and-drop or cut-and-insert, all the questions for those chapters or sections are moved along with the title. Chapter or section numbers, question numbers, and question IDs are automatically updated when you move items in a testbank.

To rearrange chapters, click once on the chapter or chapters you want to move. Then hold down the mouse button and drag the selected chapter(s) to the new location in the testbank. An insertion line indicates where they will go when you release the mouse button. Alternatively, you can "cut" the selected chapters, click on the chapter title where you want to re-insert them, then select "Insert" from the Edit menu. The chapters are inserted after the selected chapter.
o To rearrange sections of chapters, click the plus (+) sign next to the chapter title to display the section headings. Select the title of the section(s) you want to move. Then hold down the mouse button and drag the section titles to the new location. The horizontal insertion line marks the location where the sections will go when you release the mouse button. You can drag sections within chapters or to other chapters, if the section headings are displayed.

Instead of drag-and-drop, you can also cut the section titles, click on the section title where you want to insert the cut titles, and then select "Insert" from the Edit menu to insert the sections below the selected section title.

o To rearrange questions, click the plus (+) sign next to chapter and section headings as needed to view questions or question IDs. Select the question(s) you want to move. Hold down the mouse button and drag the questions to the new location. A horizontal insertion line indicates where the questions will go when you release the mouse button. You can drag questions within a chapter or to other chapters if the questions or question IDs are displayed.

Note: The item selected as the insertion point must be the same type of item that was cut—chapter title, section title, or question. For example, select the title for Chapter 5 and choose "Cut." Select the title for Chapter 3 and choose "Insert." Chapter 5 is inserted after Chapter 3 and renumbered as Chapter 4. Chapters below are automatically renumbered.

Deleting Chapters, Sections, or Questions

To delete chapters, sections, or questions from a testbank, select a chapter title, a section title, a question, or a question ID. You can also make multiple selections by holding down the Ctrl key or the Shift key. When you have selected what you want to delete, click the Delete button on the TestGen Text Formatting toolbar, select "Delete" or "Cut" from the Edit menu, or press the Delete key on the keyboard. TestGen prompts you to confirm that you want to delete what is selected.

Note: Deleting a chapter or section title deletes the title as well as all the questions included under that title. Chapters and sections below the deleted item are renumbered automatically after the deletion.

Modifying Testbank Styles

To change the font, font size, style, or color of any of the titles, descriptors, or question numbers in the testbank, select "Preferences > Testbank" from the Tools menu and click the Default Styles tab.

To change the font, size, color, or style for questions, answers, instructions, explanations in the testbank, select "Global Style Replacement" from the Tools menu.

Saving Your Work

During testbank (and test) editing, use the Save icon or the "Save" option on the File menu frequently to save a copy of your work to disk. Saving replaces the previous copy of the testbank or test with the current version, using the same filename. Avoid working for a long time without saving, which could result in a loss of data in the event of a power or program failure.
Editing Multiple-Choice and Bimodal Questions

Multiple-choice and bimodal questions include an optional instruction field, a question field, and two or more answer choice fields.

17) An ideological political party
   A) holds extreme political views.
   B) will not cooperate with other parties.
   C) is deeply committed to certain policy goals.
   D) all of the above

Answer: C

To edit, simply click in any of the visible fields and make changes as needed.

Adding and Removing Answer Choices

You can add additional answer choices for multiple-choice and bimodal questions by dragging a Blank Answer Choice from the Resource Library into the answer choice list for a question. You can also add a blank choice if you select a question, then select "Blank Answer Choice" from the Question menu.

Rearrange the order of choices by dragging and dropping. If you need to delete an answer choice, select it so its background changes color, and then press the Delete key.

Marking the Correct Answer

To mark the correct answer for a multiple-choice or bimodal question, click to the left of the answer choice so that its background changes color. Then click the checkmark icon on the Standard toolbar or right-click the answer choice and choose "Mark/Unmark as Correct" from the pop-up menu. A checkmark appears to the left of each answer choice that is marked as correct. Repeat the process to remove the checkmark from an incorrect answer choice.

(You can select more than one answer choice as correct, but this is appropriate only for a paper test, and you will receive a warning if you try to transfer or save multiple-answer multiple-choice questions to a web test.)

Pinning Answer Choices

The order of multiple-choice and bimodal answer choices can be scrambled when a test is created, displayed, or printed. To keep an answer choice, such as "None of the above," in a fixed position, select the answer choice and then click the pin icon from the Standard toolbar or select "Pin or Unpin..." from the Question menu. You can also right-click the selected answer choice and select "Pin/Unpin" from the pop-up menu. A picture of the pin appears next to the answer choice and the choice will not move from its fixed location if other answer choices are scrambled.

Pinning answer choices is essential when the correct answer choice is something like "Both B and C are correct." You want to make sure that this choice, as well as choices B and C, is pinned to prevent scrambling. If, however, "Both B and C are correct." is NOT the correct answer, then choices B and C do not have to be pinned in place.
Using Bimodal Questions

Using a bimodal question type provides flexibility in your testbank and test questions in that you can enter a question once and then display it in either multiple-choice or short-answer format on a test. Not all multiple-choice questions are suitable for use as bimodal questions.

Well-Constructed Bimodal Questions

A well-constructed bimodal question can be answered without the student seeing the multiple-choice answers. For example, the following question works just as well when displayed in short-answer format as in multiple-choice format.

Bimodal Question (Multiple Choice Format = OK):

The outermost layer of the epidermis is _________.

A) stratum lucidum
B) stratum basale
C) stratum corneum
D) superficial fascia

Bimodal Question (Short Answer Format = OK):

The outermost layer of the epidermis is _________.

Questions Not Suitable as Bimodal Questions

The following question works well in multiple-choice format, but not in short-answer format when the answer choices are removed. It would not be suitable as a bimodal question.

Bimodal Question (Multiple Choice Format = OK):

Which of the following statements is true?

A) Federalism is the typical way nations organize their governments.
B) Most European countries are confederations.
C) The American states have unitary governments.
D) Great Britain has a federal system.
E) None of the above are true.

Bimodal Question (Short Answer Format = NOT OK):

Which of the following statements is true?

Changing the Form of Bimodal Questions

All bimodal questions are displayed as multiple-choice questions in testbanks. On tests and in testbanks, the [BI] bimodal indicator prints to the left of each bimodal question. You can also display the Question Type descriptor to identify bimodal questions as BI.
On tests, instructors have the option to change the form of bimodal questions between multiple choice and short answer either globally or on a question-by-question basis.

Adding Evaluated Answers

Since bimodal questions can be displayed in short answer format and used on web tests with the TestGen plug-in, they are eligible to have evaluated answers, or multiple forms of correct answers. When you display the short answer form of a bimodal question, a green evaluated answer icon [E] next to the correct answer indicates that multiple forms of the correct answer have been defined.

To add or view alternate correct answers for the selected question, select “Evaluated Answer Editor” from the Tools menu. Instructions for using the Evaluated Answer Editor are given in another section of Help.

Editing Other Properties

To add or edit shared instructions or edit additional fields or shared descriptors, click the Show Properties button at the bottom of the testbank editing window.
Editing True/False Questions

True/False (TF) questions include an optional instruction field, a question field, and an answer. Simply click in the question field and type or edit as needed.

Marking the Correct Answer

In order to mark the correct answer for true/false questions, you need to display answers in the testbank. The correct answer and additional descriptors can be displayed if you select "Preferences > Testbank" from the Tools menu. Click the Descriptors tab and mark the items you want to display.

The choices "True" and "False" are displayed below each true/false question. Click on the correct answer choice so its background changes color. Then either click the correct answer checkmark on the Standard toolbar or select "Mark or Unmark as Correct Answer" from the Question menu. You can also right-click the correct answer choice and choose "Mark/Unmark as Correct" from the pop-up menu.

Editing Other Properties

To add or edit shared instructions or edit additional fields or shared descriptors, click the Show Properties button at the bottom of the testbank editing window.
Editing Short Answer and Essay Questions

Short answer and essay questions have the same layout for question and answer, but you can use the two question types to distinguish free-response questions, such as fill-in-the-blank or completion, from longer questions and answers that ask the student to explain, compare, contrast, or describe.

Short Answer Questions

The short answer (SA) question type is often used for fill-in or completion questions, or when the question can be answered with a short phrase or sentence. However, it is a free-form format and the question and answer can contain any type of content.

Short answer questions include an optional instruction field, a question field, and an answer field. Simply click in any of the visible fields and type or edit as needed.

You can display the answer field and selected descriptors if you select "Preferences > Testbank" from the Tools menu, click the Descriptors tab, and mark the items you want to display. To add or edit shared instructions or edit additional fields or shared descriptors, click the Show Properties button at the bottom of the testbank editing window.

Adding Evaluated Answers

Since some types of short answer questions can be used for plug-in tests, they are eligible to have evaluated answers, or multiple forms of correct answers. A green evaluated answer icon [E] next to the correct answer indicates that multiple answers have been defined.

To add or view alternate correct answers, select the answer and then select "Evaluated Answer Editor" from the Tools menu. Instructions for using the Evaluated Answer Editor are given in a separate section of Help.

Answer Blanks for Short Answers

When a short answer question needs longer answer blanks or multiple answer lines for lettered parts of the question, select "Change Answer Blank" from the Question menu. A dialog opens for you to select the answer blank width and the number of answer blanks.
If you choose to "Show Labels," the answer blanks are labeled with lowercase letters: a., b., and so on.

*Note:* The option to show answer blanks must be selected on the Questions tab of the Test Options dialog in order for these multiple answer blanks to appear.

**Essay Questions**

Use the Essay question type when longer sentences or paragraphs are expected as answers. Essay (ES) questions include an optional instruction field, a question field, and an answer field.

Simply click in any of the visible fields and type or edit as needed. Additional descriptors can be displayed if you select "Preferences > Testbank" from the Tools menu, click the Descriptors tab, and mark the items you want to display. To edit shared instructions, double-click the instruction field. To add instructions or edit additional fields or shared descriptors, click the Show Properties icon at the bottom of the testbank editing window.
Editing Vocabulary Questions

Vocabulary questions are a specialized form of short answer question that can be used to group questions related to definitions of key terms. They include an optional instruction, a question (term) field, an answer (definition) field, and an optional pronunciation field. The pronunciation field can be used to show a phonetic spelling of the term or provide information about the term or its definition.

Simply click in any of the visible fields and type or edit as needed. Additional descriptors can be displayed if you select "Preferences > Testbank" from the Tools menu, click the Descriptors tab, and mark the items you want to display. To add or edit shared instructions or edit additional fields or shared descriptors, click the Show Properties button at the bottom of the testbank editing window.

Changing the Form of Vocabulary Questions

Vocabulary questions assume that the question field contains the "term" and the answer field contains the "definition" for the term. On tests, instructors can make a global change to this setting by making a selection on the Questions tab of the Test Options dialog.

In addition, instructors can override the global setting and reverse the term and definition on a question-by-question basis by selecting a vocabulary question on a test and clicking the bimodal (BI) button on the Standard toolbar.

<table>
<thead>
<tr>
<th>accrual</th>
<th>Answer: a transaction in which revenue is earned or expense is incurred before</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Diff: 1 Type: VO</td>
</tr>
<tr>
<td></td>
<td>Objective: Ch. 2 - LO4</td>
</tr>
</tbody>
</table>
Editing Matching Questions

Matching questions include an instruction, a question field (Column 1), an answer field (Column 2), and an optional field for foils. Matching questions exist as individual items in a testbank, but automatically reformat into two columns when instructors choose them for tests. The testbank layout is shown below:

1.4 Matching  
*Match the following fruits and their colors.*

1) Column 1: Banana  
   Column 2: Yellow  
   Foil:

2) Column 1: Eggplant  
   Column 2: Purple  
   Foil:

3) Column 1: Carrot  
   Column 2: Orange  
   Foil:

When editing matching questions in a testbank, simply click in any of the visible fields and type or edit as needed. To add or edit shared instructions or edit additional fields or shared descriptors, click the Show Properties button at the bottom of the testbank editing window.

Using Instructions in Matching Questions

Each group of matching questions requires a unique instruction. The shared instruction is assigned to each question in the matching group so questions remain together if test items are scrambled. When an instructor chooses matching questions for a test, questions with the same instruction appear in a two-column format with randomly shuffled answer choices in column 2, as shown below:
Matching fruit colors:

1) Banana - A) Blue
2) Carrot - B) Purple
3) Blueberries - C) Yellow
4) Eggplant - D) Orange
5) Zucchini - E) Green
6) Lettuce

When writing instructions for matching questions, use a statement that is specific to the content of the matching group—for example, “Match each state with its capital city.” Or, you can use a more generic instruction, such as “Match the following.” See the section “Using Shared Instructions” for more information about adding, deleting, and modifying instructions.

Question and Answer

Enter a matching question and answer for each question in the group using the Column 1 and Column 2 fields. Items in column 1 appear as the numbered test items. Items in Column 2 appear as lettered answer choices and are randomly shuffled when questions are transferred to a test.

On tests, if two matching questions selected for a test have the same correct answer, the answer choice appears only once in column 2. So, it is possible to have, for example, ten questions in the column 1 and only two choices in the column 2 if the correct answers for all ten items are one of the two choices.

Adding Answer Foils

During editing, a blank Foil field appears for each matching question in a testbank. A foil will appear as an additional choice in column 2 when matching items are assembled on a test.

A foil is an incorrect answer for the question to which it is assigned, but may be the correct answer for a different question in the matching group. When foils are used, it is possible for column 2 to have more items than column 1, since column 2 might include some choices that do not match with any item in column 1. Using a foil ensures that the additional choice will appear in column 2 of the matching group whether or not all questions from the matching group are chosen for a test.

If you want more than one foil for a matching question, select the matching question and drag a Blank Answer Choice from the Other Templates section of the Resource Library onto the selected question.

Note: The use of foils is optional. If Foil fields are left blank during testbank editing, they will not show when you view the testbank in the Testbank Library.
Adding Explanations

Testbank and test questions can include explanations—solutions or rationales—for correct answers and incorrect answer choices. These explanations can be viewed on-screen, printed on tests, or printed on test answer keys to assist students and instructors in analyzing test results. Explanations, when available in testbanks and tests, are also included on TestGen plug-in tests as well as exported WebCT and QTI tests for all question types except essay and short answer questions with long answers.

You can use explanations for multiple-choice, bimodal, true/false, and short answer question types. For multiple-choice and bimodal questions, you can enter explanations for the correct answer choice as well as any of the incorrect answer choices. Explanations are not used for matching, vocabulary, or essay question types.

If the explanation field is not visible on the screen, select “Preferences > Testbank Options” from the Tools menu and click the Descriptors tab. Click in the box next to Explanation to mark it for display, then click OK.
Adding Comments

Comments are unique remarks about specific questions, and are in addition to Explanations that can be provided to explain or give the rationale for correct answers. Comments can be attached to any question in a testbank or on a test by clicking in the Comment field below the question and typing.

If the comment field is not visible on the screen, select "Preferences > Testbank Options" from the Tools menu and click the Descriptors tab. Click in the box next to Comments to mark it for display, then click OK.
Using the Ruler and Tabs

During editing, you may need to set tabs, center text horizontally, or otherwise adjust the placement of text or expressions within a question, answer, instruction, header, footer, or macro. You can perform all these tasks with TestGen's built-in ruler. Select "Show Ruler" from the View menu to display the ruler if it is not visible at the top of the editing window.

The ruler displays the full width of the page that is allowed for each question, based on what you have set for the page margins.

Using Tabs

Use any of the four triangular markers at the left side of the ruler to set a tab on the ruler. Each triangle symbol represents a different kind of tab: left-justified, centered, right-justified, and a decimal tab to align decimal points in numbers. Click on any of the markers, drag it onto the ruler, and drop it at the desired location.

Note: TestGen's default left and right page margins are 0.5 inch for printed tests. If you change page margins so that the line width is smaller—for example, left and right margins set at 2 inches, leaving only 4.5 inches available for test questions—some lines of tables and tabbed material might wrap to the next line. Be sure to set page margins so that questions containing large tables or tabbed columns will fit across the page. When authoring questions, try to keep tables and tabs no wider than about 5 inches.
Using the Properties Window

When parts of questions cannot be edited directly in the testbank editing window, they can be viewed and edited using the Properties window. To open the Properties window for any question selected in the testbank editing window, click the Show Properties button at the bottom of the testbank editing window. This opens the Properties window below the selected question.

Convert the given measurement to the unit indicated.

1) 1.88 m to cm
   - A) 18.8 cm
   - B) 18.8 cm
   - C) 0.0188 m
   - D) 0.188 cm

Note: If more than one question is selected, the Properties window displays only the information that is the same in all the selected questions. For example, if all the selected questions are the same question type, that question type shows in the Question Type list box. Or, if all the selected questions have a difficulty level of 2, then “2” shows in the Difficulty edit box. However, if some of the selected questions have the same topic, but other selected questions have different topics, then no topic shows in the Topic list box; the word None shows instead.

The Properties window displays all the supplemental information attached to a question, whether or not you have these items displayed in the testbank editing window. Some of the items in the Properties window are for display only, some items can be edited directly in the Properties window, and other items are edited in separate Properties Editor windows.

Items for Display Only

The following descriptors are displayed for informational purposes only and cannot be edited.

**Question ID**—The question ID indicates the relative position of the question in the testbank with respect to chapter and section, followed by the item number.

**Question Dates**—These are the dates the question was created and last modified.
**Number of Variations**—This gives the number of possible variations for questions that contain programmed algorithmic or user-created variables. Questions that have more than 50 possible variations show "50+".

**Items You Can Edit in the Properties Window**

The following items, although they can be displayed in the testbank window, can be changed or assigned only in the Properties window for the selected question(s).

- **Question Type**—Select a question type from the drop-down menu.
- **Difficulty Level**—Enter a number from 1 to 9 to represent the difficulty level for the selected question. A value of 0 means no difficulty level has been assigned. The numbers 1, 2, and 3 are used most often to designate easy; medium or moderate; and challenging, difficult, or hard questions.
- **Workspace**—Enter a number from 1 to 15 to represent the number of blank lines to show below the selected question if an instructor elects to show workspace on the test page. Every 6 lines represents about 1 inch of space.
- **Page Reference**—Enter a page or section reference, up to a maximum of 16 characters maximum, for the selected question.

**Items That Are Shared Descriptors**

At the bottom of the Properties window, drop-down lists for shared descriptors let you assign or unassign instructions, topics, skills, or other items to one or more questions selected in the testbank editing window. An edit button for each category opens an editing window where you can add, delete, or modify the content of list items. See the sections on "Using Shared Instructions" and "Using Shared Descriptors" for more information on managing shared instructions and descriptors.

**Assigning Properties to One or More Questions**

The information you view or apply in the Properties window applies to the question(s) you have selected in the testbank editing window.

With only *one* question selected, the information you see or apply in the Properties window affects only that one question.

With *multiple* questions selected in the testbank editing window, the information you apply in the Properties window affects all the selected questions at once.

**Example 1: Multiple Similar Questions**

If you select several questions that all have the same difficulty level and the same topic, that difficulty level and topic will show in the Properties window. Any changes you make to difficulty level or topic will affect all the selected questions.

**Example 2: Multiple Dissimilar Questions**

If you select several questions that have different difficulty levels and different topics, the difficulty level and the Topic category will be blank in the Properties window. If you then assign a new difficulty level or topic in the Property window, it will be applied to all the selected questions.
Using Shared Instructions

Groups of questions in a testbank can share a common instruction to which each question refers—a table, a picture, a graph, a paragraph of text, or a combination of these. The instruction groups related items on a test, so that if test questions are scrambled or sorted, items with a common instruction remain grouped, depending on the type of sort.

An instruction is printed or displayed above the first question in the group of questions assigned to it. In the Testbank Library and on tests, the instruction does not display for any questions that follow the first question in the group unless a question with a different instruction interrupts the flow of questions.

Instructions are assigned, edited, and managed through the Properties window in the same way as shared descriptors.
Assigning an Instruction to a Question

To assign, or link, an instruction to a question in the testbank you are editing, select the question (or group of questions) and click Show Properties to open the Properties window if it is not already open.

- If no instruction is currently assigned to the selected question or any questions in the selected group, the word "None" is in the Instruction field.
- If an instruction has been previously assigned to the selected question or group of questions, the first portion or a descriptive short name for the instruction shows in the Instruction field.
- If a group of questions is selected and they do not all have the same instruction, the Instruction field is blank.

Click the arrow at the right of the instruction choice box to drop down a list of available instructions. The list is in alphanumeric order by the first portion of the instruction or by a short name that has been assigned to it. Find an instruction in the list, select it, and close the list. If you decide not to make a selection, move the mouse off the list without clicking any of the choices.

The selected instruction appears in the Instruction field of the Properties window and also appears in the testbank window above the question or group of questions to which you have assigned it.

Clearing an instruction from a Question

When the testbank editing window or the Properties window shows that an instruction is assigned to a selected question (or group of questions), and you want to remove, or unlink, the instruction from the selected question(s), use the drop-down Instruction list in the Properties window. Click the arrow at the right of the Instruction choice box and scroll to the word "None" at the top of the list. Select "None" and close the list. The previously assigned instruction will be cleared from the selected question(s) in the Properties window and in the testbank editing window.

*Note:* Clearing an instruction from a question in a testbank does not remove the instruction from the Instruction list, and it can be assigned to other questions.
Managing the Instruction List in the Instruction Editor

When you need to add, modify, or remove an instruction from the Instruction list click the Edit icon next to the Instruction field in the Properties window. This opens the Instruction Editor.

In the Instruction Editor, you can modify an existing instruction, add a new instruction to the list, delete an instruction from the list, or modify the short name for an instruction.

Modifying an Instruction

To modify an instruction for a question in the testbank you are editing, select an item from the list at the left side of the Instruction Editor. The full instruction appears in the editing field. Make changes as needed in the editing field and then click the Update List button.

Note: If the instruction is currently assigned to one or more questions in the testbank, the instruction is automatically updated in all the questions that share it.

Adding a New Instruction to the List

To add a new instruction to the list, click the Add button. A "New Instruction n" entry (where n is a number) appears in the list and in the editing field at the right. Replace the words "New Instruction n" in the editing field with what you want for the instruction. In addition to text, you can insert symbols, graphics, templates, tables, and graphs.

When you are finished with the new instruction, click the Update List button. The first portion of the new instruction appears in the instruction list as well as in the "short name" field below.

Using Short Names for Instructions

The first 60 characters of the instruction are automatically used as the "short name" of the instruction to display in the Instruction list when you create a new instruction and click Update.
List. In many cases, the supplied short name is descriptive enough to let you distinguish one instruction from the another in the list, but you can modify the short name to make it shorter or longer.

If some instructions in the list have similar short names, or if you want to use a descriptive phrase to identify an instruction, you can change the short name to make it easier to differentiate the instructions in the list. If the instruction is a graphic or a long paragraph, you might want the short name to describe it as "Figure 3-1" or "Photosynthesis diagram" or "Case Study: Identical Twins," for example.

You can enter a short name when you create a new instruction, before you click the Update List button. Or, you can change the short name for items already in the Instruction list by selecting the item, changing the short name, and then clicking Update List.

*Note:* Although symbols, templates, and international characters are allowed in instructions, you cannot use them in short names.

**Printing the Instruction List**

When you want to print a copy of the full Instruction list, click the Print icon at the top of the list. The printout lists the short names for all the currently defined instructions.

*Note:* If you select "Print" from the File menu, the entire Instruction Editor window is printed to give a hard copy of the current instruction.

**Deleting an Instruction from the List**

To delete an instruction from a testbank you are editing, select an item from the list at the left side of the Instruction Editor. Then click the Delete button.

When you delete an item from the Instruction list, it is removed from all the testbank questions to which it was assigned.
Using Shared Descriptors

Each question in a testbank can have descriptive information assigned to it to classify it in some way, and many questions can share the same descriptor. Questions can have up to five shared descriptors, including a topic, skill, objective, and two user-defined categories. (Occasionally, the shared descriptor categories are renamed, as decided by the author or publisher.) The use of shared descriptors varies from testbank to testbank—some testbanks or question types have no descriptors, while others may use one or more categories for each question.

Shared descriptors are used by instructors to filter testbank questions based on a specified criteria. Shared descriptors, when printed on tests, answer keys, or test summary pages, are also used by students and instructors to analyze test results and identify topics or skills that need further study.

Displaying Descriptors in a Testbank

To display descriptors in a testbank, the testbank must be open in the testbank editing window. Make your selections on the Descriptors tab of the Testbank Options window. The descriptors you select are displayed below each question in the testbank:

<table>
<thead>
<tr>
<th>Question 1</th>
<th>Question 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>1) All but which one of the following are processes of interpersonal perception&lt;br&gt; A) forming impressions of others&lt;br&gt; C) interpreting the behavior of others&lt;br&gt; B) describing the behavior of others&lt;br&gt; D) identifying barriers&lt;br&gt; Answer: D&lt;br&gt; Page Ref: 72-77&lt;br&gt; Skill: Knowledge</td>
<td></td>
</tr>
<tr>
<td>2) What process is involved when we direct our attention to specific elements and ignore others?&lt;br&gt; A) interpersonal perception&lt;br&gt; C) perception&lt;br&gt; B) selective perception&lt;br&gt; D) passive perception&lt;br&gt; Answer: B&lt;br&gt; Page Ref: 69&lt;br&gt; Skill: Knowledge</td>
<td></td>
</tr>
</tbody>
</table>

The descriptors that are displayed when you close the testbank editing window are the same ones that are displayed when the testbank is re-opened in the Testbank Library.

Viewing Descriptors in the Properties Window

When you select a test question in a testbank and then click the Show Properties button at the bottom of the testbank editing window, you see the Properties window, which shows all descriptors and additional information about the question.
You can change some of the question attributes by typing or picking from drop-down lists. Descriptors that are shared, such as Instruction, Topic, and Skill, have an Edit button that you can click to open the Properties Editor for that descriptor. The Properties Editor contains a list of all the current entries for the selected category, along with the tools to make changes or add new list items (see below).

Assigning a Shared Descriptor to a Question

To assign, or link, a descriptor to a question in the testbank you are editing, select the question (or group of questions) and click Show Properties to open the Properties window if it is not already open.

- If no descriptor is currently assigned to the selected question or any questions in the selected group, the word "None" is in the descriptor field.
- If a descriptor has been previously assigned to the selected question or group of questions, the descriptor or first portion of the descriptor shows in the descriptor field.
- If a group of questions is selected and they do not all share the same descriptor, the descriptor field is blank.

Click the arrow at the right of the choice box for one of the descriptor categories to drop down a list of available choices. Find the descriptor you want, select it, and close the list. If you decide not to make a selection, move the mouse off the list without clicking any of the choices.

The selected item appears both in the Properties window and in the testbank window, if the testbank is set to display that particular descriptor.

Clearing a Shared Descriptor from a Question

When the testbank editing window or the Properties window shows that a descriptor is assigned to a selected question (or group of questions), and you want to remove the descriptor from the selected question(s), use the drop-down list for the appropriate category. Click the arrow in the
category choice box to display the list of choices. Scroll to the top of the list and select "None" to close the list. The previously assigned descriptor will be cleared from the selected question(s) both in the Properties window and in the testbank editing window.

Note: Clearing a descriptor from a question in a testbank does not remove it from the Instruction list, and it can still be assigned to other questions.

Managing Shared Descriptor Lists in the Properties Editor

When you need to add, modify, or remove an item from one of the descriptor categories, click the Edit icon next to the desired category name in the Properties window. This opens the Properties Editor for that descriptor.

In the Properties Editor, you can modify an existing descriptor, add a new descriptor to the list, or delete a descriptor from the list.

Modifying a List Item

To modify a list item, select an item from the list at the left side of the Properties Editor. The full text of the descriptor appears in the editing field. Make changes as needed and then click the Update List button.

Note: If the descriptor is currently assigned to one or more questions, it is automatically updated in all the questions that share it.

Adding a New Descriptor to the List

To add a new descriptor to a list, click the Add button. A "New Topic n" entry (where n is a number), for example, appears in the list and in the editing field at the right. Replace the text in the editing field with the text for the new descriptor and click the Update List button. The new descriptor is inserted in the list alphanumerically.

If you want the descriptor to fit on one line, limit the text to about 55-60 characters. In addition to keyboard characters, you can include math symbols and expressions using symbols and
templates from the Equation Editing toolbar. If the text is longer than one line, it will wrap to as many lines as needed to accommodate the content; the editing window shows you where the text will break between lines.

**Deleting a List Item**

To delete a descriptor from a testbank, select an item from the list at the left side of the Properties Editor. Then click the Delete button.

*Caution:* When you delete a shared item from a descriptor list, it is removed from all the testbank questions to which it has been previously assigned.

**Printing a Descriptor List**

When you want to print a copy of the full list of topics (or other descriptor), click the Print icon at the top of the list. The printout lists the short names for all the currently defined items.

*Note:* If you select "Print" from the File menu, the entire Properties Editor window is printed to give a hard copy of the currently selected descriptor.

**Renaming a Descriptor Category**

The default names for the five descriptor categories are Topic, Skill, Objective, User1, and User2. It might be appropriate to change the category names for some testbanks, or to rename the User1 or User2 categories to something more descriptive.

To change the name of a descriptor category, open the Properties Editor for that category. At the top of the Properties Editor, change the List Name as needed. The recommended maximum length for descriptor category names is 16. (A longer category name reduces the number of characters that can be displayed for the list items for that category.)
Save As New Testbank

When you have a testbank open for editing and choose the Save option, the current testbank file replaces the one previously saved on disk, using the same testbank filename.

If, however, you want to save a copy of the testbank with a new name, you can select “Save As New Testbank” from the File menu. A good use for Save As is if you want to open an old testbank and make changes in it, but keep the original testbank intact.

When the save dialog appears, type a new filename for the testbank and be sure the desired folder is set as the location in which the new testbank will be saved. The file type should be set to .BOK for a TestGen testbank.

When you click OK to save the new testbank file, a dialog asks if you want to add the new testbank to the Testbank Library. Click Yes or No to make your choice and close the dialog. If you click Yes, the testbank title appears in the list of testbanks already in the Testbank Library.

Whether or not you add the new testbank to the Testbank Library, the newly named testbank file replaces the one that was previously open in the testbank editing window, and the name of the new testbank appears at the top of the editing window. You can proceed to edit the new testbank as needed.
Math Related Editing

Using Symbols and Templates

Symbols and templates built into TestGen make it easy to create expressions used in math and other subjects. These items are located on the Equation Editing toolbar displayed in the top section of the TestGen application. If the Equation Editing toolbar is not visible, select “Toolbars > Equation Editing” from the View menu.

<table>
<thead>
<tr>
<th>symbol palettes</th>
<th>math templates</th>
</tr>
</thead>
<tbody>
<tr>
<td>+ &gt; ∈ Δ → Π π ℝ ∞</td>
<td>∑ Π</td>
</tr>
</tbody>
</table>

Symbols

If you need to insert a symbol that is not available on the keyboard, look for it on one of the symbol palettes on the Equation Editing toolbar at the top of the TestGen window. Click a symbol to open its associated palette of symbols and choose the symbol you want to insert.

Math Templates

For technical subjects such as mathematics, statistics, chemistry, biology, and economics, you may need to insert a mathematical expression into a question or answer. Use the math templates located on the Equation Editing toolbar.

When you want to insert a template at the location of the cursor, click the appropriate button to display the palette. Then click a template to insert it into the question. Boxes outline the cells, or fields, where you can enter numbers, text, or other templates. To move from field to field within a template, press the right arrow key or click in any field with the mouse. When you have filled all the fields, press the right arrow key again to move out of the template and continue typing, or simply click the mouse outside the template.

Nested Templates

You can put one template inside of another template to build more complex expressions, as shown in the example below, which has a square root template in the numerator of a fraction template.

\[
\frac{\sqrt{50}}{5}
\]

Answer: \(\sqrt{2}\)

To try this on your own, put the cursor in the question or answer field of a test question. Then follow these steps:

1. Click the first math template (the fraction) on the Equation Editing toolbar to display its palette.
2. Click the first symbol, a large fraction, to insert the fraction template in the question or answer.

3. Place the cursor in the numerator of the fraction and then choose the square root template from the Equation Editing toolbar. This inserts an empty radical template in the numerator of the fraction.

4. Enter a number in the radical, and then press the right arrow to exit the square root template.

5. Press the right arrow key again or click in the denominator to exit the numerator.

6. Now type a number in the denominator.

7. Press the right arrow to exit the fraction template.

8. Press the space bar once and type more text if needed.

Using Grouping Templates to Avoid Line Breaks

Normally, when text or expressions are too long to fit at the end of a line, word wrap occurs and bumps some words or parts of expressions to the next line. This sometimes produces an undesirable break in the middle of an expression. You can use TestGen's grouping template to prevent text, objects, or expressions, such as "123 meters" or "3x + 5y = 12", from being split apart at the end of a line.

Example: The expression \( y = 5 \) is split between two lines on a test. 

4) If the growth rate of multifactor productivity is 2.5, and \( b = 0.25, k = 4, n = 2 \), and \( y = 5 \), then the growth rate of labor productivity is 
   A) 8.0.
   B) 3.0.

To group an expression or set of items, first put the cursor at the desired location in a question, answer, or instruction. Then select the grouping template from the fraction palette.

You see the outline of a box at the cursor location. Now type or paste text or the desired expression inside the grouping box. Anything you put inside the grouping (boxing) template will become a single unit and wrap to the next line when the entire boxed item is too big to fit at the end of its current line.
Example: Expression $y = 5$ is boxed to prevent splitting on a test:

If the growth rate of multifactor productivity is 2.5, and $b = 0.25$, $k = 4$, $n = 2$, and $y = 5$, then the growth rate of labor productivity is

4) If the growth rate of multifactor productivity is 2.5, and $b = 0.25$, $k = 4$, $n = 2$, and $y = 5$, then the growth rate of labor productivity is

A) 8.0.

B) 3.0.

Example: Four expressions boxed to prevent splitting during rewrapping of text:

The British thermal unit (Btu) is commonly used in engineering applications. A Btu is defined as the amount of heat required to raise the temperature of 1 lb of water by 1°F. There are _______ joules in one Btu. $1 \text{ lb} = 453.59 \text{ g}$.$\text{C} = (5/9)(F - 32)$.

specific heat of $\text{H}_2\text{O} (l) = 4.18 \text{ J/g-K}$

The box outlines show on-screen when you click inside the box template while editing, but they do show on printed tests.

Note: The width of a question can change depending on the margins used for a test, whether answer blanks are displayed, whether the test is printed or shown online, and other factors. It is best to box all expressions you do not want to split, even if they do not currently split in the editing window.
Inserting Mathematical Graphs

You can create graphs of functions and relations on a Cartesian or polar background, or create number line graphs by using TestGen's built-in graphing tool. To insert a graph, place the cursor in the question, answer, instruction, or note field and select "Graph" from the Insert menu. Choose "Cartesian," "Polar," or "Number Line" from the submenu to display the appropriate graphing tool and set of axes.

The Graph Window

The graph window shows the graph(s) that will be inserted into the question. You can use the menu options and buttons at the top of the graph window to modify the graph, print the graph, place the graph in a problem, or exit the graphing tool.

File Menu

Select "Print" from the File menu to print the contents of the graph window.

Select "Quit" from the File menu to close the graphing tool without placing a graphic in the question.
New Grid
Select "Cartesian," "Polar," or "Number Line" from the New Grid menu to display a new background for the type of graph you choose. Choosing the same type of background as the current display leaves your current graph intact.

Place Button
When the Graph window shows the image you want to use, click the Place button to insert the image into your question as a text character or as a transparent graphic, depending on the preferences you have set for inserting graphics. The graphing tool closes after you choose Place.

Graph Button
Click the Graph button to display the Set Up Graphs window. You define up to 15 functions to display on the same graph background. To define a graph, click the Add button and select a graph type. After you define the graph, it is represented as a line item in the Set Up Graphs window. You display the defined graphs by clicking the Plot box and then the Apply button.

Range Button
Click the Range button to adjust the viewing area for the Graph window by choosing either the center point value or the bottom or left point value.

Zoom Button
Use the Zoom button to show more or less detail in the graph window.

Enter a zoom factor from 2 to 99 and then click Zoom In or Zoom Out as many times as you want. Click OK to apply the results and close the Zoom dialog. Click Cancel to close the dialog without making a change.

Format Button
Click the Format button to adjust the spacing of the tick marks, the scale, the labeling, the width of the axes, and the background pattern for a graph. The Format dialog varies slightly depending on whether you have chosen a Cartesian, polar, or number line type of grid.
### Horizontal Axis and Vertical Axis tabs:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pixels per tick</td>
<td>This number determines how far apart the tick marks are on each axis. The default value is 20. To move tick marks closer together, enter a number smaller than 20. To move tick marks farther apart, enter a number larger than 20.</td>
</tr>
<tr>
<td>Scale (units per tick)</td>
<td>This number determines how many units are represented by each tick mark. The default value is 1.</td>
</tr>
<tr>
<td>Ticks per label</td>
<td>This number determines which tick marks are labeled with a number value. To label every tick mark, enter 1.</td>
</tr>
<tr>
<td>Label</td>
<td>Enter the letters you want to use to label each axis. The default for Cartesian is x and y. The default for polar is r.</td>
</tr>
<tr>
<td>Arrowheads</td>
<td>Check one or both boxes to display arrowheads at the ends of the axes.</td>
</tr>
<tr>
<td>Title</td>
<td>Type the title for the axis (no international characters).</td>
</tr>
<tr>
<td>Orientation</td>
<td>Click a radio button to have the axis title print horizontally or vertically.</td>
</tr>
</tbody>
</table>
Display tab:

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show tick marks</td>
<td>Check the box to display tick marks.</td>
</tr>
<tr>
<td>Label tick marks</td>
<td>Check the box to label tick marks.</td>
</tr>
<tr>
<td>Label and title size</td>
<td>Enter the point size (from 10 to 24 points) for the axes labels and titles.</td>
</tr>
<tr>
<td>Axis width</td>
<td>Choose none, thin, or thick for the axes on the graph.</td>
</tr>
<tr>
<td>Background</td>
<td>Choose dotted, lined, or blank for the background of the graph. Check the Invisible box to hide the background when you place the graph in a test item.</td>
</tr>
</tbody>
</table>

Changing the Size of the Graph Window

For consistency, the default size of the graph window is 225 x 225 pixels, which allows you to insert a graph in each of four answer choices for a multiple choice question and have the answer choices fit side-by-side in two rows on a test. You can adjust the size of the graph window by dragging the side, bottom, or corner of the graph window.

To resize the graph window to a specific number of pixels, double-click the graph window to open the Resize window. Enter the pixel height and width and click OK. This action exposes more or less of the image.
The Set Up Graphs Window

The Set Up Graphs window opens when you click the Graph button and you use it to define and display graphs in the graph window.

![Set Up Graphs (Cartesian) window](image)

Choosing a graph type from the Add menu opens a dialog in which you can define the graph. The items on the Add menu vary, depending on which grid type you have chosen.

**Add Menu (Cartesian)**

The Add menu lets you choose what to plot on the Cartesian grid. Depending on your choice, the appropriate dialog opens to let you define the mathematical function or relation.

<table>
<thead>
<tr>
<th>Equation Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>y =</strong></td>
<td>Enter an equation in terms of x.</td>
</tr>
<tr>
<td><strong>x =</strong></td>
<td>Enter an equation in terms of y.</td>
</tr>
<tr>
<td><strong>Parabola</strong></td>
<td>Choose one of the four forms of the equation. Equations that include a, but not h and k, have vertex at (0,0). Equations that include h and k have vertex at (h,k). Enter values for a or a, h, and k.</td>
</tr>
<tr>
<td><strong>Circle</strong></td>
<td>Choose one of the two forms of the equation. Equations that include r, but not h and k, have center at (0,0). Equations that include h and k have center at (h,k). Enter values for r or r, h, and k.</td>
</tr>
<tr>
<td><strong>Ellipse</strong></td>
<td>Choose one of the two forms of the equation. Equations that include a and b, but not h and k, have center at (0,0). Equations that include h and k have center at (h,k). Enter values for a and b, or a, b, h, and k.</td>
</tr>
<tr>
<td><strong>Hyperbola</strong></td>
<td>Choose one of the four forms of the equation. Equations that include a and b, but not h and k, have center at (0,0). Equations that include h and k have center at (h,k). Enter values for a and b, or a, b, h, and k.</td>
</tr>
<tr>
<td><strong>Point (x,y)</strong></td>
<td>Enter coordinates for x and y. Choose style and labeling preferences.</td>
</tr>
</tbody>
</table>
Test Gen 7.4 Help

<table>
<thead>
<tr>
<th><strong>Segment</strong></th>
<th>Enter the coordinates for the two endpoints. Choose style and labeling preferences.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Smooth Curve</strong></td>
<td>Enter your choice of points, critical points, zeros, or zeros of the second derivative to define and graph a smooth polynomial curve.</td>
</tr>
<tr>
<td><strong>Parametric</strong></td>
<td>Enter two equations in terms of t. Enter minimum and maximum for values of t.</td>
</tr>
<tr>
<td><strong>Normal Curve</strong></td>
<td>Enter the mean and standard deviation to plot a normal curve. Enter coordinates for x and y along with the text you want to appear at the label location. (32 characters max)</td>
</tr>
<tr>
<td><strong>Label (x,y)</strong></td>
<td></td>
</tr>
</tbody>
</table>

**Add Menu (Polar)**

The Add menu lets you choose what to plot on the polar grid. Depending on your choice, the appropriate dialog opens to let you define the mathematical function or relation.

| **r =** | Enter a function using " theta" as the variable. To type a theta symbol, press Alt-o (lowercase "o" as in "toy"). |
| **Point (r, theta)** | Enter the coordinates of the point (r, theta). Choose style and labeling preferences. |

**Add Menu (Number Line)**

The Add menu lets you choose what to plot on the number line. Depending on your choice, the appropriate dialog opens to let you define the mathematical function or relation.

| **Point** | Enter the coordinate of the point on the number line. Choose style and labeling preferences. |
| **Segment** | Enter the coordinates of two points on the number line. Choose style and labeling preferences. |
| **Ray** | Enter the coordinates of the endpoint. Also choose whether you want the ray to point left or right. Choose style and labeling preferences. |
| **Line** | Pick a pattern and color for the line. |

**Delete Button**

To remove an item from the Set Up Graphs window, click once on the item's description to select it, then click Delete.
Trace Button
To see the coordinates for a point on any of the functions displayed in the Cartesian or polar graph window, click the Trace button so that it says “Trace On.” The words “Trace coordinates” appear at the top of the graph window.

Click on the description of the function you want to trace. Then use the left and right arrow keys to move the crosshairs along the graph and view the coordinates of the point. To make the crosshairs move a bigger step, hold down the [Shift] key when you press the right or left arrow key.

If a graph has two branches, such as in a hyperbola, press the [Tab] key to move the crosshairs from one branch of the graph to the other. This also works for circles and ellipses.

To move the crosshairs to a different graph, click on its description in the Set Up Graphs window. You may need to press the right or left arrow key several times to make the crosshairs appear for any given graph.

Compound Button
When you graph two or more inequalities, you can shade the intersection of the graphs by using the Compound button. First define the inequalities, but do not graph them. Then click the Compound button and choose which inequalities you want to compound. When you click OK, the compounded statement appears in the Set Up Graphs window. Click the check box and then Apply to see the intersection of the two graphs.

Defining Graphs
When you choose a graph from the Add menu or click Edit to modify an existing graph on the Set Up Graphs window, a secondary window opens for the type of graph you chose. On many of the definition windows, there are buttons that give menus of additional settings that let you change the look of the graph.

Define Parabola
Parabola (choose one):
- $y^2 = 4ax$
- $(y-k)^2 = 4a(x-h)$
- $x^2 = 4ay$
- $[x-h]^2 = 4a(y-k)$

$a = 2$
$h = -2$
$k = -1$

Relation Menu
Many equations can be defined as either equalities or inequalities. To choose the relation you want to graph, choose a symbol on the Relation menu.

Pattern Menu
You can graph lines and curves as solid lines or with a dashed pattern. Make your selection from the Pattern menu.
Test Gen 7.4 Help

**Color Menu**
You can graph points, lines, and curves in black or a choice of colors selected from the Color menu.

Note: Colored items print as shades of gray if you do not use a color printer for your test.

**Shade Menu**
When graphing an inequality, you can choose a pattern for the shading that shows which side of the curve or line is included in the graph. Make your selection from the Shade menu.

**Entering a Function**
To type a function or relation, type the numbers and letters from the keyboard. Some symbols can be typed with a combination of keys from the keyboard:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Keyboard Shortcuts</th>
</tr>
</thead>
<tbody>
<tr>
<td>infinity</td>
<td>Type Alt-i (Win) or Option-i (Mac)</td>
</tr>
<tr>
<td>theta</td>
<td>Type Alt-o or Option-o</td>
</tr>
<tr>
<td>pi</td>
<td>Type Alt-p or Option-p</td>
</tr>
<tr>
<td>e</td>
<td>Type Alt-e or Option-l (Use the letter l, not the number 1.)</td>
</tr>
<tr>
<td>fraction</td>
<td>Type a slash for the fraction bar. Use parentheses where needed to group symbols.</td>
</tr>
<tr>
<td>exponent</td>
<td>Type the caret (^) symbol to indicate exponentiation.</td>
</tr>
</tbody>
</table>

**Using Built-In Functions**
Some of the definition windows for polar graphs include lists of symbols that you can include in equations. Scroll to the symbol you want and click on it to make it part of your equation.

**Continuity**
To decrease the time it takes to graph advanced functions, select the appropriate description of its continuity. If you do not know whether a function is continuous, click the radio button for "Might be Continuous."

**Domain**
Specify the domain you want to use for any graph by entering a Minimum and Maximum value for the x variable. In most cases, you will want the domain of the function or relation to stretch from -inf to +inf, which are the defaults for the Minimum and Maximum values.

**Speed vs. Accuracy**
A sliding accuracy scale on some dialogs lets you choose to display a graph faster or with more accuracy. If you choose "Faster", the program will plot fewer points to display the graph. If you choose "More accurate", the program will plot more points to display the graph. In some cases, it will take slightly more time to plot a graph more accurately. In many cases, you will not notice a distinct time difference between the settings.
Editing Mathematical Graphs

To edit a graph already inserted into a question, double-click the image to open the graphing tool window.

Note: If the graph was inserted into a question as a transparent graphic, double-clicking the image will not open the graph window. Select "Transparent Graphic" from the Tools menu and click the Edit button if you want to make changes in the image.
Defining and Inserting Variables

To add more variety to questions on a test or in a testbank, you can define and include variable text or numbers in questions. Questions that include variable text or numbers are useful when you want to print multiple forms of a test, use a test with QuizMaster for network testing, or use a test in a web-based testing environment that uses the TestGen plug-in.

An Example of Variable Numbers

Using a simple example, the question

"Find the sum of 6 and 9."

is a static question that is always uses the numbers 6 and 9 and always has the answer 15. But if "6" and "9" are replaced by variables, then the question,

"Find the sum of V1 and V2."

represents more than one problem when V1, V2, and V3 (the answer) are defined as a set of linked variables. For example, to give the problem five variations, define linked variables as:

\[
\begin{align*}
V1 &= 5\times6\times7\times8\times9 \\
V2 &= 7\times5\times8\times6\times9 \\
V3 &= 12\times11\times15\times14\times18
\end{align*}
\]

If V1 is 7, then V2 is 8 and V3, the answer, is 15. Each time the problem is printed, V1, V2, and V3 can have a different set of values, depending on which value is randomly selected for V1.

Using Randomized Variables

In TestGen, when you want to insert one or more variables in a test question, place the cursor where you want the first variable to be inserted and select "Variable" from the Insert menu. The Variable Definitions worksheet appears.
Decide how many variables you will need in the question and answer, and also decide how many variations you want.

**Defining Variables**

On the Variable Definitions worksheet, click in the Values field for V1, the first variable. Type the list of values for V1, separating the values by typing [Control] [\] to insert a bullet (•) symbol. Repeat the process for V2, V3, and more, depending on how many variables you need.

**Linking Variables**

Without linking, the value for each variable is randomly chosen from the set of values you enter on the worksheet, and you do not need to have the same number of values for each variable.

When the value of one variable is the result of a calculation involving one or more other variables, you need to link the variables. To link variable values, enter a number in the Link column for all the variables that are in the same group. When variable values are linked, the value that is randomly chosen for the first variable in the linked group determines which value is used for the other variables that are part of the same linked group.

The example above shows that variables 1 and 2 are linked, so that if "60.0" (the fifth value) is selected for the value of V1, then the value of V2 is "200" (the fifth value), the value of V3 is "12.0 (the fifth value)," and so on. If these variables were not linked, then the values would be selected randomly from each list and would often produce incorrect answers for the problem.

You can have more than one group of linked variables for a problem; just use a different number in the Link column to identify each linked group.

**Inserting Variables**

In the question or answer field for a test or testbank question, place the cursor at the location where you want to insert one of your defined variables. Select Variable from the Insert menu to open the Variable Definitions worksheet, and click one of the value cells for V1 to V20. Click the Insert Selected Variable button to place a value in the question. Continue to work back and forth between the question and the worksheet to place the variables where you want them. Variable number values or variable names are highlighted with a colored background when the cursor is in the editing field for a question or answer.
Note: The inserted values for linked variables may not display the correct linked values until you have all the variables in place and you recalculate the values in the question.

Recalculating Values

To recalculate new values for the variables inserted into a question, select the question and then select "Calculate New Values" from the Question menu or use the keyboard shortcut [Ctrl] [R] for Windows or [Apple] [R] for Macintosh. You can also click the calculator icon on the Standard toolbar to recalculate new values.

Viewing Variable Names and Values

When you view questions that contain variables, you see one of the calculated values for each variable—this is the Variable Value view. There are two ways to identify where the variables are located in a question:

One method is to select "Variable Name" from the View menu to show the variable names instead of the variable values for all the variables in the entire testbank. Here is an example of variable name view and variable value view for a question:

With variable names:

$v(1)$ told $v(3)$ friends that $v(2)$ was in $v(4)$ for $v(5)$ days.

With variable names replaced by values:

Myrna told 2 friends that she was in Florida for 7 days.

Note: When you view the names for inserted variables, the variable names include a dollar sign before the number, for example $v(1)$ or $v(2)$ to indicate that they are user-created string variables rather than publisher-supplied, algorithmically calculated variables, which are shown without dollar signs, for example $v(1)$ or $v(2)$.

To switch back to viewing variable values instead of names, select "Variable Values" from the View menu.

Another method to locate variables in a question is to click in the editing field for a question or answer. When you activate the editing field, all the variable names or values are highlighted with a colored background so you can easily see where they are.

Be careful not to delete the variable values.

Number of Variations and Variant Status

When variables are included in testbank or test question, you can display the number of variations for each questions by selecting "Preferences > Test Options" from the Tools menu and clicking the Descriptors tab. Check the box next to Number of Variations to display the number of variations below each question. The number can range anywhere from 1 to 50+ (more than 50), depending on the number of variables and the range for each variable. In addition, you can check the box next to Variant Status to display a marker (down arrowhead) next to each question that has more than one variation. Items with no variation will not have the marker.
Deleting Variables

To delete a variable, move the cursor to the right of the variable and press the [Backspace] or [Delete] key. You may also select the variable and then select "Cut" from the Edit menu. Deleting or cutting a variable from a question does not remove its definition from the Variable Definitions worksheet.

Uneditable Variables

In testbanks prepared for publishers, the variables used in algorithmic questions are uneditable. These variables are associated with mathematical calculations that use features beyond the scope of the published version of TestGen. The publisher-defined variables are displayed on the screen as "v's" with reference numbers, such as v(1) or v(2), in contrast to the user-created variables that are shown as v($1) or v($2).

Caution: Altering or deleting algorithmically generated variables are likely to invalidate the mathematical calculations in the question or answer and the question will become incorrect and unusable.

Alternate Display of Negative Numbers

When requested by the publisher, some testbanks, such as those for accounting, will programmatically display variable negative numbers using parentheses rather than a negative sign. Both the negative sign and the parentheses are considered to be part of the algorithmically generated number and cannot be edited.
Calculating New Values for Variables

TestGen testbank and test questions can include variable numbers or text, usually for mathematics, economics, statistics, physics, or chemistry. These variable numbers or text may be pre-programmed as algorithms in testbanks you receive from publishers, or you can add your own variables to questions you create or modify. The benefit of using test questions with variables is that multiple forms of tests can test the same skills using problems that have different number values, or you can recalculate the variables each time you use a test to provide a new variation of it.

Locating Questions That Contain Variables

One way to locate questions that contain variables is to display the Variant Status descriptor on a test or in a testbank. The Variant Status marker displays as a downward pointing arrow next to any question that uses pre-programmed or user-added variables.

Note: Variant status symbols do not show on printed or web tests.

Another way to locate questions that utilize variables, is to display the Number of Variations descriptor on a test or in a testbank. This displays "Var: n" below each question, where n is a number from 1 to 50. If the number is "1," then the question is static, with no variations and cannot be recalculated. If the number is larger than 1, the question has more than one variation, and you can recalculate values. Numbers larger than 50 are represented by "50+.

Note: Not all test items that contain numbers are variable; variables need to be pre-programmed in publisher testbanks or instructors can create their own variables to provide more variation than a static item.

Calculating New Values on a Test

When you transfer variable or algorithmic questions from a testbank to a test, the test questions contain the same variable values as shown in the testbank. In the test window, you can force these values to recalculate by selecting one or more questions and clicking the Calculate icon or selecting "Calculate New Values" from the Question menu. The variable values change to a different set of numbers or words, and the values you see on-screen are the same as what will be on the printed test. Test items without variable values remain unaffected. If you print more than one form of a test, you can either keep these values or have them recalculate from form to form.

Calculating New Values in a Testbank

In testbanks that contain questions that include variable text or numbers, the numbers displayed in the testbank are saved as part of the testbank, but variable values can be recalculated after the questions are transferred to a test.
The variable values can also be recalculated in the testbank. To calculate new values for the variables, select the chapter, section, or question(s) you want to recalculate; then click the Calculate button or select "Calculate New Values" from the Question menu. Testbank items without variable values are unaffected.
Defining Evaluated Answers for Short Answer Questions

When you create questions for web tests that use the TestGen plug-in or Blackboard, you can set up short answer questions or bimodal questions (in short answer form) so they can accept more than one form of the correct answer. A green evaluated answer icon [E] next to an answer indicates that more than one form of the answer will be accepted as correct.

![Evaluated Answer Editor](image)

1) Find the sum of 3.5 and \( \frac{1}{4} \).

Answer: 3.75

Evaluated Answer Editor

To view or add evaluated answers for a short answer or bimodal question on a web test, select "Evaluated Answer Editor" from the Tools menu. This opens the Evaluated Answer Editor:

The Evaluated Answer editor copies the correct answer for the question into the Answer 1 field, which is not editable here and always reflects the current correct answer for the question. You can enter up to nine alternate correct answers.
Answer Evaluation Styles

There are three answer evaluation styles—literal, numeric, and expression—that let you define specific alternate answers as well as ranges of acceptable answers. Unless you change one of the settings, Answer 1 and all alternate answers are literal text that ignore case and spaces, and have no restrictions (filters) on the types of keys the student can use to enter an answer.

To configure an evaluated answer beyond the default behavior, you need to drag across all or part of the answer to select it and then click an evaluation style. The background of the selected answer or portion changes color to match the color of the button for the selected style. In addition, the options panel changes to match the selected style and you can set or reset options.

Note that if the correct answer is algorithmic, including variables programmed by the publisher or from the variable worksheet, you can switch between the variable view and the static view using the View button at the top right corner of the Evaluated Answer editor window. In variable view, you see the names of the variables used in the answer—v(1), v(2), and so on for algorithmic variables, and v($1), v($2), and so on for user-defined string variables from the variable worksheet. These represent values that will be replaced with numbers or text each time the problem is regenerated.

Caution: Be careful not to alter variable names, since doing so can invalidate the problem and cause student answers to be incorrectly evaluated.

The options for each answer evaluation style are as follows:

[L] Literal Options - Word or short phrase (yellow)

<table>
<thead>
<tr>
<th>Style:</th>
<th>L N E</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input Filter:</td>
<td>None</td>
</tr>
</tbody>
</table>

Literal Options for Answer 1

- [ ] Match Case
- [ ] Match Space

The most common use for the Literal option is to accept multiple forms of the correct text-based answer. If the answer is "1,000,000" you can enter alternate answers such as: one million, 1 million, 1M, and 1000000. You can use the following options to restrict which answers are accepted as correct for each alternate answer.

**Match Case**

Acceptable answers must match the case. For example, if the correct answer is "Monkey" with case sensitivity off, acceptable answers would include: Monkey, monkey, MONKEY, mOnKeY, and other variations of case. If **Match Case** is checked, only Monkey is accepted.

**Match Spacing**

Acceptable answers must match the spacing. For example, if the correct answer is "Ida B. Wells" with space matching turned off, acceptable answers would include: Ida B. Wells, Ida B. Wells, IdaB. Wells, I d a B. W e l l s, and other variations of spacing. If **Match Space** is checked, only Ida B. Wells is accepted as correct.
The most common use of the Numeric option is to allow a tolerance for a numeric answer or to require a specific number of significant digits.

**Tolerance**
Acceptable answers can be within a specified range of numbers. For example, if the correct answer is 3.14159 (π) and you enter an alternate answer of 3.14 with a tolerance of 0.01, then acceptable answers would be any that fall within the range of 3.14 - 0.01 and 3.14 + 0.01, or between 3.13 and 3.15. The following would be accepted as correct: 3.13, 3.14, 3.141111, 3.142, 3.15, and others in the range.

**Significant Digits**
Acceptable answers must have the correct number of significant digits. For example, if an alternate answer is 2.40 with 3 significant digits, answers such as 2.4 and 2.400 would not be accepted as correct.

Example of alternate answers for a numeric answer:

1) Find the sum of \( \frac{3}{4} \) and \( \frac{7}{4} \).

Answer: \( 2\frac{1}{2} \)
Answer 2 accepts student answers that are a single number, without operators, that are equivalent to 2.5. The student could enter, for example, 2.5, 2.50, or 2.500000, as well as the exact match fraction to give a correct answer.

[E] Expression Options - Math expression evaluation (blue)

The most common use of the Expression option is to accept alternate, symbolic forms of the answer.

Similar Form  Accepts forms of the answer that are mathematically similar, based on the order of the terms or factors. For example, if the answer is "2+3", then "3+2" would be accepted as correct, while "5" and "1+3+1" would not. Equivalent forms are also accepted; for example, a\(^{-2}\) instead of 1\(a^2\).

Reduce Only  Requires the student's answer to be fully reduced. For example, if the alternate answer is 3/4 and you check Reduce Only, answers such as 9/12 would not be accepted as correct.

Tolerance  Specify the amount by which the answer can vary from a fixed value.

If any evaluated answer contains names of variables, such as x and y, you can enter each variable name and a set of three test values that are used to evaluate the expression. The values are compared with the value of the student's expression when the same values are substituted into the student answer.

Variable  Enter each of the variable names (up to 10) used in the expression answer. For example, if the accepted expression is "2x + 6y", enter x and y in the variable list by typing them in the box.

Values  For each variable in the Variable list, enter 3 different values that the program can "plug into" the expression to obtain a value for the accepted answer. The program randomly assigns numbers, starting with 3, 5, and 7, to each variable you enter, but you can change these values for any variable. For example, if the desired answer is "2/(x-3)", a test value of 3 would cause a divide by zero error, so you would change the test value from 3 to some other integer, such as 0 or 1.

When the student enters an expression answer, the test values are substituted into the student's expression, and the student's set of resulting three numbers must match the answer's set of resulting three numbers for the answer to be counted as correct.
Example of an alternate answer using an expression in similar form:

1) Find the sum of \( \frac{3}{4} \) and \( \frac{7}{4} \).

Answer: \( \frac{11}{2} \)

With the similar form setting, the student must use the same mathematical operators as were used in the answer being compared to the student input. Since Answer 2 contains a division (fraction bar) and an implied addition (whole number plus fraction), the student’s response must contain the same operators and be mathematically equivalent to \( 2 \frac{1}{2} \).

**Test Answer Button**

To test some answers for the alternate answers you have defined for a problem, click the Test Answer button. This starts your web browser and uses the TestGen plug-in to display the problem and answer. You can enter different types of answers to see if they are correctly accepted or not. A Calculate button lets you recalculate variables if available. Close the browser window to return to the Evaluated Answer editor and make changes or save your question.
Miscellaneous Options

Other controls in the Evaluated Answer editor include the following:

**Input Filter Choice Box**

Restrict certain keystrokes at the keyboard to prevent students from inadvertently entering a correct answer that is not interpreted correctly. Choices are:

- **None (blank)**: Allows all keystrokes
- **Integers only**: Allows keys 0-9, comma, hyphen
- **Real numbers only**: Allows keys 0-9, comma, period, hyphen
- **aA-zZ only**: Allows keys a-z, A-Z
- **No numbers**: Allows all keystrokes except 0-9
- **Money only**: Only keys 0-9, comma, $, period

**Symbols and Templates**

During web tests using the TestGen plug-in, appropriate symbols and templates are available for students to help enter their answers. You will see these buttons when you use the Test Answer button.

**Mix and Match**

You can mix the three styles of evaluated answers within a single answer to maximize the ability to recognize a student's correct answer.
Other Advanced Editing

Managing Graphics

TestGen has built-in tools for importing and managing graphics. The Graphics Library and preferences for graphics positioning are described below.

Using the Graphics Library

Graphics you insert into a testbank questions are saved in the Graphics Library so that you can reuse them in other questions. Each testbank and test maintains its own Graphics Library, although the Graphics Library is not accessible from tests.

To open the Graphics Library while editing a testbank question, select “Graphics Library” from the Tools menu. You can also open the Graphics Library by double-clicking any graphic that has previously been inserted in a question.

<table>
<thead>
<tr>
<th>Category</th>
<th>Graphic</th>
<th>Hi-res</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chapter 19</td>
<td>1510.bmp</td>
<td>✓</td>
</tr>
<tr>
<td>Chapter 5</td>
<td>1512.bmp</td>
<td>✓</td>
</tr>
<tr>
<td>Chapter 8</td>
<td>1516.bmp</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td>1517.bmp</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td>1518.bmp</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td>1520.bmp</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td>1522.bmp</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td>1523.bmp</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td>1523.bmp</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td>1529.bmp</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td>1538.bmp</td>
<td>✓</td>
</tr>
<tr>
<td></td>
<td>1539.bmp</td>
<td>✓</td>
</tr>
</tbody>
</table>

The Graphics Library displays a list of one or more categories, and when you select a category, you see the names of the graphics files that are in the selected category. A Preview window shows a thumbnail view of the selected graphic. Images that are pasted into a question or inserted using the Picture option on the Insert menu are listed in a category named Miscellaneous.

Adding Graphics to the Graphics Library

To add new graphics to the Graphics Library after you have opened it, click the Add button. When the file dialog appears, locate the graphic file you want to insert and click OK. The Import Graphic dialog opens, as shown here.
You can save graphics in a Miscellaneous category or use a separate category for each chapter. Use one of the existing category names in the drop-down menu or type a new category name in the space provided. You can also rename a graphic file before you store it in the Graphics Library. Click OK to add the image file to the Graphics Library.

**Placing a Graphic from the Graphics Library**

To insert a graphic from the Graphics Library into a question, place the cursor where you want to insert the graphic in the question. Select "Graphics Library" from the Tools menu to open the Graphics Library. Click a category in the left column and click a graphic filename in the right column. Click the Place button to place the graphic in the question and close the Graphics Library window.

*Note:* If the graphic is the first or only item in a question or answer field, it will align with the base of the question number or what would be the first line of text, which might not be desirable. You might want to insert a return (press Enter) before the graphic to move it down a line in the field and produce a better visual effect.

**Adding Low- and High-Resolution Versions of a Graphic**

Images that you insert into tests, testbanks, and the Graphics Library, are generally designed to be displayed on-screen, at 96 dpi for Windows and 72 dpi for Macintosh. Printing images at these resolutions may not produce high-quality results if the images have a lot of detail. To ensure that the printed image will not be fuzzy or blurred, you can attach a higher-resolution image to the lower-resolution on-screen image in the Graphics Library.

Begin by inserting the lower-resolution version into a question or by choosing Add in the Graphics Library. Then, be sure the filename of the low-resolution graphic is selected in the Graphics Library, and click the Add Hi-res button. Find the file that is the high-resolution version of your graphic and open it. A check mark appears in the column labeled "Hi-res" to show that the high-resolution version of the graphic has been included in the Graphics Library. TestGen automatically selects the lower-resolution version to display on the screen and the higher-resolution version to print.

Instructions later in this section give more details about creating low- and high-resolution images.

**Replacing or Updating a Graphic in the Graphics Library**

To replace a graphic in the Graphics Library with a new, updated version of the graphic, open the Graphics Library and choose Add. Locate the new, altered graphic file on your computer. In the Import Graphic dialog, use the same name for the file as the original name and choose the same category as the old graphic to insert the new graphic. Answer "yes" when the program prompts you to replace the existing graphic. The updated graphic replaces the old graphic everywhere the original graphic was used in the testbank or test.

If the revised graphic is a different size than the original, the program remeasures the graphic and updates every question that uses the graphic to make sure the space allowed for the graphic is correct. This step takes only a few seconds. We recommend that you choose "Yes" to re-measure. If you choose not to have the program re-measure the graphic immediately after
Updating it, the program re-measures each affected question individually the next time it is displayed.

**Deleting a Graphic from the Graphics Library**

To delete a graphic from the Graphics Library, click once on its name and then click the Delete button. TestGen displays a message if any of the testbank's or test's questions currently use the graphic. If you click OK, the graphic file will be removed from the Graphics Library and from all the questions that use it.

**Printing Graphics from the Graphics Library**

To print any or all of the graphics in the Graphics Library, highlight the category and/or graphic you want to print and click "Print." In the Print Graphics dialog, make your selection and click OK.

**Exporting Graphics from the Graphics Library**

You can export a graphic from the Graphics Library to make changes to it using an external graphics editing program. When you select a graphic file in the Graphics Library and click Export, the program prompts you to enter the name and location where you want the file to be saved. The file exports in the same format as it was imported. If an image has a high-resolution version attached to it, both the low- and high-resolution image are exported.

**Preparing Your Own Graphics**

To prepare a graphic file to insert into TestGen, use a commercial software package to create your picture and then save it in one of the accepted graphics formats: bmp, gif, jpg, png, tif, black-and-white pcx, or pict (Mac only).

The screen resolution for displaying graphics is 96 dpi (Windows) or 72 dpi (Macintosh). Depending on the amount of detail in the image and the file format, the printed version of the image could be more "jaggy" or "grainy" than it appears on-screen. In this case you need to prepare a higher-resolution graphic that will print in the same space used by the screen-size graphic.

**Outline (vector) Graphics**

If you use a vector-based program, such as Adobe Illustrator, you can create the graphic and then export it as a bitmap (.bmp) with a resolution of 96 dpi to match the Windows screen resolution. To prepare a high-resolution version of the same image, export the file again and set the resolution at 150 or 300 dpi. Use a naming scheme, such as fig0301.bmp and fig0301x.bmp, to identify the low- and high-resolution files for the same image.

**Bitmap (raster) Graphics**

If you use a raster-based (bitmap) drawing program, such as PaintShop Pro®, create an image that is two or three times the desired on-screen size, and save this version as the high-resolution bitmap. Then scale or resize the graphic to the size you want for the on-screen display, and save this as the low-resolution bitmap. For example, create a graphic that is twice as large as needed, using 18- or 20-point Arial type for text and labels, and save it as the high-resolution bitmap. Reduce the image to 50% for the on-screen, low-resolution image.

**Physical Size**

Limit the physical measurement of each on-screen image to no more than 5 inches wide and 6 inches high. This is the approximate, maximum size that will fit on a printed page along with a question. Crop images to remove extra white space surrounding the actual image. Remember that having large images in online questions could require the student to scroll up and down in the window to see the full image and to read and answer the question.
**File Size and Number of Colors**

When you prepare graphics for TestGen, the size of each graphic file must be less than one megabyte (1 MB = 1000 bytes). If the image is large and the file size is larger than 1 MB, you can break the image into two or more parts to insert into the question in a side-by-side or stacked configuration.

Reducing the number of colors in your graphics to 256 or grayscale usually preserves more than enough detail, while making the file size smaller and reducing the time it takes to download images for online tests. Two-color images (black and white) usually work for simple line art, while 16 or 256 colors usually work well for more detailed images. If possible, process the images to make them web-ready before importing into TestGen. Images using 24-bit color may be too large to import.

**Setting Graphics Preferences**

During testbank editing, you can insert graphics and function plots as either text characters or transparent objects. Indicate which setting you prefer by selecting "Preferences > Application" from the Tools menu and clicking the Graphics Position tab.

Graphics and function plots inserted as text characters become part of the line of text and move along with the text if characters are inserted or deleted or if the text wraps to the next line. They affect the line spacing by aligning the bottom of the graphic with the baseline of the line of text.

Graphics and function plots inserted as transparent graphics can be placed at a static location and remain in the background so you can type over and around the image to place labels or other information.

**Positioning and Editing Transparent Graphics and Function Plots**

When you insert a graphic or function plot as a transparent object, it is automatically placed in the upper-left corner of the field where you inserted it, at coordinates (0,0).

*Note:* If the graphic or function plot is the only object in the edit field, you may see only the first line of it because only one line of text is visible. Press the [Enter] or [Return] key several times to add more lines to the field and display the rest of the graphic.

To reposition a transparent graphic, first select "Transparent Graphics" from the Tools menu. This displays a list of the graphics and function plots used in the current field. Select an object in the list, click the Position button, and enter new coordinates for the upper-left corner of the graphic.

*Tip:* The measurements are in pixels, so remember that an inch on-screen is approximately 96 pixels (Windows) or 72 pixels (Macintosh).
Inserting Tables

TestGen lets you insert tables into testbank and test questions—in instructions, questions, answers, explanations, and comments—as well as in page headings. To insert a table, put the cursor in an edit field and select "Table > Insert" from the Insert menu. This opens a dialog in which you can set up the table dimensions, height and width, borders and shading, and alignment.

Dimensions  Click the Dimensions tab and enter the number of rows and columns you want for the table.

Height and Width  Click the Height/Width tab and enter the minimum row height, column width, and cell padding in inches. Enter fractional widths as decimals. Height and width settings apply to all the rows and columns in the table. Table row height increases automatically when you add text that exceeds the height of the cell, but the height will never be less than the minimum row height you specify.

Cell padding adds space evenly to all four sides inside each cell to prevent text from printing too close to the cell border lines.

Borders and Shading  Click the Borders/Shading tab to select line color, pattern, and weight for table borders. You can also select fill color, pattern, and line weight for table cells.

When you insert a table, the borders and shading settings apply to all the cells in the table.

Alignment  Click the Alignment tab to set the vertical and horizontal alignment for individual table cells. Settings apply to all the cells in the table when you insert it, but you can make additional adjustments to selected cells, rows, and columns after the table is inserted using the Modify Table dialog or the justification buttons on the ruler.

Modifying Tables

To modify a table you previously inserted, select one or more cells, rows, or columns in the table. Select "Table > Modify" from the Insert menu. When the Modify Table dialog opens, click any of the tabs and change the settings for the selected parts of the table. Click OK or Apply to see the results.

To delete rows or columns from a table, or the delete an entire table, select the rows or columns, and then select "Table > Delete Cells" from the Insert menu. Make your selections and click OK or Apply to see the results.
To add one or more rows or columns to a table, put the cursor in the cell above or below where you want to add. Then select "Table > Insert Cells" from the Insert menu. Make selections on the dialog to indicate how many and where rows or columns should be inserted. Click OK or Apply to see the results.

**Aligning Tables**

Tables must reside in their own vertical space; in other words, you cannot type text on the same line as a table, outside of a table cell. However, you can align tables flush left, centered, or flush right using the justification buttons on the toolbar.
Using the Macro Editor

Instructors and testbank authors who create and edit questions on a regular basis can set up speed keys to insert often used text, graphics, graphs, templates, or expressions into test questions. Select "Macro Editor" from the Tools menu to open the Macro Editor window.

On the drop-down menu for Function Keys, select the key you want to define, from F2 through F24. (F13 through F24 correspond to Shift-F1 through Shift-F12.) In the edit box, enter the text, expression, or graphic that you want to insert when you press the named function key. For advanced expressions, use symbol palettes, expression templates, ruler, and tabs to take advantage of the full editing capabilities in the Macro Editor. In the example above, the F2 key is set up to insert the quadratic equation each time you press the F2 key while editing a question.

*Note:* F1 is reserved for TestGen Help and cannot be used as a TestGen macro key.
Using Global Style Replacement

Select "Global Style Replacement" from the Tools menu to change the base font, type size, style, and color for selected portions of all the items in a testbank or test.

First, select the check boxes in the top panel to put an "X" next to each component of the test or testbank you want to change.

Then, in the bottom panel, mark the attributes you want to change for the selected components and adjust the values as desired—font, size, and/or style. You can change one attribute at a time or make several changes at once, and you can repeat the global style replacement process as many times as desired, with different settings each time.

When you are ready, click Reformat All Matching Text. There will be a pause while the program makes the changes you requested.

Caution: Global style replacement changes the selected components in the entire testbank or test and cannot be undone with the Undo button. You can, however, repeat the global style replacement to change items back to a previous setting.

Note: If a question contains a symbol that does not exist in the font you choose for the global style replacement, TestGen uses font substitution to try to find and display the character in a different, similar font.
Setting Default Styles for Tests

TestGen, when first installed, uses predefined settings for text styles and spacing to display components of tests—instructions, questions, answers, question type headers, and explanations, for example. These settings apply to every new test you make.

To change the settings for one or more components, select "Preferences > Test Options" from the Tools menu. On the Test Options window, select the Default Styles tab.

Text Format Styles

Select a test component from the drop-down menu to view the current settings and to see a sample of the style in the panel below. Make changes using the Text Formatting toolbar. Click OK to apply the styles to the current test. Click Set as default... to apply the styles to the current test and all future tests.

The settings for question numbers, answer choice letters, question type headers, descriptors, and labels for answers, explanations, and comments take effect as soon as you click OK and close the Test Options window.
The settings for instructions, questions, and answers apply to new questions you add to the test using a template or the Insert menu, but do not affect questions that are already part of the test or questions that you transfer from a testbank. To change the fonts and styles for existing questions, select "Global Style Replacement" from the Tools menu.

Spacing

The standard amount of vertical space between questions, between questions and first answer, and between answer choices is 0.25". You can change the amount of vertical space between these items by selecting one of them from the drop-down menu or entering a new value. Click OK to apply the value to the current test and close the window. Click Set as Default... to apply the new values to the current test and all new tests you create in the future.
Setting Default Styles for Testbanks

TestGen, when first installed, uses predefined settings, called default styles, to display components of testbanks—instructions, questions, answers, descriptors, and explanations, for example. These settings for color, font, font size, text style, and alignment are used for new questions you add to testbanks during edit sessions, as well as for the display of some of the current testbank components.

To view or change the default style for one or more testbank components, select "Preferences > Testbank Options" from the Tools menu. Select the Default Styles tab on the Testbank Options window.

Select a component from the drop-down menu to view the current settings and to see a sample of the style in the panel below. Click OK to apply the styles to the current testbank.

The settings for descriptors, question numbers, and labels for answers, explanations, and comments take effect as soon as you click OK.
The settings for instructions, questions, and answers affect all the new questions you add to the testbank using a template or the Insert menu, but do not affect questions that are already part of the testbank. To change the fonts and styles for existing questions, select "Global Style Replacement" from the Tools menu.

The settings for the Level 1 heading (chapter titles) and other section headings (when available) do not show up on-screen, but are used when you print a testbank.

*Note:* The Default Styles component list contains entries for Levels 1 through 5, although individual testbanks may have fewer levels of organization, usually only 1, 2, or 3.
Starting a New Testbank

If you are a testbank author or an instructor who wants to create a new testbank, first be sure that testbank editing is enabled. Then select “New Testbank” from the File menu.

Testbank Name

When the file dialog appears, enter a filename for the new testbank. (TestGen testbank files use the file extension .BOK.) Set the location for where the testbank file will be saved—in the TestGen Testbanks folder or in another location on your hard drive.

Number of Levels

After you name the testbank file, you need to select the number of levels for the testbank.

To determine the number of levels in the testbank, decide how the testbank table of contents will be organized. The most commonly used number of levels is 1, 2, or 3. A one-level testbank would have chapter title headings with questions below each chapter heading; there would be no subheadings. A two-level testbank would have chapter title headings with subheadings below to group the questions, usually by question type.

Sample Organization for Two- and Three-Level Testbanks

A two-level testbank has (level 1) headings for chapter titles and (level 2) subheadings for the divisions or question types in a chapter. (ID view is shown.)

<table>
<thead>
<tr>
<th>Chapter 1 Analyzing Business and Technical Requirements</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multiple Choice Questions</td>
</tr>
<tr>
<td>cis 1.1-1</td>
</tr>
<tr>
<td>cis 1.1-2</td>
</tr>
<tr>
<td>True/False Questions</td>
</tr>
<tr>
<td>cis 1.2-1</td>
</tr>
<tr>
<td>cis 1.2-2</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 2 Planning a Framework for Security</th>
</tr>
</thead>
<tbody>
<tr>
<td>etc.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 2 Planning a Framework for Security</th>
</tr>
</thead>
<tbody>
<tr>
<td>etc.</td>
</tr>
</tbody>
</table>
A three-level testbank has chapter titles, followed by two levels of subheadings. This type of organization is often used for math testbanks where chapters are divided into sections that each have one or more objectives. (ID view is shown.)

Click "Create New Testbank" to confirm the number of levels and proceed to the Testbank Setup dialog.

*Note:* The number of levels for a testbank cannot be changed once a testbank is created.
Test Gen 7.4 Help

**Testbank Setup Dialog**

After you choose the number of levels for a testbank, the Testbank Setup dialog opens. You can reopen this dialog any time you are editing a testbank by selecting "Testbank Setup" from the View menu.

![Testbank Setup Dialog](image)

**Testbank Information**

In the Name box, enter the testbank title, which will appear in the title bar at the top of the testbank window. In the Abbreviation field, enter an abbreviation for the textbook title that will be used as part of the unique question ID assigned to each question in the testbank. Use eight or fewer characters for the testbank abbreviation.

TestGen uses the testbank abbreviation and the number of the levels to create the unique ID for each question. For example, the question ID "law 1.1-5" refers to question 5 in section 1 of chapter 1 of the testbank abbreviated as "law."

*Note:* The first number in a question ID usually matches the number of a textbook chapter, but the number could be different if additional "chapter" headings, such those for appendices or supplementary chapters, are inserted between standard numbered chapters.

**Default Text and Automatic Numbering in Headings**

This section of the setup window lists the number of levels in the testbank. Each level can be set to display default text and automatic numbering before titles or subheadings. For example, the default text in the Prefix box might be "Chapter," "Unit," or "Module" in front of the automatic number for each main heading in the testbank. Type the text you want to precede each level of heading, or remove the default text from the Prefix box.

To use automatic numbering, use `<L1#>` as a placeholder to represent the "Level 1 number", `<L2#>` to represent the "Level 2 number", and so on. Setting the Level 1 prefix as "Chapter `<L1#>`" automatically prints the word "Chapter" and sequentially numbered chapter numbers in front of chapter titles. Setting the Level 2 prefix as " `<L1#>.<L2#>` " automatically numbers the subheadings as 1.1, 1.2, and so on. If you add, delete, or rearrange chapters or sections, the automatic sequential numbering changes based on the new table of contents or outline.

In rare instances, you may need to begin numbering chapter titles or sections with a number other than 1. To adjust the starting number, insert "+" or "-" and a number after the # sign inside the brackets. For example, to make the first chapter "Chapter 0" instead of "Chapter 1," enter "Chapter `<L1# -1>`" for the Level 1 prefix in the Testbank Setup dialog.

**Note:** Do not type the chapter or section titles in the Prefix boxes, because you will enter them in the testbank window, after the Testbank Setup dialog closes.

In some cases, automatic numbering may be unsuitable for a particular testbank. In these cases, the prefix and automatic numbering can be removed from the prefix field, and nonstandard numbering can be included as part of the chapter or section titles.

**Add to Testbank Library**

Select Yes or No to indicate whether or not you want the new testbank to be listed in the Testbank Library. If you choose Yes, the testbank file resides on disk at the location where you created it, and the testbank title appears in the Testbank Library for easy opening. If you choose No, the testbank file resides on disk at the location you specified when you created the new file, but the book title is not listed in the Testbank Library.

**Modifying Titles**

When you click OK on the Testbank Setup dialog, the new testbank window opens. The testbank window contains a heading for each level you defined in the Testbank Setup dialog, including prefixes and numbers. Click the plus (+) sign at the left of main headings to display subheadings. To edit any of the main headings or subheadings, simply click on the title you want to edit, and then click in the text editing field. Modify the text as needed.

**Adding Content to Questions**

The first question in a new testbank is a "dummy" question that serves as a placeholder until you add text to it. Click in the question field and type the question. Type the answer or answer choices, depending on which type of question you want. To change the question to another question type, select the question by clicking just to the left of the question number so the background changes color. Then select "Change Question Type" from the Question menu. Select the new question type from the drop-down menu and click OK. Continue to edit the question, answer(s), and question properties as needed.

For information about adding more questions, see the "Modifying Testbanks" section.
Adding More Chapters or Sections

For information about adding additional chapters or sections within a chapter, see the "Modifying Testbanks" section of Editing Testbanks.
TestGen Tools

Checking Spelling for Tests and Testbanks

You can open TestGen's built-in spell checker by selecting "Spell Check" from the Tools menu. At the top of the dialog, choose whether you want to check only what is selected or all parts of the test or testbank.

Click the Options button to select the elements you want to check—questions, answers, instructions, descriptors, titles, and other parts of the testbank.

Click the Start button to begin looking for spelling mistakes. Misspelled words appear one-by-one along with suggestions for the correct spelling when available. Select any of the suggestions to place it in the "Change to" area and click the Replace button to replace the misspelled word. To replace all occurrences of the word found in the test or testbank, click Replace All.

If the spell checker finds a word that you want to leave "as is," but you do not want to find it again or add it to your user dictionary, then click the Skip button.

If there is a word that is spelled correctly but the spell checker does not recognize it, click the Learn button to add the word to your user dictionary.

Click Done to close the spell checker.
Using Find and Replace

Select "Find and Replace" from the Edit menu to look for or replace text in a testbank or test. At the top of the dialog, click a button to check only what is selected or the entire test or testbank. Click the Options button to limit which elements to check during the Find operation.

When the target word or phrase is found, the context window at the bottom of the Find and Replace window gives the location and a portion of the text that contains found words or phrase. The location gives the abbreviation for the testbank name, a chapter number, a section number (if applicable), and the question number. For example, "soc 2-34" indicates the "soc" (abbreviation) testbank, chapter 2, question 34.

When the target word or phrase is found, you can click a button to Replace the found text with the text that is in the Replace field, Skip the found text and go to the next instance of it, or Replace All instances of the found text in the set of questions you are checking.

The Status message at the bottom changes as the process continues to check the questions, answers, or other options you have selected in the Options dialog.

When the process is complete, the status message at the bottom of the Find and Replace window says "Done searching."
Setting TestGen Preferences

The following settings let you customize your version of TestGen according to your needs. To change these settings, select "Preferences > Application Preferences" from the Tools menu. This opens the TestGen Preferences window.

File Locations

To set default locations for opening and saving testbanks and tests, click the File Locations tab. Type or browse to the location where you want TestGen to look the first time you open or save a testbank or test during a session. The default location for Testbank and Tests folders is inside the TestGen folder in your user's Documents folder.

Graphics Position

When you insert a picture (graphic) into a testbank or test question, the graphic can be inserted as a text character or as a transparent object. The same applies to function plots created with TestGen's graphing tool. You can select one of these as a global attribute for graphics and plots by selecting "Preferences > Application" from the Tools menu and clicking the Graphics Position tab.

Insert Graphics as Text Characters

Choose this option if you want graphics and plots to be inserted as text characters, so they become part of the paragraph of text and can be positioned in the same way as other text. The image moves if spaces, tabs, or carriage returns are inserted or deleted before the graphic. No text can print in the same space as the graphic or plot.
Insert Graphics as Transparent Objects

Choose this option if you want graphics and plots to be imported as transparent objects so you can type text characters in the same space as the graphic. The text you type overprints the transparent image. The image will not move when spaces, tabs, or carriage returns are added to the text.

The upper-left corner of a transparent graphic is positioned, initially, at the upper-left corner (0,0) of the field in which it is inserted. To reposition a transparent graphic, select “Transparent Graphics” from the Tools menu. Choose the graphic you want to move, and then click the Position button. This opens a dialog in which you can enter different values for the location of the upper-left corner of the graphic, causing it to move in the field. (See the Managing Graphics section for more information.)

Ask Every Time

Click this choice if you do not want to have a global setting for how graphics and plots should be inserted and want to decide on the positioning each time you insert one into a question.

Transfer Options

Several settings related to the order of multiple-choice answer choices and the use of preassigned workspace are on the Transfer Options tab of the Application Preferences dialog.

Scramble Answer Choice Order When Transferring Questions

Your choice here determines whether or not the answer choices for multiple-choice (and bimodal) questions are scrambled when you transfer questions from a testbank to a test.

If you choose to scramble on transfer, the order of the answer choices for a question on a test, most likely, will be different from the order of the choices shown in the testbank, and the letter of the correct answer will change accordingly. Answer choices such as “all of the above” or “Both A and B” that are pinned, will never change to a different position when you transfer questions to a test.

If you choose not to scramble on transfer, the answer choices for questions transferred to a test remain in the same order as in the testbank.

Display Preassigned Workspace on Tests

Some (but not all) testbank questions have workspace values that were assigned by testbank authors when the testbank questions were written. To see the amount of preassigned workspace allowed for each question, display the workspace descriptor below each question. These values are numbers that indicate how many lines of blank space should be allowed after a question if the student is expected to show work or write longer answers on the test page.

Your choice in this section of the Transfer Options dialog determines whether the preassigned workspace is displayed on a test when you transfer questions from a testbank to a test.

Note: If you select to display workspace when transferring questions to a test, the questions that do not have preassigned workspace will have only the standard amount of vertical space between questions.

Note that on tests, whether or not you choose to display preassigned workspace, you can always modify the amount of workspace below any question by clicking in the blank area and pressing Enter (or return) to add lines or the Backspace or Delete key to remove lines.
**Number Formatting**

Select the Number Format tab to view or change settings related to how algorithmically generated numbers should be displayed.

*Note:* This setting does **not** affect static numbers or variable numbers created on the Variable Definition worksheet.

**Digit Grouping Symbol**

Insert a comma (,) to set off every three digits in a number larger than 999.

Leave the field blank if you want a blank space to set off every three digits in numbers larger than 999.

**Decimal Symbol**

Enter a period (.) to separate the whole number and the decimal portion of a number.

**Start Grouping at Ten Thousands Place**

Check this box to use a digit grouping symbol only when numbers are larger than 9999. This means that four-digit whole numbers will not display any digit grouping (e.g., 4000 rather than 4,000).

**Show Grouping After Decimal Point**

Check this box to display the digit grouping symbol in digits to the right of the decimal point.

**Testbank Editing**

The setting on the Testbank Editing tab determines whether or not you will be able to modify the content of testbanks you have downloaded to your computer or put in the Testbank Library. Testbank editing provides additional tools for authoring and modifying test items—the ability to assign and change properties, instructions, testbank display, and more.


**Resetting TestGen Defaults**

If at any time you would like to restore all of TestGen's original settings, select "Reset TestGen" from the Tools menu. This will affect a number of settings and preferences for tests and testbanks, including, but not limited to:

- default locations for saving TestGen tests and testbanks,
- transfer preferences,
- question and answer display,
- number formatting,
- default text styles,
- page header and footer defaults,
- question type headers,
- graphics positioning,
- availability of testbank editing,
- toolbar display preferences.

Resetting TestGen does NOT reset or change your password.
Using Keyboard Shortcuts

Many of the options on TestGen menus and buttons have shortcuts to provide faster access to each function. Some keyboard shortcuts, such as those using the Alt key and the Ctrl key are specific to the computer operating system.

Windows Shortcuts

You can use the Alt key as a shortcut to display TestGen application menus. When you press the Alt key and then the underlined letter in the name of the menu, the menu opens to display the choices. Once a menu is displayed, activate any option on the menu by typing its underlined letter, if available, or select an item using the mouse. For example, to insert a question on your test, display the Insert menu by pressing the Alt key and typing I. Next, type Q because it is the underlined letter for that menu item. Press the Esc key to close the menu.

When using Windows, you may press F1 to access Help and Alt F4 to exit the program. You may use the Delete key to permanently delete the selected chapters, sections, or questions from a testbank, or to delete the selected questions from a test.

Windows and Macintosh Menu Shortcuts

The following letters, in combination with the Ctrl key (Windows) or the Apple/Command key (Macintosh), perform these menu functions.

<table>
<thead>
<tr>
<th>Ctrl A - Select All</th>
<th>Ctrl I - Italic</th>
<th>Ctrl O - Open</th>
<th>Ctrl V - Paste</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl B - Bold</td>
<td>Ctrl J - Jump</td>
<td>Ctrl P - Print</td>
<td>Ctrl W - Close</td>
</tr>
<tr>
<td>Ctrl C - Copy</td>
<td>Ctrl K - Collapse All</td>
<td>Ctrl R - Recalculate</td>
<td>Ctrl X - Cut</td>
</tr>
<tr>
<td>Ctrl E - Expand selection</td>
<td>Ctrl L - Spell Check</td>
<td>Ctrl S - Save</td>
<td>Ctrl Y - Redo</td>
</tr>
<tr>
<td>Ctrl F - Find/Replace</td>
<td>Ctrl N - New Test</td>
<td>Ctrl U - Underline</td>
<td>Ctrl Z - Undo</td>
</tr>
</tbody>
</table>

PgDn / PgUp - Move to next/previous page of a test or screenful of questions in a testbank

F1 - Shortcut for Help (Windows only)

Shortcuts While Editing

F2, ..., F12
Shift F1, ..., Shift F12

Insert text, symbols, expressions, graphics as defined in the Macro Editor

Contextual Right-Click Menus

Many of the work areas and editing fields in TestGen have contextual menus that you access by clicking the right mouse button (Windows). When you right-click an object or area, a pop-up menu displays options that are most appropriate for the current area or activity. Use the mouse to select an action from the pop-up menu and close the menu.
# Error Messages for Export and Save

When you export or save a test, you might one or more messages that alert you to potential problems with the test. These alerts usually mean that one or more questions or answers contain data that is not accepted by the target platform or will cause problems when students try to enter an answer. If you see an error report, note the question numbers, return to the test to make changes, then repeat the export or save action.

<table>
<thead>
<tr>
<th>Error Message</th>
<th>Explanation or Solution</th>
</tr>
</thead>
<tbody>
<tr>
<td>Answer length exceeds limit of 2000 characters. Please edit to avoid truncation on import.</td>
<td>The answer is too long for the target platform. You need to shorten the answer for the question.</td>
</tr>
<tr>
<td>Answer field for this question is empty. Please add an answer in order for software to evaluate student answer.</td>
<td>Edit the question in TestGen so that it has an answer.</td>
</tr>
<tr>
<td>Answer contains information that cannot be entered or evaluated in target delivery mode.</td>
<td>The question contains HTML content, such as a symbol or graphic or a non-Latin-1 international character that cannot be entered by the student. Discard or revise question to allow for student input using TestGen symbols.</td>
</tr>
</tbody>
</table>
| Question contains graphic that will not display properly in target delivery mode. | Question contains a transparent graphic that is not enclosed by a "grouping" template. Image will be lost on conversion to HTML.  
To alter the question so that the graphic exports, replace the transparent graphic with an empty grouping template, using Enter keypresses to make the box large enough to contain the graphic. Select the graphic from the graphics library, and re-insert the graphic as a transparent graphic into the grouping box. Also copy any overlying text into the box. Delete the original transparent graphic from the problem using "Edit Transparent Object" from the Tools menu. |
| Answer may need more information to be evaluated properly by the software. | Answer might be missing, too long (over 60 characters), involve math expressions, or contain key trigger phrases, such as "answers will vary." Review the question's answer and modify as needed so that students can input the answer. |
| Question points will not be retained in target delivery mode | Assigned point values for questions will be lost on export since they are not supported by the target platform. All questions have equal value. |
| Multiple choice and bimodal questions must contain at least two answers. | Multiple choice or bimodal questions contain one or no answer choices. Edit as needed to provide at least two choices. |
| Alert. This question could not be formatted for online display. | Question type is not supported in target delivery mode and empty placeholder question will be exported in its place, unless corrected. Remove offending items from the test. |
| Not supported by TestGen plug-in: Essay, Matching, and Vocabulary |
| Not supported by QuizMaster: Essay, Short Answer, Matching, and Vocabulary |
| TestGen plug-in tests may have no more than 10 answer choices for multiple-choice questions. Remove extra answer choices from this question. | Message appears when you save a TestGen plug-in (web) test and a multiple-choice question has more than 10 answer choices. |
| QuizMaster tests may have no more than 5 answer choices for multiple-choice questions. Remove extra answer choices from this question. | Message appears when you save a test for use with QuizMaster and a multiple-choice question has more than 5 answer choices. |
| This question has more than 25 answer choices. Remove extra answer choices from this question. | Message appears when you save a test (other than for use with the TestGen plug-in or QuizMaster) and a multiple-choice question has more than 25 answer choices. |
Limited Warranty

This software is warranted against defects in materials and workmanship for a period of 90 days from your receipt of the software. This limited warranty is void if the media are damaged by causes not arising from defects in materials or construction. Pearson Education does not warrant that the programs will be free from error or will meet your specific requirements. Further, Pearson Education makes these programs available on an "As Is" basis, with no express or implied warranty concerning the programs' fitness for a particular purpose.

In no event shall Pearson Education be liable to anyone for special, collateral, incidental, or consequential damages in connection with or arising from the purchase or use of the programs. The sole and exclusive liability shall not exceed the purchase price of the software. Pearson Education shall not be liable for any claim of any kind whatsoever by any other party against the user of the programs. Some states do not allow the exclusion or limitation of implied warranties or consequential damages, so the above limitations or exclusions may not apply to you in those states.

During the 90-day warranty period, defective media will be replaced when returned with proof of purchase/ownership and with return postage prepaid. The replacement software will be warranted for 90 days from the date of replacement. Other than the postage requirement, no charge will be made for the replacement. Mail defective media to:

   Pearson Education
   Higher Education Media Support
   1900 East Lake Avenue
   Glenview, IL  60025

For technical assistance,

   Phone: 1-800-677-6337 (1-800-6-PROFESSOR)
   Email: media.support@pearsoned.com

These programs are not copy protected. This doesn't mean that you can make unlimited copies of them. The programs are protected by the copyright laws that pertain to computer software. It is illegal to distribute copies of these programs without written permission from Pearson Education. In particular, it is illegal to give a copy of the programs to any other person.